Subject: Re: [eman] energy-specific efforts at IETF?

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 6 Jul 2016 13:52:48 +0200

Le 30/06/2016 à 06:49, joel jaeggli a écrit :
> On 6/28/16 8:10 AM, Romascanu, Dan (Dan) wrote:
>> Sure. But your two statements (in the first paragraph) use each of
>> the conditional 'may'. What is the reason to use YANG on the devices?
>> The SDN paradigm does not AFAIK make assumptions about using a
>> specific protocol or DML at the device management level. YANG comes
>> at a certain cost (bits on wire, memory). Maybe this is affordable,
>> or maybe YANG is needed for other reasons, but this needs to be shown
>> explicitely.
>
> Signaling presumes in some utility is derived from coordination.
>
> If I have a ten year primary battery or I'm a space probe headed to
> alpha centuri I'm not going to devote a lot of electrons to expressing
> my power consumption or battery condition.
>
> More active or particularly coordinated groups of devices such as the
> elements of a BST or a datacenter might well have information to share.

Whereas I can expect a BST (Base Station?) to be operated on chemical 
battery in emergency areas, it would be hard to imagine an entire 
datacenter on battery - wouldn't it rather be on combustion-engine 
electricity generators?

For the BST case: I will write separately.

For the datacenter: I think there would be a need for an entirely 
different MIB, different than a battery-MIB.

Alex

>
>> Regards,
>>
>> Dan
>>
>>
>>> -----Original Message----- From: Alexandre Petrescu
>>> [mailto:[email-masked]] Sent: Tuesday, June 28, 2016
>>> 5:55 PM To: Romascanu, Dan (Dan); Rolf Winter; Nadeau Thomas Cc:
>>> [email-masked] Subject: Re: [eman] energy-specific efforts at IETF?
>>>
>>> The SDN paradigm may be applied not just to switches but to
>>> smartphones. Further, a tool like CoMI (CoAP Management Interface)
>>> may make use of YANG models on IoT devices which are typically
>>> constrained on battery.
>>>
>>> Yesterday I read about an NB-IoT LPWA device from u-blox which runs
>>> on a battery for 10 years.
>>>
>>> Alex
>>>
>>> Le 02/06/2016 à 11:20, Romascanu, Dan (Dan) a écrit :
>>>> No, RFC 7577 defines an SMIv2 MIB.
>>>>
>>>> Before engaging in a discussion about 'let us do EMAN data
>>>> modelling in YANG' I would like to see a use case - i.e. an
>>>> example of an energy monitoring system that uses YANG for
>>>> reporting energy information.
>>>>
>>>> Regards,
>>>>
>>>> Dan
>>>>
>>>>
>>>>> -----Original Message----- From: eman
>>>>> [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
>>>>> Sent: Thursday, June 02, 2016 11:22 AM To: Rolf Winter; Nadeau
>>>>> Thomas Cc: [email-masked] Subject: Re: [eman] energy-specific
>>>>> efforts at IETF?
>>>>>
>>>>>
>>>>>
>>>>> Le 02/06/2016 à 10:18, Rolf Winter a écrit :
>>>>>> Is there anything that the EMAN work is not addressing or
>>>>>> that requires new protocol work?
>>>>>
>>>>> For my clarification - is the battery monitoring MIB RFC7577
>>>>> using YANG?
>>>>>
>>>>> Alex
>>>>>
>>>>>>
>>>>>> On Wed, Jun 1, 2016 at 8:00 PM, Nadeau Thomas
>>>>> <[email-masked]> wrote:
>>>>>>>
>>>>>>> Not that I know of in the form of an official working
>>>>>>> group. EMAN was
>>>>> shut down something like a year ago.
>>>>>>>
>>>>>>> --Tom
>>>>>>>
>>>>>>>> On Jun 1, 2016:8:34 AM, at 8:34 AM, Alexandre Petrescu
>>>>> <[email-masked]> wrote:
>>>>>>>>
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> Is there any other effort focusing on energy consumption
>>>>>>>> happening at
>>>>> IETF currently?
>>>>>>>>
>>>>>>>> I am interested in aspects related to energy consumption
>>>>>>>> of IP networks
>>>>> used to deliver video streams.
>>>>>>>>
>>>>>>>> Yours,
>>>>>>>>
>>>>>>>> Alex Petrescu
>>>>>>>>
>>>>>>>> Le 09/06/2015 à 05:01, Mouli Chandramouli (moulchan) a
>>>>>>>> écrit :
>>>>>>>>> Thanks to all the WG chairs for shepherding the IETF
>>>>>>>>> drafts and taking them to a conclusion. I may not be
>>>>>>>>> able to travel to Prague.  So, enjoy.
>>>>>>>>>
>>>>>>>>> Cheers Mouli
>>>>>>>>>
>>>>>>>>> From: Nadeau Thomas <[email-masked]
>>>>>>>>> <mailto:[email-masked]>> Date: Saturday, 6
>>>>>>>>> June 2015 2:22 AM To: "Benoit Claise (bclaise)"
>>>>>>>>> <[email-masked] <mailto:[email-masked]>> Cc: eman
>>>>>>>>> mailing list <[email-masked] <mailto:[email-masked]>>,
>>>>>>>>> "[email-masked]
>>>>>>>>> <mailto:[email-masked]>"
>>>>>>>>> <[email-masked]
>>>>>>>>> <mailto:[email-masked]>> Subject: Re:
>>>>>>>>> [eman] Status of the EMAN W.G. effort.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Beers are on you! 8)
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>> On Jun 5, 2015:4:46 PM, at 4:46 PM, Benoit Claise
>>>>>>>>>> <[email-masked] <mailto:[email-masked]>>
>>>>>>>>>> wrote:
>>>>>>>>>>
>>>>>>>>>> Yes, thanks to the contributors, document editors, WG
>>>>>>>>>> chairs, previous ADs :-), basically the entire EMAN
>>>>>>>>>> community. Celebration in Prague? Fine with me.
>>>>>>>>>>
>>>>>>>>>> Regards, Benoit
>>>>>>>>>>> Greetings,
>>>>>>>>>>>
>>>>>>>>>>> Now that we've crossed the milstone of having
>>>>>>>>>>> draft-ietf-eman-applicability-statement-11 move to
>>>>>>>>>>> the RFC editor
>>>>> queue,
>>>>>>>>>>> I think we can pause and reflect on the effort that
>>>>>>>>>>> has completed.
>>>>> It
>>>>>>>>>>> took a while to get here and the consensus that we
>>>>>>>>>>> built was hard
>>>>> won
>>>>>>>>>>> but I hope durable.
>>>>>>>>>>>
>>>>>>>>>>> It's my intention to close down the working group,
>>>>>>>>>>> maintaining the mailing list for a time. The
>>>>>>>>>>> mailing list archive as with other IETF mailing
>>>>>>>>>>> lists will be preserved. in the immediate sense if
>>>>>>>>>>> there is
>>>>> work
>>>>>>>>>>> around the edges of this space we have the opsawg
>>>>>>>>>>> working
>>> group
>>>>> to
>>>>>>>>>>> support such activities.
>>>>>>>>>>>
>>>>>>>>>>> Thank you again for your diligent efforts,
>>>>>>>>>>> especially the present and former chairs who
>>>>>>>>>>> shepherded this work to the point that it is at
>>>>> now.
>>>>>>>>>>>
>>>>>>>>>>> Regards Joel
>>>>
>> _______________________________________________ eman mailing list
>> [email-masked] https://www.ietf.org/mailman/listinfo/eman
>>
>
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 8 Jul 2016 14:24:34 +0200

Hello,

We have submitted a new draft describing a YANG model for the battery MIB:

https://tools.ietf.org/html/draft-petrescu-battery-mib-yang-00

How should we pursue this draft?

Alex

Le 06/07/2016 à 13:52, Alexandre Petrescu a écrit :
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eman

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 8 Jul 2016 14:31:09 +0200

Hi,

how is this different from 'smidump -f yang BATTERY-MIB', which
implements the translation defined in RFC 6643? RFC 6643 was written
to avoid manual translations and having to republish MIB modules

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 11 Jul 2016 17:17:29 +0200

We will have to check this, but for now I must say I did not know that
one could generate the YANG model simply by issuing that command.

Quickly skimming through it seems that 'smidump -f yang BATTERY-MIB'
would not add a contact address of the person who performed the translation.

Alex

Le 08/07/2016 à 14:31, Juergen Schoenwaelder a écrit :
>>>>> Sure. But your two statements (in the first paragraph) use
>>>>> each of the conditional 'may'. What is the reason to use YANG
>>>>> on the devices? The SDN paradigm does not AFAIK make
>>>>> assumptions about using a specific protocol or DML at the
>>>>> device management level. YANG comes at a certain cost (bits
>>>>> on wire, memory). Maybe this is affordable, or maybe YANG is
>>>>> needed for other reasons, but this needs to be shown
>>>>> explicitely.
>>>>
>>>> If I have a ten year primary battery or I'm a space probe
>>>> headed to alpha centuri I'm not going to devote a lot of
>>>> electrons to expressing my power consumption or battery
>>>> condition.
>>>>
>>>> More active or particularly coordinated groups of devices such
>>>> as the elements of a BST or a datacenter might well have
>>>> information to share.
>>>
>>> Whereas I can expect a BST (Base Station?) to be operated on
>>> chemical battery in emergency areas, it would be hard to imagine
>>> an entire datacenter on battery - wouldn't it rather be on
>>> combustion-engine electricity generators?
>>>
>>> For the datacenter: I think there would be a need for an
>>> entirely different MIB, different than a battery-MIB.
>>>
>>> Alex
>>>
>>>>
>>>>> Regards,
>>>>>
>>>>> Dan
>>>>>
>>>>>
>>>>>> [mailto:[email-masked]] Sent: Tuesday, June
>>>>>> 28, 2016 5:55 PM To: Romascanu, Dan (Dan); Rolf Winter;
>>>>>> Nadeau Thomas Cc: [email-masked] Subject: Re: [eman]
>>>>>> energy-specific efforts at IETF?
>>>>>>
>>>>>> The SDN paradigm may be applied not just to switches but
>>>>>> to smartphones. Further, a tool like CoMI (CoAP Management
>>>>>> Interface) may make use of YANG models on IoT devices which
>>>>>> are typically constrained on battery.
>>>>>>
>>>>>> Yesterday I read about an NB-IoT LPWA device from u-blox
>>>>>> which runs on a battery for 10 years.
>>>>>>
>>>>>> Alex
>>>>>>
>>>>>>> Before engaging in a discussion about 'let us do EMAN
>>>>>>> data modelling in YANG' I would like to see a use case -
>>>>>>> i.e. an example of an energy monitoring system that uses
>>>>>>> YANG for reporting energy information.
>>>>>>>
>>>>>>> Regards,
>>>>>>>
>>>>>>> Dan
>>>>>>>
>>>>>>>
>>>>>>>> [mailto:[email-masked]] On Behalf Of Alexandre
>>>>>>>> Petrescu Sent: Thursday, June 02, 2016 11:22 AM To:
>>>>>>>> Rolf Winter; Nadeau Thomas Cc: [email-masked] Subject:
>>>>>>>> Re: [eman] energy-specific efforts at IETF?
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>> Is there anything that the EMAN work is not
>>>>>>>>> addressing or that requires new protocol work?
>>>>>>>>
>>>>>>>> For my clarification - is the battery monitoring MIB
>>>>>>>> RFC7577 using YANG?
>>>>>>>>
>>>>>>>> Alex
>>>>>>>>
>>>>>>>>>
>>>>>>>>>> Not that I know of in the form of an official
>>>>>>>>>> working group. EMAN was
>>>>>>>>>>> Is there any other effort focusing on energy
>>>>>>>>>>> consumption happening at
>>>>>>>> IETF currently?
>>>>>>>>>>>
>>>>>>>>>>> I am interested in aspects related to energy
>>>>>>>>>>> consumption of IP networks
>>>>>>>>>>> Le 09/06/2015 à 05:01, Mouli Chandramouli
>>>>>>>>>>> (moulchan) a écrit :
>>>>>>>>>>>> Thanks to all the WG chairs for shepherding the
>>>>>>>>>>>> IETF drafts and taking them to a conclusion. I
>>>>>>>>>>>> may not be able to travel to Prague.  So,
>>>>>>>>>>>> enjoy.
>>>>>>>>>>>>
>>>>>>>>>>>> Cheers Mouli
>>>>>>>>>>>>
>>>>>>>>>>>> <mailto:[email-masked]>> Date:
>>>>>>>>>>>> Saturday, 6 June 2015 2:22 AM To: "Benoit
>>>>>>>>>>>> Claise (bclaise)" <[email-masked]
>>>>>>>>>>>> <mailto:[email-masked]>> Cc: eman mailing
>>>>>>>>>>>> list <[email-masked] <mailto:[email-masked]>>,
>>>>>>>>>>>> <mailto:[email-masked]>> Subject:
>>>>>>>>>>>> Re: [eman] Status of the EMAN W.G. effort.
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> Beers are on you! 8)
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>>> On Jun 5, 2015:4:46 PM, at 4:46 PM, Benoit
>>>>>>>>>>>>> Claise <[email-masked]
>>>>>>>>>>>>> <mailto:[email-masked]>> wrote:
>>>>>>>>>>>>>
>>>>>>>>>>>>> Yes, thanks to the contributors, document
>>>>>>>>>>>>> editors, WG chairs, previous ADs :-),
>>>>>>>>>>>>> basically the entire EMAN community.
>>>>>>>>>>>>> Celebration in Prague? Fine with me.
>>>>>>>>>>>>>
>>>>>>>>>>>>> Regards, Benoit
>>>>>>>>>>>>>> Greetings,
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> draft-ietf-eman-applicability-statement-11
>>>>>>>>>>>>>> move to the RFC editor
>>>>>>>> queue,
>>>>>>>>>>>>>> I think we can pause and reflect on the
>>>>>>>>>>>>>> effort that has completed.
>>>>>>>> It
>>>>>>>>>>>>>> took a while to get here and the consensus
>>>>>>>>>>>>>> that we built was hard
>>>>>>>> won
>>>>>>>>>>>>>> but I hope durable.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> It's my intention to close down the working
>>>>>>>>>>>>>> group, maintaining the mailing list for a
>>>>>>>>>>>>>> time. The mailing list archive as with
>>>>>>>>>>>>>> other IETF mailing lists will be preserved.
>>>>>>>>>>>>>> in the immediate sense if there is
>>>>>>>> work
>>>>>>>>>>>>>> around the edges of this space we have the
>>>>>>>>>>>>>> opsawg working
>>>>>> group
>>>>>>>> to
>>>>>>>>>>>>>> support such activities.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> especially the present and former chairs
>>>>>>>>>>>>>> who shepherded this work to the point that
>>>>>>>>>>>>>> it is at
>>>>>>>> now.
>>>>>>>>>>>>>>
>>>>>>>>>>>>>> Regards Joel
>>>>>>>
>>>>> _______________________________________________ eman mailing
>>>>> list [email-masked]
>>> _______________________________________________ eman mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/eman
>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 11 Jul 2016 17:20:30 +0200

> would not add a contact address of the person who performed the translation.

Yep, why would it. The key is automated translations in order to avoid
having to republish stuff.

/js

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 20 Jul 2016 10:40:04 +0200

> having to republish stuff.

I just noticed in the DHC WG meeting that there is this YANG Data Model 
for DHCPv6 Configuration draft-ietf-dhc-dhcpv6-yang-03

And I suspect there are already many MIBs for DHCPv6 on major platforms.

This gives some credit to the idea to lay down the smidump output in an 
Internet Draft.

Alex
PS: I am in Berlin and willing to meet talk about YANG model for battery 
MIB.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 20 Jul 2016 12:29:39 +0200

On Wed, Jul 20, 2016 at 10:40:04AM +0200, Alexandre Petrescu wrote:
> I just noticed in the DHC WG meeting that there is this YANG Data Model for
> DHCPv6 Configuration draft-ietf-dhc-dhcpv6-yang-03
> 

The BATTERY-MIB is not configuration; the IETF does not have the
resources to republish ~100 mostly read-only MIB modules rendered in
YANG. This is why RFC 6643 was created.

/js

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 20 Jul 2016 14:12:39 +0000

> -----Original Message-----
> From: eman [mailto:[email-masked]] On Behalf Of Juergen
> Schoenwaelder
> Sent: Wednesday, July 20, 2016 1:30 PM
> To: Alexandre Petrescu
> Cc: BEN HADJ SAID Siwar; Plymoth Nilsson Anders ([email-masked]);
> [email-masked]; [email-masked]; Erkki Harjula
> Subject: Re: [eman] YANG model for battery MIB
> 
> > > > We will have to check this, but for now I must say I did not know
> > > > that one could generate the YANG model simply by issuing that
> command.
> > > >
> > > Yep, why would it. The key is automated translations in order to
> > > avoid having to republish stuff.
> >
> > This gives some credit to the idea to lay down the smidump output in
> > an Internet Draft.
> >
> > Alex
> > PS: I am in Berlin and willing to meet talk about YANG model for
> > battery MIB.
> 
> The BATTERY-MIB is not configuration; the IETF does not have the resources
> to republish ~100 mostly read-only MIB modules rendered in YANG. This is
> why RFC 6643 was created.
> 
> /js
> 

I would add 'the IETF does not have the resources and there is no need to republish ...'. But I can certainly can be wrong. I am in Berlin as well, and if you want discuss, Alexandru, I am willing to do it also. 

Regards,

Dan

---

From: Andy Bierman <[email-masked]>
Date: Wed, 20 Jul 2016 23:15:41 -0700

On Wed, Jul 20, 2016 at 3:29 AM, Juergen Schoenwaelder <
[email-masked]> wrote:

> that
> for

big +1

However it would be really useful to have those converted MIB modules
available.  Perhaps the next hackathon can have a project to convert
the most relevant MIB modules to YANG and put them in github

https://github.com/YangModels/yang

> /js
Andy

---

From: Rolf Winter <[email-masked]>
Date: Fri, 22 Jul 2016 15:29:13 +0200

Great suggestion. Maybe our AD can make sure that authors of new MIB
modules will add their converted YANG modules to that repository as part of
the publishing process.

---

From: Benoit Claise <[email-masked]>
Date: Sun, 24 Jul 2016 00:12:36 +0200

On 7/22/2016 3:29 PM, Rolf Winter wrote:
> modules will add their converted YANG modules to that repository as 
> part of the publishing process.
>
We could try, but the rate of MIB modules production at the IETF slows down.

Regards, B.
>
> On 21 Jul 2016 8:15 a.m., "Andy Bierman" <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>
>     On Wed, Jul 20, 2016 at 3:29 AM, Juergen Schoenwaelder
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>         Phone: +49 421 200 3587 <tel:%2B49%20421%20200%203587>       
>          Campus Ring 1 | 28759 Bremen | Germany
>         Fax: +49 421 200 3103 <tel:%2B49%20421%20200%203103>       
>          <http://www.jacobs-university.de/>
>
>         [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>