Subject: Re: [ericas] Examples of Internet protocols not working well in emergent regions

From: Andrés Arcia-Moret <[email-masked]>
Date: Sun, 5 May 2013 21:06:19 +0200

Hello 

This is an interesting proposal. Nowadays I'm working at the International Centre of Theoretical Physics (Italy), specifically at Marconi Lab.

http://wireless.ictp.it/

At the wireless lab we're mainly interested in bringing the Internet technologies to emerging regions. So, I'll be willing to participate. 

Alejandro, I have some questions regarding your mail, so I write them between lines.

On Apr 29, 2013, at 3:59 AM, Alejandro Acosta <[email-masked]> wrote:

> Hi Arturo,
>  This is a copy/paste from the mailing list archive. I just subscribed.
>  Regarding satellite networks I can mention few things.
>  Some toughs:
> 
> - TCP spoofing increases and improves a lot satellite links. I fully
> recommend it. Very, very few problems reported when using TCP
> spoofing, mainly some https connections. But one more time, almost
> none. The improvement is over >25 %

spoofing like in the PEP approach at BT? or do you rather mean *snooping*?

> 
> - Andres Arcia (co-author of RFC 5690, on cc) has some recommendations
> in this respect since he has done several studies in this area. He
> recommends different handling of tcp acks, he has already some
> Linux-modified kernels to test. We've also gathered a lot of data and
> we can continue testing some things.
> 
> - Delay looks (and it's) impossible to improve

In what sense?

> 
> - VoIP runs ok using SIP with QoS and good tunning of g.729 (better
> than what most documents say). I don't recall the MOS but anyway it's
> very good.
> 
> - SCPC links are extremely expensive (anywhere in the world), I think
> the trend is to move to eSCPC over some VSAT technologies
> 
> - Transactional information (ATMs, Point of Sale) work just fine over
> regular VSAT (no eSCPC). Please be careful if VPNs+routing protocols
> run on this links, if so,, it's no any longer transactional.
> 
> - Let's remember that most satellite link are asymmetric.

and so, AckCC may be of use (RFC 5690). See also:
 
http://www.saber.ula.ve/handle/123456789/31038

> 
> - Regarding bandwidth I can only think in good compression
> technologies built in modems, more gzip in http.
> 
> just my two cents,
> 
> Alejandro Acosta,
> 
> 
> -----
> 
>    From: Arturo Servin <arturo.servin at gmail.com>
>    To: ericas at irtf.org
>    Date: Sun, 28 Apr 2013 22:19:04 -0300
>    List-id: "Discussion list for \"Emerging Regions Internet
> Challenges And Solutions\" \(ERICAS\) " <ericas.irtf.org>
> 
> 	Some ideas of possible challenges for the IP suite in emergent regions:
> 
> 	- Long delay networks
> 	- Low bandwidth networks
> 	- Satellite networks (which are low BW and have long delays)
> 	- Mesh wireless networks
> 	- Networks not connected all the time
> 	- Not reliable/slow backup networks (i.e. in many countries there is
> just one ISP, how can we provide multi-home for critical services using
> a not very reliable backup link, for example a satellite link, a 3/4G,
> dial-up, etc.)
> 	
> 	These are the problems that for instance, I suffer or I know people
> that do. Nevertheless I imagine there should be many more of these.
> 
> 	I imagine that a first step would be to document a set of problems on
> which we could try to solve.
> 
> 	
> Regards,
> as

-
A/A/

---

From: Alejandro Acosta <[email-masked]>
Date: Sun, 5 May 2013 19:43:47 -0430

Hi Andres,

On 5/5/13, Andrés Arcia-Moret <[email-masked]> wrote:
> Hello
>
> This is an interesting proposal. Nowadays I'm working at the International
> Centre of Theoretical Physics (Italy), specifically at Marconi Lab.
>
> http://wireless.ictp.it/
>
> At the wireless lab we're mainly interested in bringing the Internet
> technologies to emerging regions. So, I'll be willing to participate.

Good!, can you share some ideas about it?

> spoofing like in the PEP approach at BT? or do you rather mean *snooping*?

No, I meant spoofing.

>> - Delay looks (and it's) impossible to improve

I mean, satellites are about 35.000 km of distance, signal has to go
to the satellite and return to earth. Even at speed of light it takes
about 250 ms one way. This is the time that _today_ it looks
impossible to improve/eliminate,.

> http://www.saber.ula.ve/handle/123456789/31038

Thanks for pointing this out.

Regards,

Alejandro Acosta,

-- 
=====
^A.......o$