Subject: Re: [ESDS] Discovery Services Features and Functionality Survey Results

From: Ali Rezafard <[email-masked]>
Date: Wed, 15 Apr 2009 10:03:58 -0400

Dear ESDS members,

We wanted to thank the survey participants for their time and input  
into the DS requirements gathering process. The survey has concluded  
and the results are compiled. The collected responses are from three  
communities with interest in DS. We had respondents from the  
EPCglobal, AIAG, and IETF communities.

Attached is the questioner along with the results.

Best Regards,
Ali

On 4-Feb-09, at 4:53 PM, Ali Rezafard wrote:

> Dear ESDS members,
>
> As part of our collaborative efforts with EPCglobal Data Discovery  
> JRG to devise the best possible approach for Discovery Services  
> (DS), we are collecting requirements and prioritizing them, from all  
> potential end users of DS. EPCglobal has compiled a comprehensive  
> survey for the key questions and technical debates facing the end  
> users and the eventual EPCglobal Software Action Group that will  
> draft the specification.
>
> We would like to ask for some of your time and insight to better  
> understand and evaluate DS design choices. The survey is an online  
> questionnaire divided into two main sections, the Client Perspective  
> and the Resource Perspective. The first section focuses on questions  
> relating to the Client, who is doing the act of discovery. The  
> second section explores the questions facing the Resource (or  
> resource owner), who is interested in being discoverable by  
> authenticated and authorized Clients.
>
> Your answers will direct and clarify the requirements for DS and we  
> thank you in advance for your time and effort. At the end of the  
> survey we will ask for your contact information and we might contact  
> you to verify your email and authenticate your answers.
>
> Here is the link to the survey: http://www.surveymonkey.com/s.aspx?sm=es2mDxhMFOo0H7dWMch_2fZA_3d_3d
>
> Please remember to use Surveymonkey's webpage navigation buttons  
> instead of your browser's navigation. Each of your survey answers  
> are saved in a local cookie when you click the "Next" button. So you  
> could finish the survey in multiple sessions (using the same link),  
> as long as you use the same browser on the same computer and have  
> not cleared your cookies.
>
> The survey will conclude by February 27, 2009. Please feel free to  
> also discuss the questions on the ESDS mailing list.
>
> We thank you in advance for your participation and assistance.
>
> Best Regards,
>
> Ali Rezafard
>
> <DEADLINE: Data Discovery Fe.ics>
>
>
> _______________________________________________
> ESDS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/esds

---

From: Tony Rutkowski <[email-masked]>
Date: Wed, 15 Apr 2009 10:18:50 -0400

Dear Ali,

I'm curious why this work is so very narrowly focussed
on only the EPCglobal namespace.  The subject matter
encompasses many other namespaces - a number of which
are effectively competitive for the intended applications.
It seems out of character for the IETF.

best,
tony

-- 
Tony Rutkowski | Netmagic Associates LLC | Ashburn VA | mob: +1 703.999.8270

---

From: Ali Rezafard <[email-masked]>
Date: Wed, 15 Apr 2009 10:57:03 -0400

Dear Tony,

EPCglobal is one of the communities working on Discovery Services.  
This survey was carried out by EPCglobal and the ESDS community's  
input was solicited. If this were a survey developed by ESDS, then it  
would have been namespace neutral.

Thanks,
Ali

---

From: Tony Rutkowski <[email-masked]>
Date: Wed, 15 Apr 2009 11:07:28 -0400

Dear Ali,
> would have been namespace neutral.
Ah so.  They are promoting their own favorite namespace.
Makes sense.  The context wasn't immediately apparent.

It will be useful to create a generic namespace ontology for
these services and then apply the results working with all the
other organizations dipping their oars into this pond.

cheers,
tony