Subject: Addition to agenda..

From: [email-masked]
Date: Tue, 28 Mar 2000 19:14:02 -0500

A few notes..

*************

Date: Tue, 28 Mar 2000 08:13:07 -0800 (PST)
From: Dan Wing <[email-masked]>
To: KITAGAWA Takurou <[email-masked]>
cc: [email-masked]
Subject: Re: [IETF-FAX] Addition to Agenda.
In-Reply-To: <[email-masked]>
Message-ID: <[email-masked]>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
Sender: [email-masked]
Precedence: bulk
List-Archive: <http://www.imc.org/ietf-fax/mail-archive/>
List-ID: <ietf-fax.imc.org>
List-Unsubscribe: <mailto:[email-masked]?body=unsubscribe>

A few comments on this proposal:

1. E.164 -> DNS mapping works just as well as this proposal and scales
to the largest enterprise or telephone company.

EXACTLY .. THIS IS THE ENUM PROPOSAL IN THE IETF.

2. Is there supposed to be an Internet-wide authority on the
"best" offramp for everyone to use?

THIS IS THE TRIP ISSUE IN THE IPTEL WG.... 

3. Why HTTP instead of LDAP?  Because HTTP is ubiquitous?

YOU DONT USE HTTP, UNLESS YOU WANT TO HAVE THE SAME PROBLEMS THE IPP WG HAS HAD OVER THE YEARS.

THE IETF IS VERY VERY STRICT THESE DAYS ON THE USE OF HTTP IN APPLICATION PROTOCOLS.

-Dan Wing

On 28 Mar 2000 23:29 +0900, KITAGAWA Takurou wrote:

> 
> [email-masked] writes:
> 
> > Dear Colleagues,
> > 
> > A person asked me that he would like to make a presentation
> > at our meeting about Fax-Gateway issue.
> > 
> > He requests only 5 minutes, so Allocchio-san and I accepted it.
> > Before closing our meeting, he will do it.
> > 
> > I do not know if his idea is good/suitable for our wg/
> > useful or not. Because it is not based on SMTP.
> > 
> > Anyway, he promised to me that he will circulte his detailed idea
> > in our ML, sooner or later.
> > 
> > Regards,
> > --
> > Hiroshi Tamura([email-masked])
> 
> ---------------------------------------------------------------------------
> Directory Server for Internet Fax with HTTP and CGI
> 
> Abstract
> 
> A d

---

From: KITAGAWA Takurou <[email-masked]>
Date: 29 Mar 2000 10:43:33 +0900

> EXACTLY .. THIS IS THE ENUM PROPOSAL IN THE IETF.

I have mentioned about this in the previous reply, so please see it.

> THIS IS THE TRIP ISSUE IN THE IPTEL WG.... 

With TRIP, gateway providors cannot  have thier own local policies.

> THE IETF IS VERY VERY STRICT THESE DAYS ON THE USE OF HTTP IN APPLICATION PROTOCOLS.

I don't understand the reason.
Please tell me your suggesting protocol.

-- 
KITAGAWA Takurou
Graduate School of Informatics, Kyoto University
[email-masked]

---

From: Dan Wing <[email-masked]>
Date: Tue, 28 Mar 2000 23:07:18 -0800 (PST)

> THE IETF IS VERY VERY STRICT THESE DAYS ON THE USE OF HTTP IN

Yeah, but this proposal is really a layer-7 thing, in my view.  It doesn't
really involve the IETF as it doesn't do anything -- he's just looking up
a mapping of E.164 -> email address using HTTP.  Gosh, seems too much like
a non-standardizable solution to me, really!

-d

---

From: Dan Wing <[email-masked]>
Date: Tue, 28 Mar 2000 23:13:39 -0800 (PST)

> a non-standardizable solution to me, really!

[Actually, after thinking about it for another minute....]

Informational may make a lot of sense for the proposal.  The difficulty is
in describing how to find the 'correct' HTTP server with the 'correct'
information for each subscriber.  ENUM solves this straight away ("ask
your DNS server", which is expected to be configured correctly by your IS
group), but the lookup-by-HTTP proposal leaves the "how do you find the
HTTP server that knows the correct answers for you" as an open problem.  

That's hard to solve.

But, again, it's useful as an Informational RFC; something else has to
solve the more difficult problem of "how to find the HTTP server that
knows the answer for ''you''".

-Dan Wing

---

From: FUJIKAWA Kenji <[email-masked]>
Date: Wed, 29 Mar 2000 21:42:30 +0900

Dear Dan;

From: Dan Wing <[email-masked]>
Subject: Re: Addition to agenda..
Date: Tue, 28 Mar 2000 23:13:39 -0800 (PST)

> knows the answer for ''you''".

First, a user makes a contract with a certain gateway provider,
and then, is notified of directory server's addresses of the 
provider. 
Those directory servers tell gateways of the provider to the user.

Uses of gateways have to be charged, since gateways use PSTN too.
Our proposal gives a straghtforwad way for this.

Authentication will be peformed by just client's IP address,
or by SMTP with some authentication mechanism.

Regards,
---------------------------------------------------------------
FUJIKAWA, Kenji @ Grad. Sch. of Informatics, Kyoto Univ., Japan
 WWW: http://www.lab1.kuis.kyoto-u.ac.jp/~fujikawa/index-e.html
                        TEL +81 75-753-5387 FAX +81 75-751-0482
                              E-mail [email-masked]