Subject: Agena Changes

From: [email-masked]
Date: Tue, 28 Mar 2000 21:51:02 -0500

With TRIP, gateway providors cannot  have thier own local policies.

> 3. Why HTTP instead of LDAP?  Because HTTP is ubiquitous?
> 
> YOU DONT USE HTTP, UNLESS YOU WANT TO HAVE THE SAME PROBLEMS THE IPP WG HAS HAD OVER THE YEARS.
> 
> THE IETF IS VERY VERY STRICT THESE DAYS ON THE USE OF HTTP IN APPLICATION PROTOCOLS.

I don't understand the reason.

The reason is that too many applications are trying to get through firewalls by simply using http and port 80. This is now considered a big NO NO. New uses of http in applications now require a seperate scheme and port. IPP was forced to go to ipp:// xxxx etc and use port 631 for its application.

LDAP for query..its really your only choice.
Please tell me your suggesting protocol.

-- 
KITAGAWA Takurou
Graduate School of Informatics, Kyoto University
[email-masked]

> -Dan Wing

---

From: KITAGAWA Takurou <[email-masked]>
Date: 29 Mar 2000 16:16:50 +0900

> The reason is that too many applications are trying to get through firewalls by simply using http and port 80. This is now considered a big NO NO. New uses of http in applications now require a sep…

I don't think that such a change does not make firewalls more effective,
but anyway, changing scheme-name and port# in this directory server is
acceptable.

---

From: Dan Wing <[email-masked]>
Date: Tue, 28 Mar 2000 23:30:18 -0800 (PST)

On 29 Mar 2000 16:16 +0900, KITAGAWA Takurou wrote:

> > The reason is that too many applications are trying to get through
> > firewalls by simply using http and port 80. This is now considered a
> > big NO NO. New uses of http in applications now require a seperate
> > scheme and port. IPP was forced to go to ipp:// xxxx etc and use port
> > 631 for its application.
> 

Additionally, the lookup mechanism wouldn't be used between companies on
the Internet so I don't think the issue with HTTP applies (and is also why
I don't think this is really a protocol or interoperability issue between
endpoints -- but may well be an interoperability issue between, say, fax
machine manufacturers and HTTP-fronted databases).

So, I don't think HTTP is a sticking point here at all.

Richard, do you disagree?

-Dan Wing

---

From: [email-masked]
Date: Wed, 29 Mar 2000 21:47:07 +0900 (JST)

Comment as one of implementers.

> machine manufacturers and HTTP-fronted databases).

Yes.
Manufacturers always think of the interoperability, irrespective of proposals,
although it may be bad sometimes.

As a co-chair,
Anyway, shall we listen to his proposal ?

--
Hiroshi Tamura([email-masked])

---

From: Claudio Allocchio <[email-masked]>
Date: Wed, 29 Mar 2000 15:19:55 +0100

> although it may be bad sometimes.

jUST ONE PERESONAL COMMENT: http (i'D SAY web ...) TENDS TO BE VERY 
"VOLATILE" AS DATABASE SOURCE... 

> Anyway, shall we listen to his proposal ?

Of course! But I' suggest that it is then discussed with ENUM people, 
because that is the correct WG. We can of course contribute with our 
suggestions, as we are already doing, but the correct WG is not ietf-fax.

Claudio

---

From: FUJIKAWA Kenji <[email-masked]>
Date: Wed, 29 Mar 2000 23:36:19 +0900

From: Claudio Allocchio <[email-masked]>
Subject: Re: Agena Changes
Date: Wed, 29 Mar 2000 15:19:55 +0100

> because that is the correct WG. 

I made sure in the ENUM WG meeting that 
there is a case where local mapping E.164 -> URL (mail address)
is required, and that this is out of scope of ENUM WG.

The point is that ENUM is focused on global mapping 
and our proposal is focused on local mapping.

Each gateway provider will want to have his own policy
in an Internet fax envirionment.

> We can of course contribute with our 
---------------------------------------------------------------
FUJIKAWA, Kenji @ Grad. Sch. of Informatics, Kyoto Univ., Japan
 WWW: http://www.lab1.kuis.kyoto-u.ac.jp/~fujikawa/index-e.html
                        TEL +81 75-753-5387 FAX +81 75-751-0482
                              E-mail [email-masked]

---

From: [email-masked]
Date: Thu, 30 Mar 2000 09:10:01 +0900 (JST)

Dear Colleagues,

It seems that there are opposite opinions to consider it in our WG.

If you are in Adelaide and have some opinions about it,
Please comment in our meeting today.