Subject: Is the name of option "T33S" correct?

From: "Toyoda, Kiyoshi" <[email-masked]>
Date: Fri, 19 May 2000 17:39:57 +0900

Allocchio-san,

I want to test the interworking of addressing RFC2304
for promoting it to Draft Standard.
But, the minutes of Adelade meeting below said that it is 
difficult to test for many implemetors because the machine 
must support T33. I think it is misunderstanding that the 
machine must support T33 to test the interworking.

At 08.40 +0900 00-04-27, Hiroshi Tamura wrote:
>- draft-ietf-fax-faxaddr-v2-00.txt, draft-ietf-fax-minaddr-v2-00.txt
>
>Interworking is not enough, especially for /T33S issue.
>T33S conforms to ITU-T T.33(Facsimile routing utilizing the subaddress).
>It is kind of an application profile. There are fax machines
>that support T.30 SUB signal. But there are very few implementations
>about T.33. A question was raised about how to validate
>if two independent implementations interwork for addressing.
>About this question, there was an opinion it is that gateways can
>handle the specified address correctly.

The option "/T33S=" does not support T33 because "#" character 
does not be allowed in the sub-addr field as below nevertheless 
T33 must support "#" character. And we can not write multiple 
subaddresses in the sub-addr field nevertheless T33 must support 
it with "#" character.  So, I think that "/T33S=" means sub-address 
of T30. 

I would like to propose to change the name of t33-sep and T33S 
to t30-sep and T30S. 

>      qualif-type1 = "/" t33-sep "=" sub-addr
>
>   where
>
>      t33-sep = "T33S"
>
>      sub-addr = 1*( DIGIT )

>4.1 Multiple subaddresses
>
>   In case a particular service requires multiple T.33 subaddresses, and
>   these subaddresses need to be given on the same "fax-mbox", multiple
>   "fax-email" elements will be used.

Best regards,

Kiyoshi Toyoda

---

From: MAEDA toru <[email-masked]>
Date: Fri, 19 May 2000 18:59:15 +0900

Toyoda-san, Allocchio-san

 From the beginning of discussion, T33S means T.33, not SUB in T30.
Also SUB in T.30 consists of  "*" , "#" , space and numeric digits as 
defined in Table 3/T.30.

Regards,

Toru MAEDA

> >   "fax-email" elements will be used.

*****************************
Toru MAEDA
CANON Inc. OIP Technology Adv. 3
*****************************