Subject: Re: [Fecframe] Working Group Last Callondraft-ietf-fecframe-config-signaling

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Wed, 3 Mar 2010 16:22:20 -0800

Thanks for addressing these. But, I need to refresh my memory on this
draft. Also, some stuff may need revision once the framework is revised.

Which reminds me that the wglc has been running for the framework draft
since the last IETF (over two months). A revision based on the comments
already made on the draft is already overdue. Can we get a revised
version so that maybe we can eventually finalize all the work and other
drafts in fecframe?

-acbegen

> -----Original Message-----
> From: Rajiv Asati (rajiva)
> Sent: Wednesday, February 24, 2010 7:50 PM
> To: Ali C. Begen (abegen); Marshall Eubanks; [email-masked]
> Subject: RE: [Fecframe] Working Group Last
Callondraft-ietf-fecframe-config-signaling
> 
> Hi Ali,
> 
> Sorry about the delayed response. Thank you so much for your review
during the WGLC and useful
> comments. I have incorporated all of the comments in the -02 version
(attached) and answered each of
> your comment below:
> 
> 1. Very good catch. I have expanded your suggestion a bit for further
clarity as shown below:
> 
> This document does not make any assumption that the 'FEC sender' and
'Media Source/Sender'
> functionalities are implemented on the same device, though that may be
the case. Similarly, this
> document does not make any assumption that 'FEC receiver' and 'Media
Receiver' functionalities are
> implemented on the same device, though that may be the case.
> 
> 2. I think that you meant to say 'encoding format', not signaling
protocol. If so, then I agree to
> your suggestion and update the text as shown below:
> 
> Independent of what all encoding formats supported by an FEC scheme,
each instance of the FEC
> Framework must use a single encoding format to describe e.g. encode
all of the configuration
> information associated with that instance.
> 
> 
> 3.
> 
> > "Unicasted", "multicasted" should be "unicast", "multicast"
> 
> ==> Fixed.
> 
> 
> 4.
> 
> > - page 10:
> >
> > There is an editor's note, which should be removed (the note itself
> > could be kept).
> >
> 
> 'Editor's note' removed.
> 
> 5.
> 
> > - Section 4.2.2:
> >
> > Is this section suggesting/assigning/registering any new RTSP
> > parameters? If so, is there a proper way of doing it? Any IANA
> > considerations that this document needs to have?
> 
> Good point.
> 
> I have updated this section accordingly to explicitly request an
option-tag for 'FEC protection
> required'. Also updated the IANA considerations.
> 
> Do we need to include anything else?
> 
> 
> 6.
> 
> > - Section 4.2.3:
> >
> > Not sure how useful this section is. At least, the document should
> > provide the references for the mentioned specs.
> 
> 
> Agreed to the limited usefulness. Section 4.2.3 has been deleted now.
> 
> 
> > Nits:
> > - "Configuration Information" is sometimes capitalized, sometimes
not.
> > The document needs to be consistent.
> 
> Fixed.
> 
> > - Typo in page 2: "FEC scheme specifics information". Use FSSI where
possible.
> 
> Fixed.
> 
> > - Need for plural versions at the end of Section 1, i.e., multicast
> > applications, unicast applications, security considerations.
"section X"
> > should be "Section X".
> 
> Fixed.
> 
> > - Inconsistent capitalization in the numbered list on page 3.
> 
> Fixed. All capital.
> 
> > - Missing commas before and after "i.e."
> 
> Fixed.
> 
> > - Spell out "OAM" on page 4
> 
> Done
> 
> > - "provide a mean" --> "provide a means" on page 4
> 
> Fixed.
> 
> > - The capitalization of special words like "MUST, MAY, SHOULD" be
> > checked as there are many occasions where the capitalized versions
> > would probably make more sense.
> 
> Fixed.
> 
> > - Typo on page 9: "doesn't already exists"
> 
> Fixed.
> 
> > - Conclusions section can be removed.
> 
> Done.
> 
> Cheers,
> Rajiv
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
On
> > Behalf Of Ali C. Begen (abegen)
> > Sent: Monday, April 27, 2009 9:23 PM
> > To: Marshall Eubanks; [email-masked]
> > Subject: Re: [Fecframe] Working Group Last
> > Callondraft-ietf-fecframe-config- signaling
> >
> > These are my comments for this draft. I suppose due to normative
> > references, this document will have to wait for the framework and
SDP drafts anyway.
> >
> > BR,
> > -acbegen
> >
> >
> > - Page 4:
> >
> >    "This document does not make any assumption that the 'FEC sender
and
> >    receiver' functionality and the 'Media Source/Receiver'
functionality
> >    are implemented on the single device, though it may be the case."
> >
> > Should read:
> >
> > "This document does not make any assumption that the Media Sender
and
> > FEC Sender functionalities or the Media Receiver and FEC Receiver
> > functionalities are implemented on the same host, although this may
be the case."
> >
> > - page 5:
> >
> >    "Each instance of the FEC Framework muse use a single encoding
format
> >    to describe e.g. encode all of the configuration information
> >    associated with that instance."
> >
> > I believe we need to make it clear that an FEC scheme can support
> > multiple signaling protocols but it must use a single encoding
format in a particular
> > instance.
> >
> > - page 5 and beyond:
> >
> > "Unicasted", "multicasted" should be "unicast", "multicast".
> >
> > - page 10:
> >
> > There is an editor's note, which should be removed (the note itself
> > could be kept).
> >
> > - Section 4.2.2:
> >
> > Is this section suggesting/assigning/registering any new RTSP
> > parameters? If so, is there a proper way of doing it? Any IANA
> > considerations that this document needs to have?
> >
> > - Section 4.2.3:
> >
> > Not sure how useful this section is. At least, the document should
> > provide the references for the mentioned specs.
> >
> >
> > Nits:
> > - "Configuration Information" is sometimes capitalized, sometimes
not.
> > The document needs to be consistent.
> > - Typo in page 2: "FEC scheme specifics information". Use FSSI where
possible.
> > - Need for plural versions at the end of Section 1, i.e., multicast
> > applications, unicast applications, security considerations.
"section X"
> > should be "Section X".
> > - Inconsistent capitalization in the numbered list on page 3.
> > - Missing commas before and after "i.e."
> > - Spell out "OAM" on page 4
> > - "provide a mean" --> "provide a means" on page 4
> > - The capitalization of special words like "MUST, MAY, SHOULD" be
> > checked as there are many occasions where the capitalized versions
> > would probably make more sense.
> > - Typo on page 9: "doesn't already exists"
> > - Conclusions section can be removed.
> >
> >
> >
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]] On Behalf Of Marshall Eubanks
> > > Sent: Saturday, April 18, 2009 11:04 AM
> > > To: [email-masked]
> > > Subject: [Fecframe] Working Group Last Call
> > > ondraft-ietf-fecframe-config-signaling
> > >
> > > I think that this document is also ready, so I would like to issue
a
> > > working group last call on
draft-ietf-fecframe-config-signaling-01.
> > > This document can be
> > > found at
http://tools.ietf.org/id/draft-ietf-fecframe-config-signaling-01.txt
> > >
> > > I encourage everyone to read this document and comment during the
> > > last call period.
> > >
> > > This last call will end on Monday, May 4th, 2009.
> > >
> > > Regards
> > > Marshall Eubanks
> > > _______________________________________________
> > > Fecframe mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/fecframe
> > >
> > _______________________________________________
> > Fecframe mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/fecframe

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 3 Mar 2010 18:46:29 -0600

Hi Ali,

Thanks. Would appreciate your feedback.

Cheers,
Rajiv

> From: Ali C. Begen (abegen)
> Sent: Wednesday, March 03, 2010 7:22 PM
> To: Rajiv Asati (rajiva); [email-masked]'
> Subject: RE: [Fecframe] Working Group Last Callondraft-ietf-fecframe-
> config-signaling
> 
Callondraft-ietf-fecframe-
> config-signaling
all
> of the configuration
"section
> X"
On
> > > references, this document will have to wait for the framework and
SDP
> drafts anyway.
and
format
> in a particular
"section
> X"