Subject: Re: [Fecframe] Posting of IPR Disclosure related to QUALCOMM Incorporated's Statement about IPR related to draft-roca-fecframe-rs-02

From: Vincent Roca <[email-masked]>
Date: Thu, 25 Mar 2010 21:18:54 +0100

Mike,

I discover that QC just updated its previous IPR disclosure
against our I-D in:    https://datatracker.ietf.org/ipr/1288/

This disclosure refers to draft-roca-fecframe-rs-02, i.e. the
latest version where we tried to solve the potential IPR issue
as I explained to you in my previous emails (sent before the
IPR disclosure update):
http://www.ietf.org/mail-archive/web/fecframe/current/msg00636.html

So I take it as QC's official answer: the issue is not solved in
-02 version according to QC!

Since it seems I have no choice, let's put everything on the
table:

** Concerning US Patent 7,660,245:
This patent has three independent claims: 1, 16 and 18.
*All of them* are restricted to situations where different source
packets contribute to a different number of source symbols.
Unless we forgot something, we removed from our I-D all
references to this technique, which is sufficient to conclude that
version -02 cannot infringe US Patent 7,660,245.

** Concerning Patent 20100050057:
This patent has four independent claims: 1, 10, 16 and 24.
*All of them* are restricted to situations where different source
packets contribute to a different number of source symbols, so
my answer is exactly the same.

I'd like to understand. *I am doing significant efforts but
I now have the feeling this is not reciprocal.* What's wrong?
I need an answer.

Regards,

  Vincent

On 25/03/10 18:08, IETF Secretariat wrote:
> Dear Vincent Roca, Jerome Lacan, Kazuhisa Matsuzono, Mathieu Cunche, Amine Bouabdallah:
>
> An IPR disclosure that pertains to your Internet-Draft entitled "Reed-Solomon
> Forward Error Correction (FEC) Schemes for FECFRAME" (draft-roca-fecframe-rs)
> was submitted to the IETF Secretariat on 2010-03-18 and has been posted on the
> "IETF Page of Intellectual Property Rights Disclosures"
> (https://datatracker.ietf.org/ipr/1288/). The title of the IPR disclosure is
> "QUALCOMM Incorporated's Statement about IPR related to
> draft-roca-fecframe-rs-02."
>
> The IETF Secretariat
>

---

From: Stephan Wenger <[email-masked]>
Date: Thu, 25 Mar 2010 13:57:35 -0700

Hi Vincent, all,

I'm tempted to unsubscribe from the Fecframe mailing list after this post.

I'm not interested in reading a layman's interpretation of patent claims, or
their mapping against a draft.

I'm not interest in being advised of patent numbers other than those of my
employer.  I want to preserve my freedom of studying the IPR disclosures if
and when I choose, which may very well include "never".

I'm not interested in witnessing design-around attempts, even if they
include "significant efforts" of yours.

I'm certain I'm not alone in the above.

I would appreciate if you were showing just a bit more sensitivity towards
the practical needs of employees of large and small corporations.

Stephan

On 3.25.2010 13:18 , "Vincent Roca" <[email-masked]> wrote:

> _______________________________________________
> Fecframe mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fecframe

---

From: "Luby, Michael" <[email-masked]>
Date: Thu, 25 Mar 2010 18:19:49 -0700

All,
I agree with and respect Stephan's remarks, this is not the forum to discuss specific IPR.
Mike

On 3/25/10 1:18 PM, "Vincent Roca" <[email-masked]> wrote:

Mike,

Regards,

  Vincent

---

From: Vincent Roca <[email-masked]>
Date: Mon, 29 Mar 2010 15:32:01 +0200

Hello Stephan and Mike,

I think your emails deserve an answer.
Generals considerations first, and then I'll focus on
the specific point under discussion.

-- 

I'm also fed up with all these IPR issues that oblige me to
leave my primary activities all too often. I'm researcher,
not an IPR lawyer and I have no natural inclination for
these legal aspects.

That being said, I also want my work to be useful to the
whole community (within or outside of the IETF, Nokia and
QC included). From this point of view, if there's an IPR
disclosure and if I have the feeling an alternative
solution exists, I'll examine it instead of "passively
accepting" the situation. In any case be assured my
behavior is only governed by the desire to be useful to
the community.

One big difference between you and me is the fact I don't
have any legal department in charge of examining IPR
aspects. If my documents are subject of a disclosure, I
can either ignore it (as many colleagues do) or tackle
its analysis. If I want to achieve my above goal of being
useful to the community, this second option is the only
possible.

Yes, I'd like we could all work just like 30-40 years ago,
when smart people were eager to design the best possible
Internet, using the best possible techniques, just because
it was the right answer to the situation. It's  worth
remembering this heritage. It's perhaps an utopia
today, however I'm doing my best to stick with this
philosophy since I currently have the freedom to do
that.

Finally, you can find many examples of WGs going into this
kind of discussion, e.g. in the informational RFC 3669
(https://datatracker.ietf.org/doc/rfc3669/).
A few excerpts of the lessons learned:

    o  IPR claims should never be disregarded without good cause.  Due
       diligence should be done to understand the consequences of each
       claim.
[...]
    o  It's sometimes beneficial to push IPR claimants to find out what
       they think their claims cover and what their licensing terms are.

    o  Possibilities of prior art should be considered.

    o  It's all right, and sometimes beneficial, to discuss IPR claims
       and gather information about possible prior art on the group list.
       The results of such discussion can be considered when deciding
       whether to develop a technology (but remember that neither the
       IETF nor any working group takes a stand on such claims as a body,
       and the group is not the best place to get legal advice).

The above sentences are not definite rules, of course, and
each situation is specific and needs to be handled
appropriately. However saying that "[the FECFRAME mailing
list] is not the forum to discuss specific IPR" is a
personal interpretation that is in-line with the IETF
practices.

-- 

Now, concerning the topic that triggered this discussion:

- I've updated the I-D and in theory it's sufficient for
   QC to be aware of our attempts to solve the problem;
- However I explicitly told Mike what we've done and
   asked him to clarify QC's position. No answer;
- I met Mike just before the fecframe meeting and asked
   again the same question. Unless I misunderstood what he
   said, I didn't get any answer;
- the situation was once again explained in my slides.
   I was not there unfortunately, but I didn't see
   anything in the Minutes;
- And then came this new IPR disclosure that completely
   ignores any effort I've made to try understand the
   situation and to solve it.

At this point, I'm now wondering if QC's strategy is not
to leave this point open until everybody forget? Anyway,
if QC does not want to answer, I want it to be clearly
stated and justified. How long it will take me to have
this clarification is not under my control.

I'm not responsible of the whole story. Especially as
last year I even made sure that there was no IPR issue
in FECFRAME. Now DF/QC chose the submarine patent
approach ("undisclosed pending patent") and to keep it
secret till it's granted, last month.  It's their right but me
and my co-authors are the victims in this story.

Last but not least...
In all my emails exchanges, I pay attention not to offend
anybody. I don't have the feeling that any email I sent
(including this one) was offending, but if somebody has a
different feeling, then I apologize since this was not my
goal.

Sorry for this very long email. I hope that you now better
understand my attitude. Stephan, if you are not interested
by my  IPR-related emails, which I can understand, then
please  ignore them.

And long life to the IETF that already enabled me to solve
similar issues, without having to waste time, energy and
money in a court, whereas a consensus was easily achievable
as long as both parties are working toward this goal. Last
Autumn discussion with Mike on the RMT mailing list proved
it's possible. Thanks!

Best regards,

     Vincent

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 29 Mar 2010 07:31:29 -0700

Vincent,
I stand to my points.  Three more things:
1. I¹m not with Nokia IPR/legal anymore, I¹m now with a video-conferencing
company called Vidyo.  My access to legal resources here is limited.
2. I have not implied that you are out of policy, although that may also be
the case.  I have implied (and state here now directly) that the way you are
working on IPR topic is dangerous to me, to my employer, possibly to my
previous employers, and arguably to yourself.  It¹s also rude to push
information towards people who have expressed to you many times that they
are not interested in.  The reasons for that lack of interest are not your
concern. 
3. When patent numbers are involved and details of claim language are
discussed on a public mailing list, there is no such thing as ³ignoring².
One may well ³notice² (in any sense of this word you wish to tag to it).
Regards,
Stephan

---

From: "Luby, Michael" <[email-masked]>
Date: Mon, 29 Mar 2010 09:54:27 -0700

Some remarks below. (***)
________________________________________
From: Vincent Roca [[email-masked]]
Sent: Monday, March 29, 2010 6:32 AM
To: Luby, Michael
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Posting of IPR Disclosure related to QUALCOMM Incorporated's Statement about IPR related to draft-roca-fecframe-rs-02

Hello Stephan and Mike,

--

*** There is IPR disclosures on many specifications within the IETF, and the standards in which they exist are useful to the whole community.  Your premise is flawed, and thus much of the reasoning below.

*** Much of the best technology used on the Internet has/had IPR, including Reed-Solomon codes, all video codecs, etc.

--

*** You got an answer, which I'll repeat here: the one issue that we discussed previously was addressed, but there are other issues which we have identified that still need to be considered and addressed.

*** The main change to the new IPR disclosures (and we updated them all in RMT and FECFRAME, not just this one) compared to previous is the licensing terms, that rationally should put the whole issue to rest.  Clearly, this didn't mollify you, as it seems that any IPR, even if the licensing terms are quite quite favorable, is unacceptable in your opinion.  However, during the course of the IPR update process, we did reexamine the spec and understood that there were still some technical issues with the current draft that probably would have to be changed to be clear of the particular IPR that is declared on the current draft.  If I remember correctly, you also mentioned that you would be adding some new elements to the next version of the draft, and be aware and forewarned that these will also have to be carefully scrutinized, as part of our obligations, to see if there is any necessity to declare additional IPR. 

*** This is not nor ever has been QC strategy.

*** It was not a submarine patent, and it is dangerous to allege this.

Last but not least...

*** Nothing was achieved in RMT in my opinion.  That was a huge waste of time and energy in my opinion to try and resolve the situation, and didn't achieve anything, as still it is the case that QC has declared IPR on some of your drafts and you have declared loudly and publicly in many forums that this is not the case.  How is that a good resolution?

Best regards,

    Vincent

On 26/03/2010 02:19, Luby, Michael wrote:
All,
I agree with and respect Stephan’s remarks, this is not the forum to discuss specific IPR.
Mike

Mike,

Regards,

  Vincent