Subject: Re: [Fecframe] DISCUSS and COMMENT: draft-ietf-fecframe-sdp-elements

From: "David Harrington" <[email-masked]>
Date: Fri, 24 Sep 2010 09:28:01 -0400

Hi,

I see you are on top of most of the comments and DISCUSSes already.
Great!
I agree with publishing an update so they can clear if they want.

dbh

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Ali C. Begen (abegen)
> Sent: Thursday, September 23, 2010 2:17 AM
> To: Jari Arkko
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: RE: DISCUSS and COMMENT: draft-ietf-fecframe-sdp-elements
> 
> I am holding onto the revision until I hear from all the 
> members. Then a revision will be on its way.
> 
> Cheers, acbegen.
> 
> > -----Original Message-----
> > From: Jari Arkko [mailto:[email-masked]]
> > Sent: Thursday, September 23, 2010 2:15 AM
> > To: Ali C. Begen (abegen)
> > Cc: [email-masked]; [email-masked]; 
> > [email-masked]; draft-ietf-fecframe-sdp- 
> > [email-masked]
> > Subject: Re: DISCUSS and COMMENT: draft-ietf-fecframe-sdp-elements
> > 
> > That was fast! Is there a new draft already so that I could clear?
> > 
> > Jari
> > 
> > Ali C. Begen (abegen) kirjoitti:
> > >
> > >> -----Original Message-----
> > >> From: Jari Arkko [mailto:[email-masked]]
> > >> Sent: Thursday, September 23, 2010 1:41 AM
> > >> To: [email-masked]
> > >> Cc: [email-masked]; [email-masked]; 
> > >> [email-masked]
> > >> Subject: DISCUSS and COMMENT: draft-ietf-fecframe-sdp-elements
> > >>
> > >> Discuss:
> > >> Please correct the use of ', |, HT from the ABNF, and remove
any 
> > >> duplication.
> > >>
> > >
> > > Already did.
> > >
> > >
> > >>> If the FEC scheme does not require any specific 
> information, the 
> > >>> 'ss-fssi' and 'fssi' parameters MAY be null and ignored.
> > >>>
> > >> The ABNF allows both leaving these constructs out completely,
or 
> > >> specifying them without any elements. Which one, or 
> either one do 
> > >> you mean here? Please clarify.
> > >>
> > >
> > > I think the following change will fix this (section 4.5):
> > > sender-info = element *( ',' element )
> > >
> > > And in the text, we will say if there is not fssi info, 
> the construct will not appear.
> > >
> > >
> > >> Capitalization of udp/fec needs to be consistent throughout the

> > >> spec.
> > >>
> > >
> > > OK will check again.
> > >
> > >
> > >> Comment:
> > >> These issues came up in a review by Ari Keranen:
> > >>
> > >> 4.5. Repair Flows
> > >>
> > >>          sender-info = [ element *( ',' element ) ]
> > >>
> > >> Shouldn't use "'" character in ABNF (same problem in multiple 
> > >> places)
> > >>
> > >
> > > I guess it should be:
> > > 	sender-info = [ element *( "," element ) ]
> > >
> > >
> > >>          separator   = "(" | ")" | "<" | ">" | "@"
> > >>                        | "," | ";" | ":" | "\" | <">
> > >>                        | "/" | "[" | "]" | "?" | "="
> > >>                        | "{" | "}" | SP | HT
> > >>
> > >> Should use "/" instead of "|" for alternatives. Should use
"HTAB"
> > >> instead of "HT"?
> > >>
> > >
> > > Yes, fixed it already.
> > >
> > >
> > >> Rules element, name, token, value, and separator are 
> defined twice.
> > >>
> > >
> > > Will remove the second copies.
> > >
> > >
> > >>     If the FEC scheme does not require any specific
> > >>     information, the 'ss-fssi' and 'fssi' parameters MAY 
> be null and
> > >>     ignored.
> > >>
> > >> By "be null" do you mean "not exist" or something else?
> > >>
> > >
> > > I will revise this as I described above.
> > >
> > >
> > >> 6.1. One Source Flow, One Repair Flow and One FEC Scheme
> > >>
> > >>          m=application 30000 udp/fec
> > >>
> > >> change "udp/fec" into "UDP/FEC" to be consistent with sec 4.1.
> > >>
> > >
> > > Will do.
> > >
> > > Thanks.
> > > -acbegen
> > >
> 
>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Fri, 24 Sep 2010 06:36:20 -0700

Sure, I fixed all the issues except the one related to IANA registration and for that I sent an email to IANA, waiting for their response.

-acbegen

> From: David Harrington [mailto:[email-masked]]
> Sent: Friday, September 24, 2010 9:28 AM
> To: Ali C. Begen (abegen); [email-masked]
> Cc: [email-masked]; [email-masked]