Subject: Re: [Fecframe] Fwd: I-D Action:draft-ietf-fecframe-rtp-raptor-04.txt

From: Colin Perkins <[email-masked]>
Date: Wed, 1 Dec 2010 18:33:56 +0000

Thomas,

I've just (very quickly) read the -04 draft. Some comments from an RTP perspective:

- Section 4.1: explain how the RTP payload type is chosen (dynamic assignment) and signalled using SDP.

- Section 4.1: explain how the SSRC is assigned, and how the repair RTP session is associated with the source RTP session using RTCP. They should probably be sent as separate RTP sessions, using RTCP CNAME to align, but this somewhat depends on whether the FEC is systematic or not.

- Section 5: "Applications that use this media type" is not specified.

- Section 10: the SDP is incorrect: RTP/AVT on the m= line should be RTP/AVP and the fmt is not specified.

- Section 10: is the grouping using FID mandatory, or an example of how it can be done?

- Section 9 should probably give many more details on how the RTP headers are constructed, and how the repair flow and source flows are associated. It seems somewhat light.

Cheers,
Colin

On 25 Nov 2010, at 19:45, Thomas Stockhammer wrote:
> Experts,
> 
> we also have reactivated draft-ietf-fecframe-rtp-raptor-04. Highlights of the changes compared to -03
> - Update of authors
> - Alignment with draft-ietf-rmt-bb-fec-raptorq-04
> - Alignment with draft-ietf-fecframe-raptor-03
> - Alignment with draft-ietf-fecframe-11
> - Some minor editorial updates
> - Updates of references
> - A significant amount of comments from Ali are integrated in the revised version. Non-implemented comments were resolved offline with Ali
> - Some small comments from Mike Luby on terminology are integrated.
> 
> Thanks to Ali and Mike.
> 
> I think it is time to get this out of the queue. 
> 
> The document should also be forwarded to AVT once we have a stable version.
> 
> Thanks and Best regards and Happy Thanksgivings ...
> 
> Thomas
> 
> 
> Begin forwarded message:
> 
>> From: [email-masked]
>> Date: November 25, 2010 8:30:01 PM GMT+01:00
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: [Fecframe] I-D Action:draft-ietf-fecframe-rtp-raptor-04.txt
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the FEC Framework Working Group of the IETF.
>> 
>> 
>> 	Title           : RTP Payload Format for Raptor FEC
>> 	Author(s)       : M. Watson, T. Stockhammer
>> 	Filename        : draft-ietf-fecframe-rtp-raptor-04.txt
>> 	Pages           : 25
>> 	Date            : 2010-11-25
>> 
>> This document specifies an RTP payload format for Forward Error
>> Correction /(FEC) repair data produced by the Raptor FEC schemes.
>> Raptor FEC schemes are specified for use with the IETF FEC Framework
>> which supports transport of repair data over both UDP and RTP.  This
>> document specifies the payload format which is required for the use
>> of RTP to carry Raptor repair flows.
>> 
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-fecframe-rtp-raptor-04.txt
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> Below is the data which will enable a MIME compliant mail reader
>> implementation to automatically retrieve the ASCII version of the
>> Internet-Draft.
> <Mail Attachment>
>> _______________________________________________
>> Fecframe mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/fecframe
> 
> ---
> Dr. Thomas Stockhammer (CEO) || [email-masked] || phone +49 89 978980 02 || cell +491725702667 || http://www.nomor-research.com
> Nomor Research GmbH  -  Sitz der Gesellschaft: München - Registergericht: München, HRB 165856 – Umsatzsteuer-ID: DE238047637 - Geschäftsführer: Dr. Thomas Stockhammer, Dr. Ingo Viering.
> 
> 
> 
> 
> _______________________________________________
> Fecframe mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fecframe

-- 
Colin Perkins
http://csperkins.org/

---

From: Greg Shepherd <[email-masked]>
Date: Thu, 9 Dec 2010 09:47:47 -0800

Thanks everyone!

Thomas,

Can you update the draft to reflect the list feedback? Once you do we
can take the draft to WGLC and move it along. We're getting close
folks!

Thanks,
Greg

On Wed, Dec 1, 2010 at 10:33 AM, Colin Perkins <[email-masked]> wrote:
> - Section 4.1: explain how the SSRC is assigned, and how the repair RTP
> session is associated with the source RTP session using RTCP. They should
> probably be sent as separate RTP sessions, using RTCP CNAME to align, but
> this somewhat depends on whether the FEC is systematic or not.
> - Section 9 should probably give many more details on how the RTP headers
> are constructed, and how the repair flow and source flows are associated. It
> seems somewhat light.
> Cheers,
> Colin
>
>
> - A significant amount of comments from Ali are integrated in the revised
> version. Non-implemented comments were resolved offline with Ali
> Dr. Thomas Stockhammer (CEO) || [email-masked] || phone +49 89 978980
> 02 || cell +491725702667 || http://www.nomor-research.com
> Nomor Research GmbH  -  Sitz der Gesellschaft: München - Registergericht:
> München, HRB 165856 – Umsatzsteuer-ID: DE238047637 - Geschäftsführer: Dr.
> Thomas Stockhammer, Dr. Ingo Viering.
>
>
>