Subject: [forces] xml definition issues that need to be discussed

From: Kentaro Ogawa <[email-masked]>
Date: Tue, 08 Mar 2011 14:49:02 +0900

Hi, All

Through the interop test, I and Ming discuss about xml definition of
data type of IPv4NetMask, component ID=2 in Portv4AddrInforType.

We agree that it's appropriate to change the definition
from
             <component componentID="2">
                <name>IPv4NetMask</name>
                <synopsis>IPv4 net mask length</synopsis>
                <typeRef>uint32</typeRef>
             </component>
to
             <component componentID="2">
                <name>IPv4PrefixLen</name>
                <synopsis>IPv4 net mask length</synopsis>
                <typeRef>uchar</typeRef>
             </component>

because to unify the style with other data types.
How about reflecting the change to LFB-lib04 draft?

cheers,
Ken

---

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 8 Mar 2011 07:38:53 -0500

Hi Ken,

Yes - that makes sense.
Note  that IPv4NetMask is still defined in BaseTypeLibrary and
the Portv4AddrInforType is the only place it is used. It may make
sense to still leave it defined since a netmask is a useful definition
to have.

I have  many comments on LFBlib that i was waiting for the
interop to complete before starting any discussion - should i start posting?

cheers,
jamal

On Tue, Mar 8, 2011 at 12:49 AM, Kentaro Ogawa
<[email-masked]> wrote:
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces
>

---

From: Kentaro Ogawa <[email-masked]>
Date: Wed, 09 Mar 2011 13:38:36 +0900

Hi Jamal,

I think we can start the discussion because ongoing interop
may not occur the new issue affecting to the LFB definitions.

cheers,
Ken