Subject: [forces] Fw: LFBlib readability suggestions

From: "Wang,Weiming" <[email-masked]>
Date: Wed, 27 Apr 2011 21:28:40 +0800

I'm fraid theres something unusal happened again with the mail system, so post again.

thanks,
Weiming

----- Original Message ----- 
From: "Wang,Weiming" <[email-masked]>
To: "Chuanhuang Li" <[email-masked]>; "Haleplidis Evangelos" <[email-masked]>; <[email-masked]>
Cc: "'Joel M. Halpern'" <[email-masked]>; "'wmwang'" <[email-masked]>
Sent: Wednesday, April 27, 2011 1:33 PM
Subject: Re: [forces] LFBlib readability suggestions

> Hi  Evangelos and Jamal,
> 
> There are several changes since 03 version on the LFB description section. Attached is the latest text that I'v been maintaining. Pls use this text as your base text to make  the modification. 
> 
> I'l incorparate every LFB description text since it has been made consensus by the list.
> 
> Another suggestion is, Evangelos, pls make a title with the LFB name for every text modification so that we can trace the discussions easily. 
> 
> thanks a lot.
> Weiming
> 
> ----- Original Message ----- 
> From: "Chuanhuang Li" <[email-masked]>
> 
>> Hi, Evangelos
>>     
>>    When you are reorganizing the draft content, and if there is contradiction between 
>> text and the latest XML which i had post on list before, please use the XML as guidance.
>> This is because after draft-03, we had discussed some contents and reached some consensuses.
>> And I think maybe Weiming has the latest draft contents text.
>> Thanks!
>> 
>> Yours,
>> Chuanhuang
>> 
>> ======= 2011-04-27 04:58:08 Haleplidis Evangelos, wrote: =======
>> 
>>>Greetings to all,
>>>
>>>After Jamal's suggestion I took his initiative and completed the etherphycop
>>>definition.
>>>
>>>Please take a look and comment, in the meantime I'll start working on the
>>>EtherMacIn.
>>>
>>>About Jamal's comments:
>>>
>>>XXX: It may make sense to have each of Components, Capabilities and Events
>>>on its own section?
>>>
>>>I think it is more readable this way and also following the same format as
>>>the model RFC provides consistency.
>>>
>>>XXX: I copied this from the draft but i think it may be wrong. The xml says
>>>this component is read-only. And i remember we had a very long discussion
>>>(refer to how one would map a port name to the PHY on how this ID is to be
>>>used).
>>>
>>>Well, even the text says that: " is defined so the CE can assign an ID ".
>>>Since the CE can assign the ID then it must be read-write. I think we should
>>>change it in the XML.
>>>
>>>XXX: Should we be discussing all the components, capabilities and events?
>>>i.e why the brief description below? Either that or the XML synopsis needs
>>>to be a lot more descriptive.
>>>
>>>I think we should be discussing ALL components/capabilities/events.
>>>It's more readable this way. Someone not familiar with xml may want to read
>>>and understand in this way of reading instead of looking around in the xml.
>>>
>>>Also there is a typo in the xml definition of the EtherPhyCop. In the
>>>synopsis of the DuplexModeChanged there is a "speed." in the end that is not
>>>supposed to be there.
>>>
>>>Regards,
>>>Evangelos Haleplidis.
>>>
>>>> -----Original Message-----
>>>> From: [email-masked] [mailto:[email-masked]] On
>>>> Behalf Of Jamal Hadi Salim
>>>> Sent: Tuesday, April 26, 2011 2:01 PM
>>>> To: [email-masked]
>>>> Cc: Chuanhuang Li; wmwang; Joel M. Halpern
>>>> Subject: [forces] LFBlib readability suggestions
>>>> 
>>>> to the authors,
>>>> 
>>>> As i have whined before, the general draft text is hard to read.
>>>> I think making things a little more formal as in the example LFB in RFC
>>>> 5812 section 8 will go a long way to improve readability.
>>>> 
>>>> I have attempted to redo the EtherPHYCop section, I didnt go 100% with
>>>> the RFC5812 format but please take a look in particular the "XXX"
>>>> and cross reference with:
>>>> - the text that exists right now in the draft
>>>> - the xml (and also to make sure it is well described)
>>>> - the formal scheme to describe things as i laid it out. The model
>>>> draft LFB example in section 8 is a good start.
>>>> 
>>>> cheers,
>>>> jamal
>>>
>> 
>> 
>> _______________________________________________
>> forces mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/forces
>>

--------------------------------------------------------------------------------

> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 27 Apr 2011 09:40:49 -0400

Weiming,

Your original message was received fine.
Look at:
http://www.ietf.org/mail-archive/web/forces/current/msg04003.html

cheers,
jamal