Subject: Re: [forces] comments #7

From: "Chuanhuang Li" <[email-masked]>
Date: Fri, 12 Aug 2011 23:21:08 +0800

Hi,Jamal
    Thanks again! Please see the inline.

======= 2011-08-12 17:24:09 Jamal Hadi Salim, wrote: =======
>iii) "Optinally an input packet may be accompanied by a Vlan priority
>metadata. In this case, default value for the metadata is 0."
>to:
>"In the case an input packet contains only a Vlan priority field metadata,
>a default vlan tag of 0 is assumed"
>Question: Dont we already have a Vlan tag of 0 by the time the packet
>is passed here? Also, where does this priority vlan field gets set?
>I dont recall seeing it being produced at any LFB earlier.

As said in previous email, Vlan priority was produced at EtherClassifier, if 
there is priority.
If the Input metadata VlanPriority is non-zero, the packet will have a VLAN tag, 
whatever the value of VlanID is(zero or non-zero). If VlanPriority and the VlanID 
are all zero, there is no VLAN tag to this packet.

>iv)This is one of those general comments I made that we dont say what
>the lookup keys are etc:
>"Upon a successful table lookup,"
>to:
>"The EncapTable is looked up using the MediaEncapInfoIndex.
>Upon a successful table lookup, ..."

There is some indication in Data Handling section:
"The LFB always expects from upstream
   LFBs the MediaEncapInfoIndex metadata which is used as an index to
   lookup the Encapsulation Table."

>v) Referring to the above - how do i know by looking at the XML
>that MediaEncapInfoIndex is the index used for the encaptable?
>Should there be at minimal some synopsis description somewhere that
>tells me this?
In current XML definition, all tables havn't the key or index informations in
the synopsis. Do we need explain these things clearly in XML?

>vi) It makes sense to say what the ExceptionID that is passed is
>downstream is known as - I am a little confused as to what the text
>is referring to.
Do you mean we need list the ExceptionID value in the text? It was defined 
in XML.

Yours,
Chuanhuang

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 12 Aug 2011 13:03:12 -0400

> are all zero, there is no VLAN tag to this packet.

That may make sense - but sounds inconsistent.
Arent you always passing this metadata? If you want to keep that way
fine with me - i did not see it that way when i read the text.

>   lookup the Encapsulation Table."

That is true - but you dont explain the success vs failure path.
You seem to be talking about the success path. You should be
explicit (i.e "Upon successful lookup ... and in case of failure ..").

> the synopsis. Do we need explain these things clearly in XML?

I think we need to. I shouldnt have to scratch my head to find out.

> Do you mean we need list the ExceptionID value in the text? It was defined

Just enough to be consistent with the other sections where you describe
the exceptions.

cheers,
jamal

---

From: "Chuanhuang Li" <[email-masked]>
Date: Sun, 14 Aug 2011 23:23:10 +0800

Hi,Jamal
    Please see the inline, Thanks!

Chuanhuang
======= 2011-08-13 01:03:18 Jamal Hadi Salim, wrote: =======
>fine with me - i did not see it that way when i read the text.
Currently, in EtherEncap, the input metadata "VlanPriority" was defined "optional".
If the orginal packet hadn't Vlan tag (That is no vlan priority input), The VlanPriority defaultValue was 0.
In the draft:
" Optinally an input packet may be accompanied by a Vlan priority metadata.  In this case, default value
   for the metadata is 0."
>I think we need to. I shouldnt have to scratch my head to find out.
ok, i'll modify some array components' synopsis description.

---

From: Jamal Hadi Salim <[email-masked]>
Date: Sun, 14 Aug 2011 13:00:24 -0400

Hi Chuanhuang,

On Sun, Aug 14, 2011 at 11:23 AM, Chuanhuang Li
<[email-masked]> wrote:

> " Optinally an input packet may be accompanied by a Vlan priority metadata.  In this case,
> default value  for the metadata is 0."

It is up to you how you want to reach this - my take on it is:
functionally assuming presence of both tag and priority is easier to follow.
Sometimes one or both could be zero.

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Tue, 16 Aug 2011 22:31:30 +0800

Chuanhuang,
Can you  make a summary on this comment so that I can incorparate the results in the text.

thks,
Weiming

----- Original Message ----- 
From: "Jamal Hadi Salim" <[email-masked]>
Subject: Re: comments #7

Hi Chuanhuang,

cheers,
jamal

---

From: "Chuanhuang Li" <[email-masked]>
Date: Wed, 17 Aug 2011 15:57:16 +0800

About this issue, as i have commented in the previous email, i think the 
draft content is no problem. But it need specify where "VlanPriority" metadata 
is produced and consumed both in EtherClassifier and EtherEncap. It also need 
point out emphatically this metadata is "optional". When there is no VLAN tag 
in the orginal packet, EtherClassifier will not produce it, and EtherEncap will not 
expect it.

Yours,
Chuanhuang

======= 2011-08-16 22:30:48 Wang,Weiming, wrote: =======

---

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 17 Aug 2011 05:08:23 -0400

Your call - please go ahead and add clarifying text.

cheers,
jamal