Subject: [forces] comments #11

From: Jamal Hadi Salim <[email-masked]>
Date: Mon, 15 Aug 2011 08:07:56 -0400

more comments.

---
22)5.3.1.
typo - there are two "." in the first sentence.

23) 5.3.1
"...packet as index to look up the IPv4 prefix table and generate a hop
selector as the matching result. This result will associate to the
packet as a metadatum to output to downstream LFBs, and will usually
be used there as an index to find more next hop information."
to:
"...packet as content key to look up the IPv4 prefix table and generate
a hop selector as the matching result. The hop selector is passed as
packet metadatum to downstream LFBs, and will usually
be used there as an index to find more next hop information."

24) 5.3.1.2
typo: "adrress"

25)5.3.1.2
"..LFB uses the destination IPv4 address of every input packet as index
to look up this table to get a hop selector as the result."
to:
"..LFB uses the destination IPv4 address of every input packet as the
content key to look up this table in order extract a next hop selector."

25) 5.3.2.1.
"..appropriate output port from the LFB."
to:
"..appropriate LFB output port."
26) 5.3.2.1.
"involves the forwarding TTL decrement and checksum recalculation."
Technically, could the checksum be deffered and computed in another
LFB? It doesnt have to be done here ...

27)5.3.2.1.
"Two output ports are defined to output results."
to:
"Two output ports are defined."

28)5.3.2.1.
"The packet is sent to a downstream LFB alongside with the L3PortID
and MediaEncapInfoIndex metadata."
I think it would be useful to mention where these metadata were received
from.

29)5.3.2.1.
"ICMP packet needs to be generated"
Could you summarize why ICMP packets need to be generated?

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Tue, 16 Aug 2011 20:59:43 +0800

Fixed all editorial ones and leave 26) 28) 29) for Chuanhuang to give proposed modification texts  and responses.

thanks,
Weiming

---

From: "Chuanhuang Li" <[email-masked]>
Date: Wed, 17 Aug 2011 10:12:08 +0800

Hi, all
    About 26) 28) 29), please see the inline, thanks!

Yours,
Chuanhuang

======= 2011-08-16 20:58:57 Wang,Weiming, wrote: =======

Generally, i think packet output from Nexthop should be IP encapsulated. 
 TTL decrement and IP checksum recalculation are the operation in IP header. 
I suggest changing "checksum recalculation" to "IP checksum recalculation" .

MediaEncapInfoIndex will be used in media encapsulation LFB, such as EtherEncap.
If there are more than one media encapsulation LFBs(for example, EtherEncap, 
L2/TunnelEncap), BasicMetadataDispatch will use L3PortID to dispatch packet to 
different encapsulation LFBs.

The main reason is there are no routes at all (including no default route) for the packet.
I suggest modifying this execption to "There are no routes for the packet" directly.

---

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 17 Aug 2011 05:04:41 -0400

> I suggest changing "checksum recalculation" to "IP checksum recalculation" .

Thats fine - but doesnt answer my question, which is: whether the checksum
could be defered to be handled in another LFB. I guess it may not matter; so
maybe just leave the text unchanged.

> different encapsulation LFBs.

You already have similar text in the last paragraph of that section.
I was talking about where metadata was created not where it is to be consumed.
In retrospect, dont bother adding text above - I think the text will
be slightly harder
to read as it stands, but we can live with it.

> I suggest modifying this execption to "There are no routes for the packet" directly.

Ok - thats useful to add.

cheers,
jamal

---

From: "Chuanhuang Li" <[email-masked]>
Date: Thu, 18 Aug 2011 09:34:00 +0800

Hi,Jamal 

======= 2011-08-17 17:04:35 Jamal Hadi Salim, wrote: =======

>to read as it stands, but we can live with it.
These text appears in NextHop, so the metadata was produced in this LFB. Do you mean we 
need a more explicit description ? 
Weiming will modify these text.

Yours,
Chuanhuang

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 18 Aug 2011 07:43:34 -0400

Hi Chuanhuang,

> Weiming will modify these text.

In this case, I meant ignore my earlier comment and dont make any change
for that specific comment i made.

cheers,
jamal