Subject: Re: [forces] comments #9

From: "Chuanhuang Li" <[email-masked]>
Date: Sun, 14 Aug 2011 22:58:40 +0800

Hi,Jamal
    About the execption cases, please see the inline. Thanks!

Chuanhuang
	
======= 2011-08-14 18:42:05 Jamal Hadi Salim, wrote: =======

>v) Should the first 3 exceptions really not be errors?
>I can understand Router Alert being an exception
Usually, if the packet is regarded as error, it will be dropped directly. But if it is execption, 
it need a further process.
All the execptions defined in IPv4Validator:
   o  Packet with destination address equal to 255.255.255.255
This is a limited broadcast packet. In some cases, router need process it.
   o  Packet with expired TTL
We can't say this is an error case, the packet need further process, such as generating 
ICMP.
   o  Packet with header length more than 5 words
If IP header has "Options" , the header length will be more than 5
words.
   o  Packet IP head including Router Alert options
This is an important option. Exactly,  it is the especial case with "header length more than 5 words". 

>viii)
>"Packet with source address equal to 255.255.255.255"
>was earlier listed as an exception and now is listed as an error.
>I think it should be an error and not at the exception level.
>
"Packet with source address equal to 255.255.255.255" is an error. 
In execption, the 255.255.255.255 is destination address.

>iii) Again - some of the exceptions appear to be errors. Please
>double check. When you fix them please make sure you fix the
>xml as well...
>---
>
>cheers,
>jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Sun, 14 Aug 2011 12:55:09 -0400

Hi Chuanhuang,

Please add either the justification you gave me below or make a
reference to a document that defines these as errors or exceptions
(Example RFC 1812).

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Tue, 16 Aug 2011 12:16:38 +0800

All editorial have been fixed. On the exception and error cases, the following texts are added: 

on exception, add text:
An exception case is the case when a packet needs further processing before being normally forwarded. 

on error, add text:
An error case is the case when a packet is unable to be further processed nor forwarded except being dropped.

thanks,
Weiming

----- Original Message ----- 
From: "Jamal Hadi Salim" <[email-masked]>
Subject: Re: comments #9

Hi Chuanhuang,

cheers,
jamal