Subject: [forces] compatibility WAS(Re: FW: New Version Notification for draft-haleplidis-forces-openflow-lib-00.txt

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 25 May 2012 10:22:16 -0400

Greetings Evangelos,

Excellent starting point. I will read and send you comments later
(probably this weekend).

A quick question:
Are you planning to look at backward and forward compatibility? i.e
make things in the
current model you put out (1.1) be able to work with OF 1.0 and say
1.2 and (I hear there is
a 1.3 and possibly 1.4). i.e i want to be able to use a ForCES defined
OF switch which
supports OF 1.0 using a controller which supports 1.4 and vice-versa.
And i would like
for a controller running 1.4 to support a mix and match of any of
{1.0,1.1,1.2,1.3,1.4}.

Given that OF has no respect for backward or forward compatibility it
may not work out of
the box - i was just curious if youve thought of it.

cheers,
jamal

On Thu, May 24, 2012 at 6:24 PM, Haleplidis Evangelos <[email-masked]> wrote:
> Greetings to the list,
>
> This is an OpenFlow LFB library document, currently for the OpenFlow 1.1 switch specification.
> If follows the same pattern as the current LFB-library document.
>
> http://www.ietf.org/id/draft-haleplidis-forces-openflow-lib-00.txt
>
> Regards,
> Evangelos Haleplidis.
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]]
>> Sent: Friday, May 25, 2012 1:17 AM
>> To: [email-masked]
>> Cc: [email-masked]; [email-masked]; [email-masked]
>> Subject: New Version Notification for draft-haleplidis-forces-openflow-
>> lib-00.txt
>>
>> A new version of I-D, draft-haleplidis-forces-openflow-lib-00.txt has
>> been successfully submitted by Evangelos Haleplidis and posted to the
>> IETF repository.
>>
>> Filename:      draft-haleplidis-forces-openflow-lib
>> Revision:      00
>> Title:                 Forwarding and Control Element Separation (ForCES)
>> OpenFlow Model Library
>> Creation date:         2012-05-25
>> WG ID:                 Individual Submission
>> Number of pages: 92
>>
>> Abstract:
>>    This document describes the OpenFlow switch in Logical Function
>>    Blocks (LFBs) used in the Forwarding and Control Element Separation
>>    (ForCES).  The LFB classes are defined according to the ForCES
>>    Forwading Element (FE) model and ForCES protocol specifications.
>> The
>>    library includes the descriptions of the OpenFlow LFBs and the XML
>>    definitions.
>>
>>
>>
>>
>> The IETF Secretariat
>
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Sat, 26 May 2012 02:35:30 +0300

Greetings Jamal,

That is part of the plan. As far as I can see OpenFlow does not offer
backward or even forward compatibility. At least not in OF 1.0, 1.1 and 1.2
- so i am still analyzing how best to do it. That may also be affected by
how much feedback we get resulting in how we change the model proposed.

I will provide a concrete answer after looking closer at the details. But
general answer is "yes" that is part of the plan.

Regards,
Evangelos Haleplidis.

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jamal Hadi Salim
> Sent: Friday, May 25, 2012 5:22 PM
> To: Haleplidis Evangelos
> Cc: [email-masked]
> Subject: [forces] compatibility WAS(Re: FW: New Version Notification
> for draft-haleplidis-forces-openflow-lib-00.txt
> 
> Greetings Evangelos,
> 
> make things in the current model you put out (1.1) be able to work with
> OF 1.0 and say
> 1.2 and (I hear there is
> OF switch which supports OF 1.0 using a controller which supports 1.4
> and vice-versa.
> And i would like
> may not work out of the box - i was just curious if youve thought of
> it.
> 
> cheers,
> jamal
> 
> >> Subject: New Version Notification for
> >> draft-haleplidis-forces-openflow- lib-00.txt
> >>
> >> Title:                 Forwarding and Control Element Separation
> >> (ForCES) OpenFlow Model Library Creation date:         2012-05-25 WG
> >> ID:                 Individual Submission Number of pages: 92
> >>
> >> Abstract: