Subject: [forces] Discussing Errata on RFC5812

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 4 Nov 2012 19:27:25 -0000

Hi,

Evangelos raised http://www.rfc-editor.org/errata_search.php?eid=3371

I'd welcome some opinions.

There are three parts to this:

1. Page 65

OLD
  <product> lists the allowed frame formats...
NEW
  <product> MAY lists the allowed frame formats...
END

2. Page 65

NEW
  The <product> element MUST contain at least either a frame format or a
metadata.
END

3. Page 95

For the XML schema:
Page 95
OLD
      <xsd:element name="frameProduced"> 
NEW
      <xsd:element name="frameProduced" minOccurs="0">
END

The first two items suggest that  the intent is that <product> contains one or
both of frame format and metadata
What does the WG feel is the intent here?

The third issue looks like a technical change (albeit a small one).

Cheers,
Adrian

---

From: Joel <[email-masked]>
Date: Sun, 04 Nov 2012 14:33:38 -0500

My understanding of the intent o the WG was not to require frame formats 
allowed.  Some LFBs don't have input.  Some don't have output.  Some 
don't have either.
SO I think these changes are correct.

While item 3 looks technical, it is simply aligning the XML with that 
intent.

Yours,
Joel

On 11/4/2012 2:27 PM, Adrian Farrel wrote:
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces
>