Subject: [forces] item #5 Northbound interface/Services definition

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 6 Dec 2012 08:58:27 -0500

What it is
-----------
A Services definition interface at the CE; meaning an LFB that resides
at the "CE". Such an LFB would model a service.
This lets a CE become both an "FE" on the northbound (by virtue of
defining an LFB owned by the CE) and a "CE" to other FEs on the
southbound...

Why this is needed
-----------------------
a) Allows to use ForCES for a services level interface in a formal way.
The Service level definition is a natural fit for ForCEs.
b) Allows for existence of proxy CEs for scaling reasons.

All this is outside the charter.

Please respond whether you:
a) are interested in doing the work
b) will review the work
c) find the work interesting and it should be done in the WG
d) do not think we should do this work

cheers,
jamal

---

From: WM Wang <[email-masked]>
Date: Thu, 6 Dec 2012 08:12:12 -0700

My team is interested in doing the work (a), and think this should be done in the WG (c). My team also has done some work related, hope to share later.

thanks,
Weiming

> From: [email-masked]
> Date: Thu, 6 Dec 2012 08:58:27 -0500
> To: [email-masked]
> Subject: [forces] item #5 Northbound interface/Services definition
> 
> What it is
> -----------
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces

---

From: Joel <[email-masked]>
Date: Thu, 06 Dec 2012 11:00:37 -0500

This is something we will be developing.  It would be significantly 
better if it were standardized, rather than proprietary.
It is a bit of a stretch for this WG, but I think belongs here more than 
anywhere else.

As such, (a).

Yours,
Joel

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Fri, 7 Dec 2012 00:56:01 +0200

Greetings to all,

We are very interested in doing this work and we do believe that this is
important work and must be done in the ForCES wg.

Regards,
Evangelos Haleplidis.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jamal Hadi Salim
> Sent: Thursday, December 06, 2012 3:58 PM
> To: [email-masked]

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 6 Dec 2012 18:09:26 -0500

Chair hat off:
We have implemented some parts of this already. It was a natural fit. We would
love to see this done in a standardized way.

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 6 Dec 2012 18:11:50 -0500

> It is a bit of a stretch for this WG, but I think belongs here more than

I know there's some cross-over with I2RS - but i think the scope of this is
larger than what I2RS is trying to achieve (since I2RS the service set
is limited).

cheers,
jamal

---

From: Ashwani Mehra <[email-masked]>
Date: Wed, 12 Dec 2012 10:36:30 +0530

Hi,

Agree with (c) and would like to contribute, hence (a).

Thanks
Ashwani