Subject: [forces] item #12: Simplified SCTP TML

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 10 Jan 2013 06:57:56 -0500

What it is
-----------
A simpler TML still based on SCTP.
It will use DTLS instead of IPSEC and will have a single channel
with the 3 priority channels per RFC 5811.
When RFC 5811 was being written SCTP was not considered
mature enough to be used for its stream prioritization or DTLS.

Why it is needed
---------------------
1) It is perceived a single socket per CE-FE connection will scale
better than the current TML which requires 3 sockets.
2) DTLS is simpler/more usable to deploy than IPSEC.

Please respond whether you:
a) are interested in doing the work
b) will review the work
c) find the work interesting and it should be done in the WG
d) do not think we should do this work

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 10 Jan 2013 07:01:42 -0500

Small correction:

> What it is

                ^^^^^^^
meant: single socket (not single channel)

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 10 Jan 2013 08:39:26 -0500

Chair hat off:
For the record, we have plans to implement this. So #a-#c.

cheers,
jamal

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Fri, 11 Jan 2013 00:50:22 +0200

Greetings to the list,

We believe that TML definitions SHOULD be discussed within the wg. 
I don't know whether we'll implement this (not a)) but we'll review and
comment.

Therefore b) and c).

Regards,
Evangelos Haleplidis.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jamal Hadi Salim
> Sent: Thursday, January 10, 2013 3:39 PM
> To: [email-masked]
> Subject: Re: [forces] item #12: Simplified SCTP TML
> 
> Chair hat off:
> > It will use DTLS instead of IPSEC and will have a single channel with
> > the 3 priority channels per RFC 5811.
> > When RFC 5811 was being written SCTP was not considered mature enough
> > to be used for its stream prioritization or DTLS.
> >
> > Why it is needed
> > ---------------------
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces