Subject: [forces] item #11: Multi-CE configuring a single FE

From: Jamal Hadi Salim <[email-masked]>
Date: Mon, 7 Jan 2013 08:03:52 -0500

What it is
----------
At the moment the ForCES architecture allows for multiple CEs to
be present; however, in presence of multiple CEs within the NE,
only one can be a master of a specific FE (configuring it etc).
An FE may be aware of multiple CEs and fail over mastership
fails to another CE. Such an HA setup could be configured in cold
(standard FEPO setup) or hot standby (CEHA document).
As a consequence, it is feasible for multiple CEs to control different
FEs within the same NE. So one could scale control at that level.
While the CEHA draft introduces a feature to have multiple
CEs query the same FE, it is still prohibited to have multiple CEs
configure the same FE.
The work item requested here is to allow multiple CEs to configure
a single FE.

Why this is needed
------------------

1)For control plane horizontal scaling reasons, one may require
multiple CEs dealing with one or more FEs.
2)The I2RS requirements, which are a natural fit for ForCES, would
require that multiple applications connect to multiple
controllers both connecting to the same FE.

Please respond whether you:
a) are interested in doing the work
b) will review the work
c) find the work interesting and it should be done in the WG
d) do not think we should do this work

cheers,
jamal

---

From: Joel <[email-masked]>
Date: Mon, 07 Jan 2013 17:13:39 -0500

This particular item (and the corresponding I2RS behavior) strikes me as 
extremely difficult to specify well.  One can write a spec saying "it is 
allowed".  But specifying when it is sane, and how to handle 
interactions, seems to be extremely difficult and error-prone.

I am reluctant to see us take this work on until there is demonstration 
that we know how to handle the collisions.  (The I2RS case has one 
important difference in that the entity being controlled is viewed as 
having significant local itnelli9gence, and hence can be expected to 
have a conflict-broker and error detection/handling/fall-back.)

Yours,
Joel

On 1/7/2013 8:03 AM, Jamal Hadi Salim wrote:
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces
>

---

From: "Wang,Weiming" <[email-masked]>
Date: Tue, 8 Jan 2013 12:11:25 +0800

Although very tough, the issue is a reqirement seemed quite urgent from some ForCES possible applications. Even we can include a very basic function of multipule CEs configuring, it means much.  E.g., by defining in FE model with a tag that only allowed elements are multiple configurable, we then be able to allow only those that will definitely not lead to confictions are open for for multiple CEs configurations. 

As a result, we think it worth doing some work, so a), b), and c). 

thanks,
Weiming

----- Original Message ----- 
From: "Jamal Hadi Salim" <[email-masked]>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 8 Jan 2013 09:01:18 -0500

On Mon, Jan 7, 2013 at 5:13 PM, Joel <[email-masked]> wrote:
> allowed".

I think that would be a good start.

>But specifying when it is sane, and how to handle interactions,
> seems to be extremely difficult and error-prone.
>

Agreed - but there is precedence (eg remote locks ala netconf etc); the question
is whether it is worth the exercise. One can already (today) have
multiple CEs control different FEs without any changes.
What ive heard is some folks want to have multiple CEs control multiple
LFBs or LFB instances within the same FE. This seems also to come from
desire to virtualize where the same FE maybe partitioned around
multiple LFB instances/graph per virtual entity.

> I am reluctant to see us take this work on until there is demonstration that
> we know how to handle the collisions.  (The I2RS case has one important
> difference in that the entity being controlled is viewed as having
> significant local itnelli9gence, and hence can be expected to have a
> conflict-broker and error detection/handling/fall-back.)

So a CE level arbitration/control? Which I2RS doc to look at?

cheers,
jamal

---

From: Joel <[email-masked]>
Date: Tue, 08 Jan 2013 17:55:41 -0500

The I2RS Policy document talks about managing the interaction of 
multiple requests, about priority and precedence, and other similar issues.

Yours,
Joel

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 10 Jan 2013 10:58:53 -0500

Yes, Jamal, this is very important ans useful especially when
a stable system is desired.

Mechanisms must be in place to avoid race condition and
propagation of ripple effect of multiple failures.

Support a, b, and c. Thanks.

Best.

Bhumip

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Fri, 11 Jan 2013 00:46:56 +0200

Greetings to the list,

We agree that this is an important mechanism.

It could probably be related also with Item #8: Credential subsystem
integration.

I don't know if we have the resources to do a), but we certainly support b
and c.

Regards,

Evangelos Haleplidis.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Thursday, January 10, 2013 5:59 PM
To: Jamal Hadi Salim
Cc: [email-masked]
Subject: Re: [forces] item #11: Multi-CE configuring a single FE

Best.

Bhumip

What it is
----------

Why this is needed
------------------

cheers,
jamal