Subject: [forces] item #10: Netconf Relationship + a few services inspired from Yang models

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 4 Jan 2013 06:26:50 -0500

Ok, so from the last posting it seems there are some people awake and
reading the list ;->

What it is
-----------
Illustrate netmod port, IP, route yang models as ForCES LFBs.
Evangelos and Jamal plan to put up either a single draft or
multiple to show these (3 or more) yang models as LFBs.

Why this is needed:
------------------------

a) illustrate how ForCES can go coarse grained as in the "port" yang
module or as thin as how one would describe a "port" in the
LFBlib document (where the granularity is at the level of MACs etc).

b) illustrate how ForCES can be trivially interfaced to netconf,
where netconf takes the role of  a management interface/CLI
and ForCES as a southbound interface.

c) serve as a set of simple services to show how ForCES can
be used at the northbound interface as described in posted
item #5. This is particularly interesting since the route yang
model was recently used as a pointer on how one could use
netconf to define the interfacing to IRS. We believe, at faster
update timeframe requirements, ForCES will be a better
protocol choice for that northbound protocol.

Please respond whether you:
a) are interested in doing the work
b) will review the work
c) find the work interesting and it should be done in the WG
d) do not think we should do this work

cheers,
jamal

---

From: WM Wang <[email-masked]>
Date: Fri, 4 Jan 2013 06:03:45 -0700

Hi Jamal,

We are quite interested in this topic. So a), b), and c) also.

thanks,
Weiming

> From: [email-masked]
> Date: Fri, 4 Jan 2013 06:26:50 -0500
> To: [email-masked]
> Subject: [forces] item #10: Netconf Relationship + a few services inspired	from Yang models
> 
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Fri, 4 Jan 2013 15:41:41 +0200

Greetings to the list,

As Jamal stated, we already interested and involved in this work (a) and b))
and we think this is preferably done within the ForCES wg (c)).

Regards,

Evangelos Haleplidis.

From: [email-masked] [mailto:[email-masked]] On Behalf Of
WM Wang
Sent: Friday, January 04, 2013 3:04 PM
To: [email-masked]; [email-masked]
Subject: Re: [forces] item #10: Netconf Relationship + a few services
inspired from Yang models

Hi Jamal,

thanks,
Weiming