Subject: [forces] item #9: Openflow Relationship

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 3 Jan 2013 06:48:13 -0500

[I know it is still slow week - but we gotta complete going
over these suggested work items]

What it is
----------
Illustration of OpenFlow to ForCES relationship.
Refer to:
https://datatracker.ietf.org/doc/draft-hares-forces-vs-openflow/
https://datatracker.ietf.org/doc/draft-haleplidis-forces-openflow-lib/

Why this is needed:
-------------------
OF has taken the industry by a storm and has shaped the SDN
world. ForCES has been doing SDN for years.
It is of informational  value to compare and contrast ForCES with
OF.
It is is of informational value to show that ForCES can be used in
conjunction or in place of OF.
It is valuable as well to learn technically from OF on how we could
add missing useful features to ForCES.

Please respond whether you:
a) are interested in doing the work
b) will review the work
c) find the work interesting and it should be done in the WG
d) do not think we should do this work

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Thu, 3 Jan 2013 20:20:31 +0800

Evangelos has been doing  excellent work on this item. If needed, my team will be willing to help the work in some way. 

So, a), b),  and c) with 'might be done in the WG'. 

thanks,
Weiming
 
----- Original Message ----- 
From: "Jamal Hadi Salim" <[email-masked]>

 OF.
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces
>

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Thu, 3 Jan 2013 14:39:55 +0200

Greetings,

For the reasons Jamal stated below, I think it's clear that this work must
be done in the wg (therefore we support c))

And as we are already participating in this effort we will of course support
a) & b)

Regards,
Evangelos Haleplidis.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Wang,Weiming
> Sent: Thursday, January 03, 2013 2:21 PM
> To: Jamal Hadi Salim; [email-masked]
> Subject: Re: [forces] item #9: Openflow Relationship
> 
> Evangelos has been doing  excellent work on this item. If needed, my
> team will be willing to help the work in some way.
> 
> > [I know it is still slow week - but we gotta complete going over
> these
> > suggested work items]
> >
> > What it is
> > ----------
> > OF has taken the industry by a storm and has shaped the SDN world.
> > ForCES has been doing SDN for years.

---

From: Christian Esteve Rothenberg <[email-masked]>
Date: Thu, 3 Jan 2013 11:05:30 -0200

Best wishes for 2013,

here is my individual position on this matter:
b) will review the work
c) find the work interesting and it should be done in the WG

Greetings,
Christian

-- 
Christian

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 3 Jan 2013 11:15:03 -0500

Jamal:

I'm interested in:
a) doing the work (will post an updated draft this week) - yes 
b) reviewing any work - yes 
c) find the work interesting and it should be done in the WG - yes 
d) do not think we should do this work - [false] we should do the work.

Sue 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jamal Hadi Salim
Sent: Thursday, January 03, 2013 6:48 AM
To: [email-masked]
Subject: [forces] item #9: Openflow Relationship

[I know it is still slow week - but we gotta complete going over these
suggested work items]

What it is
----------

Why this is needed:
-------------------
OF has taken the industry by a storm and has shaped the SDN world. ForCES
has been doing SDN for years.
It is of informational  value to compare and contrast ForCES with OF.
It is is of informational value to show that ForCES can be used in
conjunction or in place of OF.
It is valuable as well to learn technically from OF on how we could add
missing useful features to ForCES.

cheers,
jamal

---

From: David Meyer <[email-masked]>
Date: Thu, 3 Jan 2013 08:26:18 -0800

Jamal, am also interested in doing/reviewing the work. --dmm

---

From: Joel <[email-masked]>
Date: Thu, 03 Jan 2013 13:33:16 -0500

I think this is valuable work.  I would be happy to comment on it, and 
would like to see the WG take on the work.
While it would be somewhat lon, a combination of the two documents might 
make sense.

Yours,
Joel

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 3 Jan 2013 14:25:01 -0500

Yes, Jamal, Thanks, and
Happy New Year to Everyone.

This item (item #9) deals with my question
on OF during IETF85 in Atlanta, GA (
http://www.ietf.org/proceedings/85/minutes/minutes-85-forces), and I
support a, b, and c. Thanks.

Best.

Bhumip

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 4 Jan 2013 06:17:28 -0500

Chair hat off.
For the record, we have been implementing (at least vetting the control to
data path messaging and state maintainance of the Evangelos et al draft
as part of regular regressions we do). So #a-#c from this side.

cheers,
jamal