Subject: [forces] CEHA document update

From: Jamal Hadi Salim <[email-masked]>
Date: Mon, 18 Feb 2013 06:31:04 -0500

Hi,

Based on current implementation and deployment
experience, the authors have reached a conclusion we
need to simplify things from the previous draft.
We have removed from the draft 3 things and added one.
For this reason, we would like to allow for time to simmer
the changes and hopefully receive comments on the
content before going to ask for a WG last call.
We hope to publish the updated draft in the next 1-2 days.

The changes are:
1) Remove the confirm state therefore reducing the state
 machine for hot-standby to be very similar to cold-standy
 with some very small differences.
Justification:
The elected master CE can already override its mastership
to another CE by setting the CEID field.
The FE is already well aware of the liveliness of the backup
CE, so an extra confirmation does not change things.

2) Remove the filter control for allowing whether backup
CEs can do queries.
Justification: We found that in all cases we have
 encountered, associating to a backup CE results in the
 backup CE needing to find some FE state
(as minimal as pulling FEPO or FEObject information
from the FE).
Implementations are free to put filters via the FEM if really
deemed necessary.

3) Simplify Events.
We keep the PrimaryCEDown event from RFC 5810 and
continue to generate it for both hot and cold stand-by.
We change the new PrimaryCEChanged event to only
advertise the new master CE.
Justification: This gives us backward compatibility for free.

4) Statistics
We have added statistics to the ALLCES table for each CE
as perceived by the FE. These stats will define
receive/transmit packets/bytes as well as errors. During
deployment, the statistics turned out to be very useful for
debugging.

cheers,
jamal

---

From: "Joachimpillai, Damascene M" <[email-masked]>
Date: Mon, 18 Feb 2013 12:00:11 -0500

Where can I find the draft for CEHA? This is very important for our design.

-- DJ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jamal Hadi Salim
Sent: Monday, February 18, 2013 6:31 AM
To: [email-masked]
Subject: [forces] CEHA document update

Hi,

Based on current implementation and deployment experience, the authors have reached a conclusion we need to simplify things from the previous draft.
We have removed from the draft 3 things and added one.
For this reason, we would like to allow for time to simmer the changes and hopefully receive comments on the content before going to ask for a WG last call.
We hope to publish the updated draft in the next 1-2 days.

The changes are:
1) Remove the confirm state therefore reducing the state  machine for hot-standby to be very similar to cold-standy  with some very small differences.
Justification:
The elected master CE can already override its mastership to another CE by setting the CEID field.
The FE is already well aware of the liveliness of the backup CE, so an extra confirmation does not change things.

2) Remove the filter control for allowing whether backup CEs can do queries.
Justification: We found that in all cases we have  encountered, associating to a backup CE results in the  backup CE needing to find some FE state (as minimal as pulling FEPO or FEObject information from the FE).
Implementations are free to put filters via the FEM if really deemed necessary.

3) Simplify Events.
We keep the PrimaryCEDown event from RFC 5810 and continue to generate it for both hot and cold stand-by.
We change the new PrimaryCEChanged event to only advertise the new master CE.
Justification: This gives us backward compatibility for free.

4) Statistics
We have added statistics to the ALLCES table for each CE as perceived by the FE. These stats will define receive/transmit packets/bytes as well as errors. During deployment, the statistics turned out to be very useful for debugging.

cheers,
jamal
_______________________________________________
forces mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/forces

---

From: Jamal Hadi Salim <[email-masked]>
Date: Mon, 18 Feb 2013 13:36:17 -0500

Hi DJ,

Evangelos should be able to post it later today.

cheers,
jamal