Subject: [forces] Event Condition Equal?

From: "Haleplidis Evangelos" <[email-masked]>
Date: Mon, 11 Feb 2013 18:13:04 +0200

Greetings to the list,

While going over implementation, we came upon a case where it would be
useful to advertise a state transition an FE has observed. 

In a state machine where there are more states to the left/right of the
state of interest, it is hard to use event thresholds (greater than/less
than). 

Is there a way to do that with the current event conditions? Do you we need
to add a new equality condition for events?

Regards,

Evangelos Haleplidis.

---

From: Joel <[email-masked]>
Date: Mon, 11 Feb 2013 12:32:54 -0500

Does <eventChanged/> handle what you want?

Yours,
Joel

On 2/11/2013 11:13 AM, Haleplidis Evangelos wrote:
> Is there a way to do that with the current event conditions? Do you we
> need to add a new equality condition for events?
>
> Regards,
>
> Evangelos Haleplidis.
>
>
>
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces
>

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Mon, 11 Feb 2013 20:18:09 +0200

Greetings Joel,
	
Thanks for the reply. I probably didn't elaborate enough in the previous
email.

Our case involves an issue where we would like to target a specific value of
the state instead of any change of the state, therefore an event would be
generated if the state reaches that state only.

Event changed would not be sufficient as it would report any change. It
probably would be done with event changed and event hysteresis property, but
it would be very messy.

Regards,
Evangelos Haleplidis.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Joel
> Sent: Monday, February 11, 2013 7:33 PM
> To: Haleplidis Evangelos
> Cc: [email-masked]
> Subject: Re: [forces] Event Condition Equal?
> 
> > In a state machine where there are more states to the left/right of
> > the state of interest, it is hard to use event thresholds (greater
> > than/less than).
> >

---

From: Joel <[email-masked]>
Date: Mon, 11 Feb 2013 14:30:56 -0500

Well, one way would be a bit of a hack, but would handle the case where 
there is only one state were you need the tansition-out reported.  That 
would be to arrange the numeric values of the states so that it is 
either lowest or highest.  Then the comparators will work.

Otherwise, we would need a new changeFrom event.  I would need to see 
more details to know whether that makes sense.

Yours,
Joel

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Sun, 17 Feb 2013 22:38:25 +0200

Greetings Joel,

Our current use case is the CEHA. It would be useful for the master CE to
know when either a backup CE is associated (one case would be to
synchronize) but would be uninterested at the rest of the states. 
The CE could poll the FE periodically for this info, but it would be more
efficient with an event.

I agree that the hack you suggest can be useful.

Regards,
Evangelos Haleplidis.

> From: Joel [mailto:[email-masked]]
> Sent: Monday, February 11, 2013 9:31 PM
> To: Haleplidis Evangelos
> Cc: [email-masked]
> > Thanks for the reply. I probably didn't elaborate enough in the
> > previous email.
> >
> > Our case involves an issue where we would like to target a specific
> > value of the state instead of any change of the state, therefore an
> > event would be generated if the state reaches that state only.
> >
> > Event changed would not be sufficient as it would report any change.
> > It probably would be done with event changed and event hysteresis
> > property, but it would be very messy.
> >
> > Regards,
> > Evangelos Haleplidis.
> >