Subject: Re: [forces] InterFE Packet metadata

From: "Joachimpillai, Damascene M" <[email-masked]>
Date: Fri, 1 Mar 2013 09:11:05 -0500

Are we planning on getting an EtherType registered for FoRCES interFE messages?

-- DJ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jamal Hadi Salim
Sent: Wednesday, February 27, 2013 4:09 PM
To: Joel M. Halpern
Cc: forces
Subject: Re: [forces] InterFE Packet metadata

Ok, I finally got what Joel was alluding to.
We _cant_ tell the content by looking at the REDIRECT-DATA TLV.
The assumption is the receiver knows what the data is. Strangely enough, we havent run into any issues in our implementation - I suppose because we only have one source of redirected data and we know what it is at the receiver.
We should be able to define a metadata type which specifies this.
Not sure if lfblib would be the right place to do this.

cheers,
jamal

On Wed, Feb 27, 2013 at 1:22 PM, Jamal Hadi Salim <[email-masked]> wrote:
> We have a REDIRECT-DATA TLV (0x116) which is for the packet data.
> The METADATA TLV (0x115) carries the metadata.
>
> cheers,
> jamal
>
> On Wed, Feb 27, 2013 at 12:19 PM, Joel M. Halpern <[email-masked]> wrote:
>> While discussing a related topic with someone else, I wondered about 
>> something.  In the redirect TLV (and presumably also in the inter-FE 
>> packet
>> transfer) we say taht the metadata indicates what kind of packet is 
>> being transferred.
>> But I don't think we ever actually defined the packet-type metadatum. 
>> We have packet types in the dataplane flow, but that is not a piece 
>> of metadata.
>> have I forgotten something obvios, or do we have a gap?  (We can 
>> easily fix it in the lfb-library if we have a gap.)
>>
>> Yours,
>> Joel
>> _______________________________________________
>> forces mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/forces
_______________________________________________
forces mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/forces

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 1 Mar 2013 09:19:17 -0500

In my opinion for ethernet transport we would need one registered.

cheers,
jamal

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 01 Mar 2013 11:40:29 -0500

Assuming that we go down a path of not using a transport protocol to 
carry these (and I would prefer that path), then we either use an IP 
encapsulation (we could use IP fragmentation) or use an Ethertype.  I 
tend to prefer the ethertype approach, but I can imagine folks arguing 
for either one.

Yours,
Joel

---

From: "Joachimpillai, Damascene M" <[email-masked]>
Date: Fri, 1 Mar 2013 14:59:45 -0500

Do you think it will be good to register an ethertype and make it available for use. If people choose to use IP to avoid and/or to deal with fragmentation they could. 

-- DJ

-----Original Message-----
From: Joel M. Halpern [mailto:[email-masked]] 
Sent: Friday, March 01, 2013 11:40 AM
To: Joachimpillai, Damascene M
Cc: 'Jamal Hadi Salim'; forces
Subject: Re: [forces] InterFE Packet metadata

Assuming that we go down a path of not using a transport protocol to carry these (and I would prefer that path), then we either use an IP encapsulation (we could use IP fragmentation) or use an Ethertype.  I tend to prefer the ethertype approach, but I can imagine folks arguing for either one.

Yours,
Joel

---

From: Joel <[email-masked]>
Date: Fri, 01 Mar 2013 15:01:52 -0500

We have to decide what we want to put in the I-D for encapsulation.  I 
hope we can agree on one encapsulation.
When we have agreed, and the IESG agrees to publish, then if it needs an 
Ethertype we can get one.  (There are plenty of easy ways to use 
experimental code points for development work.)  We should not try to 
register one before then.

Yours,
Joel

---

From: "Joachimpillai, Damascene M" <[email-masked]>
Date: Fri, 1 Mar 2013 15:04:35 -0500

Ok thanks. 

-----Original Message-----
From: Joel [mailto:[email-masked]] 
Sent: Friday, March 01, 2013 3:02 PM
To: Joachimpillai, Damascene M
Cc: 'Joel M. Halpern'; forces
Subject: Re: [forces] InterFE Packet metadata

We have to decide what we want to put in the I-D for encapsulation.  I hope we can agree on one encapsulation.
When we have agreed, and the IESG agrees to publish, then if it needs an Ethertype we can get one.  (There are plenty of easy ways to use experimental code points for development work.)  We should not try to register one before then.

Yours,
Joel

On 3/1/2013 2:59 PM, Joachimpillai, Damascene M wrote:
>>>> While discussing a related topic with someone else, I wondered 
>>>> about something.  In the redirect TLV (and presumably also in the 
>>>> inter-FE packet