Subject: [forces] AD's review of charter text

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 2 Apr 2013 15:35:27 +0100

Hi,

I did a review of the text.

My edits are:

- Cut out most of the preamble
- Move the "other business" paragraph to the end
- Tweak words
- Adjust layout
- Split milestones into separate items

I posted a new revision at https://datatracker.ietf.org/doc/charter-ietf-forces/

You can see the differences at
https://www.ietf.org/rfcdiff?url1=http%3A%2F%2Fwww.ietf.org%2Fcharter%2Fcharter-
ietf-forces-03-02.txt&difftype=--html&submit=Go%21&url2=http%3A%2F%2Fwww.ietf.or
g%2Fcharter%2Fcharter-ietf-forces-03-04.txt

I'd like to carry this forward with a little momentum, so would welcome comments
of approval or otherwise.

Thanks,
Adrian

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 02 Apr 2013 10:44:13 -0400

If you think the IESG and readers can do without the extra background, 
then I am happy to see it removed.
The rest of it look fine to me (the diff link doesn't work).
Thank you Adrian,
Joel

On 4/2/2013 10:35 AM, Adrian Farrel wrote:
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 2 Apr 2013 10:59:59 -0400

Looks improved to me.

To Joel's comment:
Does the current charter have a possible (back) link to the older one
so interested people can take a peek at the history?

cheers,
jamal

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Tue, 2 Apr 2013 21:31:50 +0300

Greetings to the list,

I think there is an errata in the Subsidiary Management section in the first
.
Change "Forwarding Element Model (FEM)" to "Forwarding Element Manager
(FEM)"
Did I capture the intent correctly? 

Also can I suggest a minor rewording for readability?

From:
In addition to the specific work items listed above, the working group will
allow discussions of how to use ForCES to model topics of interest to
Network Function Virtualization, I2RS, or OpenFlow may be discussed and
reviewed. 

To:
In addition to the specific work items listed above, the working group will
allow discussions and review work of how to use ForCES to model topics of
interest to
Network Function Virtualization, I2RS, or OpenFlow. 

Other than these two I think the recharter text looks fine.

Regards,
Evangelos Haleplidis.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Jamal Hadi Salim
> Sent: Tuesday, April 02, 2013 6:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [forces] AD's review of charter text
> 
> Looks improved to me.
> 
> To Joel's comment:
> > I posted a new revision at
> > https://datatracker.ietf.org/doc/charter-ietf-forces/
> >
> > ietf-forces-03-02.txt&difftype=--
> html&submit=Go%21&url2=http%3A%2F%2Fw
> > ww.ietf.or g%2Fcharter%2Fcharter-ietf-forces-03-04.txt
> >
> > I'd like to carry this forward with a little momentum, so would
> > welcome comments of approval or otherwise.
> >
> > Thanks,
> > Adrian
> >

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 2 Apr 2013 22:13:17 +0100

Hi Haleplidis,

> Did I capture the intent correctly?

I need the WG to tell me the answer to that. 
The original text had "FEM" in the context of...

  Deployment experience has demonstrated usefulness of expressing the FEM
  with the same semantics as any other LFB and thus be controlled by the CE.

I don't think you can express a manager with semantics (although I have had
several managers that I would have liked to express :-)

I checked in RFC 5810 and find you are right. But RFC 3654 talks about the "FE
Model" and it seemed to me that a model is more easily expressed than a manager.

> Network Function Virtualization, I2RS, or OpenFlow.

Good catch. Thanks.

Adrian

---

From: Joel <[email-masked]>
Date: Tue, 02 Apr 2013 17:25:48 -0400

The presentations to the working group have been about using ForCES to 
control the FE Manager, by creating an LFB to represent it's functions. 
   It comes up in virtualization case, where you use normal mechanisms 
to establish communication with the device master, and then you 
instantiate FEMs to manage virtual FEs.

Yours,
Joel

---

From: Joel <[email-masked]>
Date: Tue, 02 Apr 2013 17:40:10 -0400

With two minor modifications, it works for me.
1) s/LFD/LFB/
2) change "same semantics as for any other LFB" to "appropriate 
semantics, as is required for every LFB definition"

The reason for point 2 is that the semantics of an LFB definition are 
its definition.  They are not the same for all LFB definitions.

Yours,
Joel

On 4/2/2013 5:31 PM, Adrian Farrel wrote:
> Gotcha. Thanks!
>
> How about...
>
> OLD
>    Deployment experience has demonstrated usefulness of expressing the
>    Forwarding Element Model (FEM) using the same semantics as for any other LFB.
> NEW
>    Deployment experience has demonstrated the value of using ForCES to control
>    the Forwarding Element Manager (FEM) by creating an LFD to represent its
>    function using the same semantics as for any other LFB.
> END
>
> Adrian
>
>> From: Joel [mailto:[email-masked]]
>> Sent: 02 April 2013 22:26
>> To: [email-masked]
>> Cc: 'Haleplidis Evangelos'; [email-masked]

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 2 Apr 2013 22:31:29 +0100

Gotcha. Thanks!

How about...

OLD

Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Apr 2013 13:16:37 +0100

Typos abound.

Very good catch on "semantics".
I think the intent of the original was "syntax". I.e., that it should be an LFB
using the same encoding rules as in other LFBs.

A

> Sent: 02 April 2013 22:40
> To: [email-masked]
> Cc: [email-masked]; 'Haleplidis Evangelos'; [email-masked]
> FEM

---

From: Joel <[email-masked]>
Date: Wed, 03 Apr 2013 09:50:16 -0400

"same syntax" would be fine.  "same structure" would also be okay.
Yours,
Joel