Subject: [forces] Macro Trends, Complexity, and Sofware Defined Networking WAS(Re: Your recharter proposal

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 2 Apr 2013 11:25:47 -0400

I would like to point out to folks interested in network
programmability to take a
closer look at Dave's presentation (the longer version at
http://www.1-4-5.net/~dmm/talks/ncrg86.pd);
I enjoyed it!

In regards to OF vs ForCES - OF will eventually _have to_ look like ForCES.
And I know this is hard to talk about in a public forum:
As someone (technical) who is involved with ForCES and
network programmability for years now, i find it frustrating that we cant
have the ONF pay attention to ForCES (when you read some of the blogs
we dont even exist). We have tried to extend an olive branch in the past
and i think it will benefit both communities if we worked together.
It doesnt seem the challenge is technical at all. One of the messages
Ive gotten back is the ONF feels like they have to create things so the
"IPR" is owned there. Given there are no know IPR issues known with
ForCES, i didnt see what the issue is. Maybe i am not getting it since
I dont attend ONF meetings.

cheers,
jamal

On Tue, Apr 2, 2013 at 10:09 AM, David Meyer <[email-masked]> wrote:

> For those who don't have ACM credentials, try
> http://conferences.sigcomm.org/sigcomm/2009/workshops/presto/papers/p19.pdf
>

> I have been arguing that if OpenFlow evolves past 1.0 (basically L2 only)
> and 1.1+ (multi-table 1.0 with additional protocol features and which
> basically unimplementable on ASIC h/w), then it will wind up looking very
> similar to ForCES. In fact if you look at the proposal that Google made for
> what they were calling OF 2.0 at the time, it has quite a bit in common with
> ForCES (at the very least architecturally). I'm not sure if that proposal is
> publically available anywhere but will check.
>
> I have been spending some time examining the architectural implications of
> the OF mode (salient features are separation of control and data planes,
> open interface to the forwarding/data plane (OF), and centralized control).
> Some of my (controversial) thoughts are on
> http://www.1-4-5.net/~dmm/talks/upperside_sdn_summit_paris_2013.pdf (this is
> necessarily abbreviated; see something like
> http://www.1-4-5.net/~dmm/talks/ncrg86.pdf for the longer form...)
>

---

From: Ran Giladi <[email-masked]>
Date: Tue, 2 Apr 2013 19:15:55 +0300

You are absolutely right. When I tried to approach OF guys back then, with the notion of generalization using ForCES, as I did, and even demonstrated it to them, I received very cold shoulder. However, it is a fact that they are establishing the industry's standard, and even my company, EZchip (I'm on their board) works with them.

Later on I'll place info+code on my University server (some procedures required...)

Best, ran

Sent from my iPhone

---

From: "Joachimpillai, Damascene M" <[email-masked]>
Date: Tue, 2 Apr 2013 13:41:22 -0400

Jamal/Ran,

I strongly support this view. This was the reason why I picked up the InterFE LFB to be part of the standards. 

Regards,
DJ

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ran Giladi
Sent: Tuesday, April 02, 2013 12:16 PM
To: Jamal Hadi Salim
Cc: [email-masked]
Subject: Re: [forces] Macro Trends, Complexity, and Sofware Defined Networking WAS(Re: Your recharter proposal

Best, ran

Sent from my iPhone

On 2 באפר 2013, at 18:25, Jamal Hadi Salim <[email-masked]> wrote:

> programmability to take a closer look at Dave's presentation (the 
> longer version at http://www.1-4-5.net/~dmm/talks/ncrg86.pd);
> I enjoyed it!
> 
> As someone (technical) who is involved with ForCES and network 
> programmability for years now, i find it frustrating that we cant have 
> the ONF pay attention to ForCES (when you read some of the blogs we 
> dont even exist). We have tried to extend an olive branch in the past 
> Ive gotten back is the ONF feels like they have to create things so 
> the "IPR" is owned there. Given there are no know IPR issues known 
> with ForCES, i didnt see what the issue is. Maybe i am not getting it 
> since I dont attend ONF meetings.
> 
> cheers,
> jamal
> 
>> I have been arguing that if OpenFlow evolves past 1.0 (basically L2 
>> only) and 1.1+ (multi-table 1.0 with additional protocol features and 
>> which basically unimplementable on ASIC h/w), then it will wind up 
>> looking very similar to ForCES. In fact if you look at the proposal 
>> that Google made for what they were calling OF 2.0 at the time, it 
>> has quite a bit in common with ForCES (at the very least 
>> architecturally). I'm not sure if that proposal is publically available anywhere but will check.
>> 
>> I have been spending some time examining the architectural 
>> implications of the OF mode (salient features are separation of 
>> control and data planes, open interface to the forwarding/data plane (OF), and centralized control).
>> http://www.1-4-5.net/~dmm/talks/upperside_sdn_summit_paris_2013.pdf 
>> (this is necessarily abbreviated; see something like 
_______________________________________________
forces mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/forces