Subject: [forces] LFB Topology possible errata

From: "Haleplidis Evangelos" <[email-masked]>
Date: Wed, 5 Jun 2013 17:53:02 +0300

Greetings to the list,

Just a question regarding the LFB Topology in RFC 5812 and possibly an
errata:

In section "5.3.3. LFBTopology and LFBLinkType", page 110 it starts with:

"The optional LFBTopology component."

Is the LFB Topology optional? The xml schema of the LFB Object specify the
LFBTopology component as mandatory.

Additionally section "5.2.1 ModifiableLFBTopology", page 106 specifies that
if the LFB Topology is static the Supported LFBs can be inferred from the
LFB Topology, possibly meaning that it should be there.

Imho, LFB Topology is not optional, even if the LFB Topology is static. A CE
may have need to read the topology to understand the internals of the FE to
see which datapath functions are implemented.

Regards,

Evangelos Haleplidis.

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 6 Jun 2013 09:07:55 -0400

Greetings Evangelos,

On Wed, Jun 5, 2013 at 10:53 AM, Haleplidis Evangelos <[email-masked]>wrote:

> Greetings to the list,****
>
> ** **
>
> errata:****
> ** **
> In section “5.3.3. LFBTopology and LFBLinkType”, page 110 it starts with:*
> ***
>
> “The optional LFBTopology component…”****
>
> ** **
>
> LFBTopology component as mandatory.****
>
> ** **
>
> Additionally section “5.2.1 ModifiableLFBTopology”, page 106 specifies
> that if the LFB Topology is static the Supported LFBs can be inferred from
> the LFB Topology, possibly meaning that it should be there.****
>
> **
>

Yes, there's either lack of clarity and possibly a contradiction there.
I believe the schema is correct. Joel?

>  **
>
> Imho, LFB Topology is not optional, even if the LFB Topology is static. A
> CE may have need to read the topology to understand the internals of the FE
> to see which datapath functions are implemented.****
>
> **
>

In practise so far (speaking of our implementation), it hasnt been
necessary to advertise
the topology when it is not modifiable. In principle i agree that we should
always
advertise it regardless of whether it is static or modifiable.

cheers,
jamal

---

From: Joel <[email-masked]>
Date: Thu, 06 Jun 2013 10:36:38 -0400

I agree that the text is wrong and the schema is right.
Thus, an errata is appropriate.
Yours,
Joel

On 6/6/2013 9:07 AM, Jamal Hadi Salim wrote:
> Greetings Evangelos,
>
> On Wed, Jun 5, 2013 at 10:53 AM, Haleplidis Evangelos <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Greetings to the list,____
>
>     __ __
>
>     Just a question regarding the LFB Topology in RFC 5812 and possibly
>     an errata:____
>
>     __ __
>
>     In section “5.3.3. LFBTopology and LFBLinkType”, page 110 it starts
>     with:____
>
>     “The optional LFBTopology component…”____
>
>     __ __
>
>     Is the LFB Topology optional? The xml schema of the LFB Object
>     specify the LFBTopology component as mandatory.____
>
>     __ __
>
>     Additionally section “5.2.1 ModifiableLFBTopology”, page 106
>     specifies that if the LFB Topology is static the Supported LFBs can
>     be inferred from the LFB Topology, possibly meaning that it should
>     be there.____
>
>     __
>
>
>
>     __
>     Imho, LFB Topology is not optional, even if the LFB Topology is
>     static. A CE may have need to read the topology to understand the
>     internals of the FE to see which datapath functions are implemented.____
>
>     __
>
>
> the topology when it is not modifiable. In principle i agree that we
> should always
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces
>