Subject: Re: [forces] Adoption of ForCES Inter-FE LFB draft-joachimpillai-forces-interfelfb

From: Jamal Hadi Salim <[email-masked]>
Date: Sun, 4 Jan 2015 07:55:28 -0500

Sorry took this long to respond. I am about to upload a new
version of the draft addressing the issues raised and updating the
document as a WG document.

On Wed, Dec 17, 2014 at 5:52 PM, Haleplidis Evangelos <[email-masked]> wrote:
> Greetings to the list,
>
> I have read and support the adoption of this as a working group document.
> I have the following comments which are mostly editorial:
>
> 1. Please change the abstract to describe what the document is all about.
> Currently the abstract discusses the main ForCES concept and that this is a
> charter item. It needs to be changed to explicitly express the gist of the
> document.
>

Done in new version.

> 2. There are a couple of spelling errors. You can use the spell checker
> (https://tools.ietf.org/tools/idspell/webservice).
>

Done.

> 3. Please change (or remove) this line: "The new ForCES charter allows the
> LFB links in a topology to be across multiple FE (inter-FE connectivity)."
>

Done.

> 4. You should possibly discuss what will happen when two IFE LFBs under a
> different master that will set the IFETYPE component.

CE-CE sync is out of scope today. This does not change that
semantic. If we have split brain and two FEs set different things
bad things will happen.
My expectation is we will get the IEEE ethertype 0xFEFE allocated
ethertype. There will be no need for an ethertype to be set by a CE.

>Since the ethertype is
> the only way you can identify this kind of message, you might want to say
> that it must be the same to both ends. Unless you want to limit this
> document to LFBs under one master. Following on that, while you specify the
> IFETYPE on the egress, you don't have a way to say what ethertype you're
> expecting. Also, what will happen if you set an ethertype on an already
> reserved one? Should you also have a PreviousFE component?
>

I have added some text - check if you find it satisfactory; we can fix
it in the next version if it is not.

> 5. Is it possible that you can have multiple connections between two
> InterLFBs? Should this be limited to one?
>

Did you mean between two neighboring FEs?
a "connection"  is defined by at least the tuple
{dst mac, src mac, ethertype, maybe vlan tag}
So i dont see why you cant have multiple instances (or table
rows of the IFETable) between 2 neighboring FEs as long as
they are unique in those tuples.
To summarize in our implementation you can do many.

cheers,
jamal

> Regards,
> Evangelos.
>
>> -----Original Message-----
>> From: forces [mailto:[email-masked]] On Behalf Of Jamal Hadi
>> Salim
>> Sent: Wednesday, December 10, 2014 4:41 PM
>> To: [email-masked]
>> Subject: [forces] Adoption of ForCES Inter-FE LFB draft-joachimpillai-
>> forces-interfelfb
>>
>> This is a re-initialized call for adoption.
>> As per last meeting discussion and charter requirements
>> http://tools.ietf.org/html/draft-joachimpillai-forces-interfelfb
>> as the WG document for the inter FE chartered work.
>>
>> If there are any objections or suggestions please raise them on the
>> list (dont send me or DJ private email).
>> Silence implies consent.
>>
>> The initial call for adoption was withdrawn because we wanted to make
>> sure we can get the code sane to the proposed ideas.
>> We have achieved that goal at this point.
>>
>> cheers,
>> jamal
>>
>> _______________________________________________
>> forces mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/forces
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Sun, 4 Jan 2015 08:01:09 -0500

The intent is to use IANA ForCES metadata definitions. So at least
for those it is clear there will be no conflict.
The IANA definition does allow for private definitions which could be
used; in such a case the synchronization is really out of scope.
IOW, this issue has to do with CE-CE synchronization more than this
LFB. I have added text to indicate that if we had a cluster of CEs
controlling FEs, then it is expected they will synchronize their
values.

cheers,
jamal

On Fri, Dec 19, 2014 at 6:22 PM, Joel <[email-masked]> wrote:
> I support adoption of this document by the working group.  The issue
> addressed is real, and suitable for IETF standardization.  The mechanisms
> described seems appropriate to the task.
>
> Once adopted, as Evangelos suggested, the working group should decide how to
> handle the case of inter-FE with the FEs controlled by different CEs.  I see
> two choices, either of which is reasonable.  We can declare that the scope
> is only inter-FE under control of a single CE, or we can declare that if
> there are two CEs they must agree out-of-band on the IDs for metadata.  (The
> one solution I would like to avoid is specifying a metadata rewrite function
> to transform the IDs at the border.)
>
> Yours,
> Joel
>
> On 12/10/14 9:40 AM, Jamal Hadi Salim wrote:
>>
>> If there are any objections or suggestions please raise them
>> on the list (dont send me or DJ private email).
>> Silence implies consent.
>>
>> The initial call for adoption was withdrawn because we wanted
>> to make sure we can get the code sane to the proposed ideas.

---

From: Joel <[email-masked]>
Date: Sun, 04 Jan 2015 11:01:58 -0500

That seems a good resolution to me.  Thank you.
Joel