Subject: Ftp-WG: Proposed changes to MLST -15 (will be -16)

From: Jeffrey Altman <[email-masked]>
Date: Mon, 22 Jul 2002 00:12:08 -0500

> > It should be addressed, but I'm not sure about the best
> > solution. Non-shortest UTF-8 is supposed to be illegal, so
> > it might be advisable to adopt parts of the NVT processing
> > for the MLSD data connection: transmit <NUL> after <CR>
> > unless that <CR> starts the regular EOL sequence.
> 
> The parts of NVT processing you're refering to indicate that <CR> <NUL> is
> the Telnet End-of-Line.

End of Line is <CR> <LF>.  <CR> <NUL> is simply <CR> by itself.  The
reason for the <NUL> is to allow for well defined state machines that
do not have to wait an arbitrary time period for the next character to
arrive.

 Jeffrey Altman * Sr.Software Designer     Kermit 95 2.0 GUI available now!!!
 The Kermit Project @ Columbia University  SSH, Secure Telnet, Secure FTP, HTTP
 http://www.kermit-project.org/            Secured with MIT Kerberos, SRP, and 
 [email-masked]               OpenSSL.

---

From: "Gregory A Lundberg" <[email-masked]>
Date: Mon, 22 Jul 2002 06:28:28 -0500

> End of Line is <CR> <LF>.

*ONE* of the forms of end-of-line is <CR> <LF>.

> <CR> <NUL> is simply <CR> by itself.

Correct.

> The reason for the <NUL> is to allow for well defined
> state machines that do not have to wait an arbitrary
> time period for the next character to arrive.

Marginally correct.

The fact remains, however, that <CR> <NUL> is specifically stated to be
*ONE* of the forms of end-of-line in the Telnet specifications.