Subject: Ftp-WG: FEAT UTF-8 in review

From: Pat LaVarre <[email-masked]>
Date: Fri, 19 Jul 2002 09:06:41 -0500

> > > LF as Telnet end-of-line
...

> From: Gregory A Lundberg
> ... Actually, it could be,

1)

Then it is permissible for the default local
configuration to accept LF as a TELNET end-of-line.

2)

And given this is permissible, then it is also
appropriately liberal, because enough actual Ftp
clients/servers are by default configured to accept LF
as EOL that working to discover which are rude enough
to send LF as EOL is not a useful way to spend time.

3)

Or have I misunderstood?  Thanks again in advance, Pat
LaVarre

-----Original Message-----
From:	Gregory A Lundberg [mailto:[email-masked]]
Sent:	Thu 7/18/2002 5:41 PM
To:	FTPEXT Working Group
Cc:	
Subject:	Ftp-WG: FEAT UTF-8 in review

> > Clients & servers should also liberally accept LF
as
> > Telnet end-of-line, yes?
>
> No.  This is not a telnet end of line

Actually, it could be, but to be one required both
ends to have been locally configured to accept it as
such; which the TELNET protocol allows.  Basically,
TELNET end-of-line is whatever you want it to be, so
long as it does not conflict with the 96 displayable
ASCII characters ( %x20-7E ).

[[[ Please ignore any Yahoo spam which follows. ]]]

__________________________________________________
Do You Yahoo!?
Yahoo! Autos - Get free new car price quotes
http://autos.yahoo.com

---

From: "Gregory A Lundberg" <[email-masked]>
Date: Fri, 19 Jul 2002 21:14:24 -0500

> configuration to accept LF as a TELNET end-of-line.

Permissible, yes.  But the required minimum does not include LF to mean
end-of-line.

> to send LF as EOL is not a useful way to spend time.

As I read it, a server could be configured that way, but I would expect few,
if any users to expect that to be the case.  I would say it would be an
'agreed upon' option, where agreement could be out-of-band, such as an
administrative requirement.