Subject: Ftp-WG: ZLIB compressed transmission mode

From: "Jeff Preston" <[email-masked]>
Date: Mon, 14 Jul 2003 10:14:29 -0500

We are looking at developing a compressed FTP transmission mode to save
bandwidth in mobile/wireless and embedded environments. The 'right thing to
do' is to use open standards, such as the zlib compression library, and work
with other developers to propose a FTP extension. Is anyone else working on
a light-weight lossless compression extension? 

Best regards,

Jeff Preston

---
Jeff Preston
Noisette Software Corporation
e: [email-masked]
w: www.noisette-software.com

---

From: "Alun Jones" <[email-masked]>
Date: Mon, 14 Jul 2003 11:25:27 -0500

> -----Original Message-----
> From: ftp-wg-owner [mailto:[email-masked]] On 
> Behalf Of Jeff Preston
> 
> We are looking at developing a compressed FTP transmission 
> mode to save bandwidth in mobile/wireless and embedded 
> environments. The 'right thing to do' is to use open 
> standards, such as the zlib compression library, and work 
> with other developers to propose a FTP extension. Is anyone 
> else working on a light-weight lossless compression extension? 

A 'semi-standard' on behalf of the WU-FTPD software is that the user can ask
for "file.Z" or "file.zip", and the server will compress the file in that
format (unless file.Z or file.zip exist already, of course).

Alun.
~~~~

-- 
Texas Imperial Software   | Find us at http://www.wftpd.com or email
1602 Harvest Moon Place   | [email-masked].
Cedar Park TX 78613-1419  | WFTPD, WFTPD Pro are Windows FTP servers.
Fax/Voice +1(512)258-9858 | Try our NEW client software, WFTPD Explorer.