Subject: [ftpext] FTP64 LANGuage [was RE: [BEHAVE] one week WGLC, draft-ietf-behave-ftp64-05]

From: "Dan Wing" <[email-masked]>
Date: Mon, 3 Jan 2011 12:38:50 -0800

> Maybe at this point in the discussion it would be good to hear from
> implementers. There are already tons of NAT44 FTP ALGs out there, I
> wonder how those solve this.

For whatever it's worth, I checked the FTP ALG for NAT44 in Cisco's
IOS, and it does nothing special with LANG (it doesn't block the
command nor parse the FEAT response).  We have other ALGs in other
products (e.g., Linksys, ASA), but I did not check those.  Our bug 
database (which spans all Cisco-branded products) has no customer 
complaints about FTP's LANG support.

-d

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 5 Jan 2011 15:19:29 +0100

> complaints about FTP's LANG support.

Apparently nobody else can muster up the energy to care about this.

I'm ok with adding a SHOULD for supporting LANG in the ALG so that if a server and client negotiate a non-default language the ALG also participates. This assumes the ALG supports the negotiated language, but I'm thinking that if the server and client support a non-default language, there's a good chance that the ALG vendor either added this language too, or allowed sufficient customization for the user to do this. The ALG only has 10 or so responses that it can generate, after all.

But for the reasons I outlined earlier, I'm still very reluctant to make this a MUST. Seeing as the FTP44 ALG people apparently managed to do without this, such a requirement runs a big risk of becoming a dead letter, anyway. There's enough of that when it comes to FTP specifications...

Iljitsch

---

From: Dave Thaler <[email-masked]>
Date: Wed, 5 Jan 2011 16:11:40 +0000

Question to FTPEXT:

Given that many NAT44's that have FTP ALG don't allow LANG to work correctly,
and we haven't seen any responses from FTPEXT folks arguing that it's
important, should the Behave WG consider LANG support in RFC 2640 to be 
unimportant?  Is it basically dead?

If so, I'm fine with a SHOULD in the FTP64 doc.   And I agree with Iljitsch's
implication that the recommendation for FTP64 ALGs should be the same
as whatever the recommendation for other FTP ALGs (e.g. in NAT44's) is.

-Dave

> -----Original Message-----
> From: Iljitsch van Beijnum [mailto:[email-masked]]
> Sent: Wednesday, January 05, 2011 6:19 AM
> To: Dan Wing
> Cc: Dave Thaler; [email-masked]; [email-masked];
> 'Behave WG'
> Subject: Re: FTP64 LANGuage [was RE: [BEHAVE] one week WGLC, draft-ietf-
> behave-ftp64-05]
> 
> I'm ok with adding a SHOULD for supporting LANG in the ALG so that if a server
> and client negotiate a non-default language the ALG also participates. This
> assumes the ALG supports the negotiated language, but I'm thinking that if the
> server and client support a non-default language, there's a good chance that the
> ALG vendor either added this language too, or allowed sufficient customization
> for the user to do this. The ALG only has 10 or so responses that it can generate,
> after all.
> 
> But for the reasons I outlined earlier, I'm still very reluctant to make this a
> MUST. Seeing as the FTP44 ALG people apparently managed to do without this,
> such a requirement runs a big risk of becoming a dead letter, anyway. There's
> enough of that when it comes to FTP specifications...
> 
> Iljitsch

---

From: Fred Baker <[email-masked]>
Date: Wed, 5 Jan 2011 11:32:19 -0800

On Jan 5, 2011, at 8:11 AM, Dave Thaler wrote:

> I agree with Iljitsch's implication that the recommendation for FTP64 ALGs should be the same as whatever the recommendation for other FTP ALGs (e.g. in NAT44's) is.

Yes.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 5 Jan 2011 22:40:45 +0100

On 5 jan. 2011, at 17:11, Dave Thaler <[email-masked]> wrote:

> And I agree with Iljitsch's

Failing to quit while I'm ahead...

Are there any FTP44 ALG recommendations?

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 5 Jan 2011 15:42:41 -0800

> Are there any FTP44 ALG recommendations?

I am only aware of
http://tools.ietf.org/html/rfc3027#section-4.1

-d

---

From: Dave Thaler <[email-masked]>
Date: Thu, 6 Jan 2011 01:57:17 +0000

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Dan Wing
> Sent: Wednesday, January 05, 2011 3:43 PM
> To: 'Iljitsch van Beijnum'; Dave Thaler
> Cc: [email-masked]; [email-masked]; 'Behave WG'
> Subject: Re: [BEHAVE] FTP64 LANGuage [was RE: one week WGLC, draft-ietf-
> behave-ftp64-05]
> 

In the interest of making progress on FTP64...

Given that the LANG/FEAT problem is not specific to FTP64 but applies to
44 ALGs (or any other type of FTP ALG for that matter), I think this problem
is probably best addressed outside of the FTP64 spec itself, and if an answer
existed in another doc, the FTP64 spec would just refer to it.

As such, I think I am ok with not solving the problem in the FTP64 spec,
and leaving it for future work.  However, I would like to see a note 
to that effect added to FTP64.   In other words, I can live with it being
unspecified in FTP64 as long as FTP64 calls out the issue and says it's left
for future work and points out that it's not specific to a 64 case.

While that may result in bad behavior, it's no worse than the situation
we're already in today where LANG behavior is somewhere between 
broken and "unexpected".   In my opinion, the FTPEXT group should 
then decide what it wants to do about LANG (rev RFC 2640 or ignore 
the problem or whatever else).

-Dave