Subject: Re: [ftpext] New Version of FTP HASH, RANG, LOCK, and HOST

From: Alun Jones <[email-masked]>
Date: Mon, 28 Jan 2013 09:00:33 -0800

Was there a reason not to simply use RANG without parameters? Or even 0 0 (which would mean no bytes to be transferred), if you insist that the command has to have two numbers.

-----Original Message-----
From: Tatsuhiro Tsujikawa
Sent: 1/28/2013 8:45 AM
To: Alun Jones
Cc: Anthony Bryan; [email-masked]
Subject: Re: [ftpext] New Version of FTP HASH, RANG, LOCK, and HOST

Hi,

On Mon, Jan 28, 2013 at 9:01 AM, Alun Jones <[email-masked]> wrote:
> After reading the RANG spec, I note that there isn't anything to state what
> errors are given by RETR if the range specified is incorrect, or by STOR /
> APPE if the range specified starts more than one byte after the end of the
> existing file on the server (and therefore, presumably, incorrect?).
>
> I also think that a simple "RANG" on its own should serve to clear out the
> range on a request. "RANG 1 0" seems an arbitrary choice of numbers (why not
> "RANG 0 -1" or "RANG 0 Inf"?).
>

We discussed internally how to reset ranges set by RANG command.
First we said that "REST 0" resets ranges for RANG too. But, later we decided
not to use REST because in the future we can completely replace REST with RANG.
And we chose invalid range pattern, like "RANG 1 0"
to reset range since it is the obvious parser pattern and checking
range is very easy.
Yes, the numbers are arbitrary. We just chose them. But we avoided negative
numbers or non-digits because the range is inherently non-negative
numbers, we don't want
to make parser accept other than digits just for this.

Best regards,

Tatsuhiro Tsujikawa

> Alun.
> ~~~~
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf
>> Of Anthony Bryan
>> Sent: Sunday, January 20, 2013 9:01 AM
>> To: [email-masked]
>> Subject: [ftpext] New Version of FTP HASH, RANG, LOCK, and HOST
>>
>> we updated the FTP HASH, RANG, and LOCK drafts, while the authors of
>> HOST have updated their (hopefully final, get any comments or reviews in
>> ASAP) draft.
>>
>> we are mostly interested in finishing up HASH & RANG, but also feel free
> to
>> comment on LOCK. fancy diffs are available. HASH, RANG, & LOCK changes
>> are all editorial or just updating the draft.
>>
>>
>> HASH FTP command to be used by clients to request cryptographic hashes of
>> files.
>> http://tools.ietf.org/html/draft-bryan-ftpext-hash
>>
>>
>> RANG command to be used by clients to designate a start and end point to
>> permit restarts and repairs of interrupted data transfers in STREAM mode.
>> http://tools.ietf.org/html/draft-bryan-ftp-range
>>
>>
>> LOCK command to be used by clients to request the server to use the
> control
>> connection for data transfers, using a single port instead of two.
>> http://tools.ietf.org/html/draft-bryan-ftp-lock
>>
>>
>> also, HOST has been updated:
>>
>> FTP command that provides a mechanism for FTP clients and servers to
>> identify individual virtual hosts on an FTP server.
>>
>> http://datatracker.ietf.org/doc/draft-hethmon-mcmurray-ftpext-ftp-hosts/
>> http://tools.ietf.org/html/draft-hethmon-mcmurray-ftpext-ftp-hosts (diffs)
>>
>> --
>> (( Anthony Bryan ... Metalink [ http://www.metalinker.org ]
>>   )) Easier, More Reliable, Self Healing Downloads
>> _______________________________________________
>> ftpext mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ftpext
>
> _______________________________________________
> ftpext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ftpext

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Tue, 29 Jan 2013 02:21:25 +0900

Hi,

On Tue, Jan 29, 2013 at 2:00 AM, Alun Jones <[email-masked]> wrote:
> Was there a reason not to simply use RANG without parameters? Or even 0 0
> (which would mean no bytes to be transferred), if you insist that the
> command has to have two numbers.
>

We chose 2 numbers solution just for make the parser easier: it always
gets 2 numbers,
without exception.
Because 2nd number of RANG is an end offset from the start of the file
and it is included in the transfer,
much like HTTP Range header field, "RANG 0 0" is valid command and
means transfer the
first byte (offset 0).

But I'm open to this issue now, including the choice of numbers and
without them.
What do you guys think about this?

Best regards,

Tatsuhiro Tsujikawa

________________________________