Subject: [Fud] FUD Side Meeting @ Prague IETF

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 18 Jul 2017 15:26:12 +0000

Hi all,

I have been asked by a few IETF participants whether we should get together this week to talk about firmware updates for IoT devices (as a follow-up of what we did at the Chicago IETF meeting).

I am proposing to meet Thursday, 9:30am in the Istanbul room (at the L level). I have reserved the room till 12:00.

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Emmanuel Baccelli <[email-masked]>
Date: Tue, 18 Jul 2017 17:30:11 +0200

Hi Hannes,
thanks for the initiative. I could join at that time.
Best,
Emmanuel

On Tue, Jul 18, 2017 at 5:26 PM, Hannes Tschofenig <
[email-masked]> wrote:

> Hi all,
>
>
>
> I have been asked by a few IETF participants whether we should get
> together this week to talk about firmware updates for IoT devices (as a
> follow-up of what we did at the Chicago IETF meeting).
>
>
>
> I am proposing to meet Thursday, 9:30am in the Istanbul room (at the L
> level). I have reserved the room till 12:00.
>
>
>
> Ciao
>
> Hannes
>
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
> _______________________________________________
> Fud mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fud
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 18 Jul 2017 22:47:35 +0200

This is the same time that YOT (Yang of Things) happens in Tyrolka.
But maybe all the people who won’t fit into that room can go to Istanbul :-)

Grüße, Carsten

> On Jul 18, 2017, at 17:26, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi all, 
>  
> IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
> Fud mailing list
> [email-masked]

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 19 Jul 2017 07:56:48 +0000

It is difficult to find a timeslot that does has no conflict at an IETF meeting, as you know.
I guess I will have to catch up on the Yang of Things afterwards.

Ciao
Hannes

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]]
Sent: 18 July 2017 22:48
To: Hannes Tschofenig
Cc: [email-masked]
Subject: Re: [Fud] FUD Side Meeting @ Prague IETF

Grüße, Carsten

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 19 Jul 2017 11:03:01 +0200

Hi, Hannes,

> It is difficult to find a timeslot that does has no conflict at an IETF

Tell me about it. I won't be in either FUD or YoT, and I'm still
double-booked!

Best wishes, and please do send a summary of your conversation to the list,
for those of us with prior commitments.

Spencer

> information in any medium. Thank you. ______________________________
> _________________
> > Fud mailing list
> > [email-masked]

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 19 Jul 2017 11:13:40 +0200

Hello FUD'ler,

again I am sorry that I cannot join, but I am in a session where I have 
3 presentation at that time.

If you actually deciding to meeting at this session slot, I would like 
to ask you to have a extensive look at:

> https://tools.ietf.org/html/draft-ietf-sacm-coswid-02#page-14

"CoSWID Attributes for Firmware "

There is a resource description type for firmware that can even include 
the corresponding firmware and act as a transport container. It - of 
course -  includes the complete expressiveness of ISO-19770-2:2015 and 
is therefore inter-operable in regard to the corresponding metadata that 
overlaps with "normal software" and can be processed by any system that 
already understands the semantics of ISO SWID documents.

Viele Grüße,

Henk

On 07/18/2017 05:26 PM, Hannes Tschofenig wrote:
> contents to any other person, use it for any purpose, or store or copy 
> the information in any medium. Thank you.
> 
>

---

From: Trishank Karthik Kuppusamy <[email-masked]>
Date: Wed, 19 Jul 2017 14:38:56 -0400

Hello everyone,

We're from The Update Framework (TUF) project [
https://theupdateframework.github.io/], where we are concerned with
attackers who compromise the software repository used to host and
distribute software updates, and thus distribute and install malware onto
millions of devices at once.

Would it be possible for us to join this meeting remotely? We are in the
EST time zone. Thanks in advance!

Regards,
Trishank

On Wed, Jul 19, 2017 at 5:13 AM, Henk Birkholz <
[email-masked]> wrote:

> Hello FUD'ler,
>
> again I am sorry that I cannot join, but I am in a session where I have 3
> presentation at that time.
>
> If you actually deciding to meeting at this session slot, I would like to
> ask you to have a extensive look at:
>
> the corresponding firmware and act as a transport container. It - of course
> -  includes the complete expressiveness of ISO-19770-2:2015 and is
> therefore inter-operable in regard to the corresponding metadata that

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 20 Jul 2017 14:54:49 +0200

Hi Trishank,

thanks for sharing the pointer to your work with this group. I will read
through asap.

Regarding this specific meeting: it was just an informal chat among
interested parties attending the IETF meeting. So, we had no remote
participation capabilities but I will share a few notes with the group.

The plan is to have an official session at the next IETF meeting where
we will be able to offer remote participation capabilities.

Ciao
Hannes

On 07/19/2017 08:38 PM, Trishank Karthik Kuppusamy wrote:
> Hello everyone,
> 
> We're from The Update Framework (TUF) project
> [https://theupdateframework.github.io/], where we are concerned with
> distribute software updates, and thus distribute and install malware
> onto millions of devices at once.
> 
> On Wed, Jul 19, 2017 at 5:13 AM, Henk Birkholz
> <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Hello FUD'ler,
> 
>     again I am sorry that I cannot join, but I am in a session where I
>     have 3 presentation at that time.
> 
>     If you actually deciding to meeting at this session slot, I would
>     like to ask you to have a extensive look at:
> 
>         <https://tools.ietf.org/html/draft-ietf-sacm-coswid-02#page-14>
> 
> 
>     There is a resource description type for firmware that can even
>     include the corresponding firmware and act as a transport container.
>     It - of course -  includes the complete expressiveness of
>     ISO-19770-2:2015 and is therefore inter-operable in regard to the
>     corresponding metadata that overlaps with "normal software" and can
>     be processed by any system that already understands the semantics of
>     ISO SWID documents.
> 
>     Viele Grüße,
> 
>     Henk
> 
> 
>         I have been asked by a few IETF participants whether we should
>         get together this week to talk about firmware updates for IoT
>         devices (as a follow-up of what we did at the Chicago IETF meeting).
> 
>         I am proposing to meet Thursday, 9:30am in the Istanbul room (at
>         the L level). I have reserved the room till 12:00.
> 
>         Ciao
> 
>         Hannes
> 
>         IMPORTANT NOTICE: The contents of this email and any attachments
>         are confidential and may also be privileged. If you are not the
>         intended recipient, please notify the sender immediately and do
>         not disclose the contents to any other person, use it for any
>         purpose, or store or copy the information in any medium. Thank you.
> 
> 
>         [email-masked] <mailto:[email-masked]>
>         <https://www.ietf.org/mailman/listinfo/fud>
> 
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/fud>
> 
> 
> 
>