Subject: [Fud] First drafts about the firmware update description

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 18 Jul 2017 09:02:40 +0000

Hi all,

It took a little bit of time to put a write-up about the work we have been doing at ARM in the area of firmware updates together. We finally managed to submit the IETF drafts.

There are two documents:

1)      The first document describes the high-level architecture of a firmware update service for IoT devices, see
https://tools.ietf.org/html/draft-moran-fud-architecture-00

2)      The second document focuses on specifying the firmware update description. We call this the "manifest".
https://tools.ietf.org/html/draft-moran-fud-manifest-00

We would like to have the IETF community to work on a standard for a manifest. Silicon partners and those developing IoT operating systems have developed their own formats and we hope they can also share what they have been doing.

Feedback on the documents is appreciated!

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Francisco Javier Acosta Padilla <[email-masked]>
Date: Tue, 18 Jul 2017 13:11:14 +0200

Hi Hannes! Thanks a lot for the submission.

I’m looking at the documents, for now I only have grammar and syntax feedback (small nitpicks), but I’ll try to give more feedback on the contents. However, how and/or where can we submit the feedback?

Best,

-- 
Francisco Javier Acosta Padilla
Research Engineer at INRIA Saclay
INFINE Team

On 18 July 2017 at 11:02:53, Hannes Tschofenig ([email-masked]) wrote:

Hi all,

There are two documents:

2)      The second document focuses on specifying the firmware update description. We call this the “manifest”.

Ciao

Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________  
Fud mailing list  
[email-masked]  
https://www.ietf.org/mailman/listinfo/fud

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 18 Jul 2017 14:08:30 +0000

Hi Francisco,

please post your comments on this mailing list.

Ciao
Hannes

From: Francisco Javier Acosta Padilla [mailto:[email-masked]]
Sent: 18 July 2017 13:11
To: Hannes Tschofenig; [email-masked]
Subject: Re: [Fud] First drafts about the firmware update description

Best,

On 18 July 2017 at 11:02:53, Hannes Tschofenig ([email-masked]<mailto:[email-masked]>) wrote:
Hi all,

There are two documents:

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you. _______________________________________________
Fud mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/fud
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.