Subject: [Fud] Revised Charter Text

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 25 Sep 2017 20:07:19 +0200

Based on the feedback following the IETF meeting in Prague I have
updated the charter text.

Ciao
Hannes

----

Firmware Updating Description (FUD)
[Alternative proposal: SUIT (Software Updates for Internet of Things).]

Vulnerabilities with Internet of Things (IoT) devices have raised the
need for a secure firmware update mechanism that is also suitable for
constrained devices. Security experts, researchers and regulators
recommend that all IoT devices are equipped with such a mechanism. While
there are many proprietary firmware update mechanisms in use today there
is a lack of a modern interoperable approach of securely updating IoT
devices.

A firmware update solution consists of several components, including
* a mechanism to transport firmware images to IoT devices,
* a manifest that provides meta-data about the firmware image
  (such as a firmware package identifier, the hardware the package
   needs to run, dependencies on other firmware packages, etc.) as
   well as cryptographic information for protecting the firmware
   image in an end-to-end fashion, and
* the firmware image itself.

With RFC 4108 the IETF standardized a manifest format that uses the
Cryptographic Message Syntax (CMS) to protect firmware packages.

Since the publication of RFC 4108 more than 10 years have passed and
more experience with IoT deployments have lead to additional
functionality requiring the work done with RFC 4108 to be revisited. The
purpose of this group is to standardize a version 2 of RFC 4108 that
reflects best current practices. This group focuses on defining a
firmware update solution for Class 1 devices, as defined in RFC 7228,
i.e., IoT devices with ~10 KiB RAM and ~100 KiB flash. This group
will not define any transport mechanism.

In 2016 the Internet Architecture Board organized a workshop on
'Internet of Things (IoT) Software Update (IOTSU)', which took place at
Trinity College Dublin, Ireland on the 13-14 June 2016. The
main goal of the workshop was to foster a discussion on requirements,
challenges and solutions for bringing software and firmware updates to
IoT devices. This workshop also made clear that there are challenges
with lack of regulatory requirements, and misaligned incentives. It is
nevertheless seen as important to standardize the building blocks that
help interested parties to implement and deploy a solid firmware update
mechanism.

In particular this group aims to publish two documents, namely
 * an IoT firmware update architecture that includes a description of
the involved entities, security threats and assumptions, and
 * the manifest format itself.

This group does not aim to standardize a generic software update
mechanism used by rich operating systems, like Linux, but instead
focuses on software development practices in the embedded industry.
Software update solutions that aim to take the features of scripting
languages, such as JavaScript variants like JerryScript, into account
are also outside the scope of this group.

This group will aim to develop a close relationship with silicon vendors
and OEMs that develop IoT operating systems.

Milestones

Dec 2017     Submit "Architecture" document as WG item.

Dec 2017     Submit "Manifest Format" specification as WG item.

Jul 2018    Submit "Architecture" to the IESG for publication as an
Informational RFC.

Nov 2018     Submit "Manifest Format" to the IESG for publication as a
Proposed Standard.

Additional calendar items:

Mar 2018     Release initial version of the manifest creation tools as
open source.

Apr 2018     Release first version of manifest test tool suite as open
source.

Jun 2018     Release first IoT OS implementation of firmware update
mechanisms as open source.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 26 Sep 2017 13:23:30 +0200

> [Alternative proposal: SUIT (Software Updates for Internet of Things).]

SUIT is so much better than FUD.

(When we created the DICE working group, which was about “Improvements to DTLS for the Internet of Things”, we got some strong feedback that people weren’t going to install “IDIOT” modifications into their systems.
I think the same applies for “FUD”.  And the suits will quickly agree with installing SUIT :-))

> The
> purpose of this group is to standardize a version 2 of RFC 4108

I think this (part of the) sentence can be misunderstood, and it does not mesh with the rest of the charter.

The possible misunderstanding of this sentence is that this is going to be a “let’s fix the bugs in and make some tweaks to RFC 4108” WG.

The rest of the charter does not say this, but misunderstanding that sentence may make people read that rest under the presumption that bugfixing/tweaking RFC 4108 is all that is going to happen.

Grüße, Carsten

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 26 Sep 2017 18:41:56 +0200

Hi Carsten

for us RFC 4108 served as a great starting point since it contains a lot
of well thought components. But that's just us.

So, the question is what updated sentence would you suggest?

Ciao
Hannes

On 09/26/2017 01:23 PM, Carsten Bormann wrote:
> _______________________________________________
> Fud mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fud
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 26 Sep 2017 18:45:17 +0200

FWIW: SUIT (Software Updates for Internet of Things) is totally fine for
me. Finding the right name for a group or a protocol is always tricky.

---

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Tue, 26 Sep 2017 16:53:51 +0000

If we do make the change to SUIT, we will need to request a new Datatracker page. Changing the name to "Firmware Updating Description" does not require a new Datatracker page.

FWIW, once the RFCs we produce are published, the name FUD, SUIT, or anything else will be less relevant and does not need to be mentioned in any of the produced documents. This makes me less concerned about what we call the WG.

Regards,
Dave

> -----Original Message-----
> From: Fud [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
> Sent: Tuesday, September 26, 2017 12:45 PM
> To: Carsten Bormann <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Fud] Revised Charter Text
> 
> FWIW: SUIT (Software Updates for Internet of Things) is totally fine for me.
> Finding the right name for a group or a protocol is always tricky.
> 
> > (When we created the DICE working group, which was about
> “Improvements to DTLS for the Internet of Things”, we got some strong
> feedback that people weren’t going to install “IDIOT” modifications into their
> systems.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 26 Sep 2017 18:59:46 +0200

> On Sep 26, 2017, at 18:41, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi Carsten
> 

There is no doubt about RFC 4108 being a good input.

Let me try explain my point in an analogy: if the QUIC WG had said it wants to do TLS 1.4, there might have been about the same misunderstanding (and QUIC certainly does use TLS as a great starting point).

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 26 Sep 2017 19:09:28 +0200

> FWIW, once the RFCs we produce are published, the name FUD, SUIT, or anything else will be less relevant and does not need to be mentioned in any of the produced documents. This makes me less conce…

While that is theoretically true, that is not the way things work out in practice — people still call TLS “SSL” because that was the name the technology was referred to before 1999 (1996, actually).  We will need to do marketing for the WG's output *before* it has an RFC number, and being able to call it SUIT in that marketing does help.
(A new data tracker page is relatively low effort compared to fixing up marketing material.)

(And no, we shouldn’t have a FUD WG producing the SUIT protocol, just as we shouldn’t have suits producing FUD :-)

Grüße, Carsten

(Says someone who is not innocent for calling a WG CoRE that then went on producing the CoAP protocol.)

---

From: Michael Richardson <[email-masked]>
Date: Tue, 26 Sep 2017 19:05:35 -0400

> me. Finding the right name for a group or a protocol is always tricky.

It's really an awesome name.
My koodos to whomever came up with it.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Russ Housley <[email-masked]>
Date: Wed, 27 Sep 2017 17:17:15 -0400

> I think the same applies for “FUD”.  And the suits will quickly agree with installing SUIT :-))

I am chairing two groups where the WG got a different name than the BoF.  In both cases, the mail list continues to have the BoF name, and it causes confusion.  If the WG gets called something other than FUD, I strongly recommend closing this mail list and opening one that is named the same as the WG.

Russ