Subject: Re: [Gendispatch] I-D Action: draft-eggert-bcp45bis-01.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 30 Mar 2021 08:59:34 +1300

Thanks for this, it looks good. One small point:

>  *  Questions and clarifications concerning IETF meetings, although	
>  most of these topics are better brought up on the discussion list	
>  for IETF LLC administrative issues [ADMIN-DISCUSS] or the attendee	
>  discussion list for a given IETF meeting, such as	
>  [IETF110-ATTENDEES] for IETF-110.

However, since not everybody attends IETF meetings, and therefore
not everybody is on the attendee lists, we should be clear that
messages like "we are going to discuss the very interesting topic X
at the next IETF meeting" do IMHO still belong on the IETF list. The
previous bullet in the draft already says this, but maybe we could
reove any doubt by having this bullet start:

* Questions and clarifications concerning practical aspects of IETF meetings...

Regards
   Brian Carpenter

On 30-Mar-21 00:58, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : IETF Discussion List Charter
>         Author          : Lars Eggert
> 	Filename        : draft-eggert-bcp45bis-01.txt
> 	Pages           : 6
> 	Date            : 2021-03-29
> 
> Abstract:
>    The Internet Engineering Task Force (IETF) discussion mailing list
>    furthers the development and specification of Internet technology
>    through the general discussion of topics for which no dedicated
>    mailing lists exists.  As this is the most general IETF mailing list,
>    considerable latitude is allowed.  Advertising, whether to solicit
>    business or promote employment opportunities, falls well outside the
>    range of acceptable topics, as do discussions of a personal nature.
> 
>    This document obsoletes RFC3005.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/
> 
> There is also an HTML version available at:
> https://www.ietf.org/archive/id/draft-eggert-bcp45bis-01.html
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-eggert-bcp45bis-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Mar 2021 09:56:54 +0300

Hi,

> * Questions and clarifications concerning practical aspects of IETF meetings...

thanks, that is a good suggestion!

Thanks,
Lars

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 30 Mar 2021 18:05:06 +1100

> * Questions and clarifications concerning practical aspects of IETF meetings...

If the intent is to makes sure that people are aware of relevant discussions, even if they're not on one of the attendee lists (and I usually decline that), it might be better to use ietf-announce@ -- e.g., in a "rollup" e-mail before the meeting, where submissions are solicited ahead of time. Or with an open calendar / wiki space (we rely on e-mail to much for stateful things anyway).

Again, ietf@ should _not_ be the default place for announcing things. It is a subset of the community.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Eliot Lear <[email-masked]>
Date: Tue, 30 Mar 2021 12:59:07 +0200

Hi,

I’d prefer to discuss fundamentals before we dispatch this draft.  The first question I think we should ask is this:

Is there an IETF community, members of which are meant to cross-fertilize ideas, such that end product is the most generally useful? OR
Are there merely disparate efforts that occasionally interact with one another, who all happen to use roughly the same processes and publication format?

If one believes the latter, then we might as well dispose of the IETF list in its entirety and perhaps let the IESG advise authors as to which dispatch function they should use, if needs be.  If one believes the former, as I do, then I would rather see the list function to address cross-cutting issues that community members would like to discuss.

Regardless, perhaps better modes for discussion (on the IETF list and elsewhere) need should be considered.  For instance, a general list might best be moderated or curated.  Let it be a bit closer to the IPJ, for instance.

Just some thoughts to chew on.

Eliot

> On 30 Mar 2021, at 09:05, Mark Nottingham <[email-masked]> wrote:
> 
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Mar 2021 14:33:46 +0300

Hi,

On 2021-3-30, at 13:59, Eliot Lear <lear=[email-masked]> wrote:
> 	• Is there an IETF community, members of which are meant to cross-fertilize ideas, such that end product is the most generally useful? OR
> 	• Are there merely disparate efforts that occasionally interact with one another, who all happen to use roughly the same processes and publication format?

I think neither of these two captures my mental model of the IETF, which is one of several (many?) communities around different technical (or administrative) topics, which are all overlapping one another to some degree or another (the topics and the communities both). The union of all these communities would be "an IETF community", as in your first bullet.

> If one believes the latter, then we might as well dispose of the IETF list in its entirety and perhaps let the IESG advise authors as to which dispatch function they should use, if needs be.  If on…

draft-eggert-bcp45bis doesn't intend to introduce any changes to the charter of [email-masked] other than those that are already in effect due to the establishment of the last-call list and other lists that have been created since BCP45 we published to be a home for recurring discussion topics. In other words, draft-eggert-bcp45bisit doesn't change the ability for the community to have cross-cutting discussions or to cross-fertilize ideas on the [email-masked] list.

(Part of the cross-fertilization, in the form of last-call reviews, now happens on the last-call list, but that change wasn't introduced by draft-eggert-bcp45bis.)

> Regardless, perhaps better modes for discussion (on the IETF list and elsewhere) need should be considered.  For instance, a general list might best be moderated or curated.  Let it be a bit closer…

I think draft-nottingham-discussion-recharter makes a pretty convincing case that [email-masked] isn't a general list for the IETF community (= the "union" I mentioned above), and probably hasn't been for quite some time.

Whether we can (re?)create such a "general" discussion forum and what shape it would take are interesting questions, but go far beyond what the purpose of draft-eggert-bcp45bis is.

Thanks,
Lars

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 30 Mar 2021 12:49:15 +0100

Hiya,

On 30/03/2021 12:33, Lars Eggert wrote:
> I think draft-nottingham-discussion-recharter makes a pretty
> convincing case [email-masked]  isn't a general list for the IETF
> community (= the "union" I mentioned above), and probably hasn't been
> for quite some time.

I don't agree that Mark's draft is convincing. I do think
the topics raised are interesting and warrant debate some
place/time, but I don't really agree with the fundamental
ideas that representation and productivity are the most
important characteristics for our broadest discussion venue.

That said, the draft in the subject line doesn't go there
and is fine.

My only quibble with draft-eggert-bcp45bis is that the
opening sentence from section 2 ("This list is meant for
initial technical discussion only.") is badly phrased
and contradicted by later text. I think it'd be better to
say "This list is not meant for detailed technical
discussion that belongs on a WG list or on it's own list,
once such a list exists." (Or, just delete the first
sentence as it's not needed.)

Cheers,
S.

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Mar 2021 14:51:43 +0300

Hi,

On 2021-3-30, at 14:49, Stephen Farrell <[email-masked]> wrote:
> and contradicted by later text.

true - it's unchanged from RFC3005 at the moment.

> I think it'd be better to

I'll come up with a better alternative.

Thanks,
Lars

---

From: Eliot Lear <[email-masked]>
Date: Tue, 30 Mar 2021 14:07:48 +0200

Hi Lars,

Just two comments for now.

> On 30 Mar 2021, at 13:33, Lars Eggert <[email-masked]> wrote:
> 
> Signed PGP part
> Hi,
> 

Sure.  And there may be other ways to look at this as well.

> draft-eggert-bcp45bis doesn't intend to introduce any changes to the charter of [email-masked] other than those that are already in effect due to the establishment of the last-call list and other l…

That’s my point.  Before we do a BCP45 update, perhaps we should ask if we should go farther, and take on Mark’s draft as well in this context, and then consider what should be done.  I like the idea of facilitated conversation.  I think it could be fun (a term not usually associated with the IETF list) but that’s me.  I’m sure others have their own ideas.

Eliot

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Mar 2021 15:58:03 +0300

Hi,

> That’s my point.  Before we do a BCP45 update, perhaps we should ask if we should go farther, and take on Mark’s draft as well in this context, and then consider what should be done.  I like the id…

I'd prefer to do a minimal update to BCP45 soon, to bring its charter back in line with its current use.

We can always revise it again, when there is consensus on more fundamental changes.

Thanks,
Lars

---

From: Eliot Lear <[email-masked]>
Date: Tue, 30 Mar 2021 15:20:10 +0200

Lars,

> On 30 Mar 2021, at 14:58, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
> 

If we have to have consensus on changes, what is the point of dispatching at all?  We might as well just go right to RFC from here.  You are setting the bar so high that we cannot even have the discussion.

Eliot

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Mar 2021 16:40:49 +0300

Hi,

On 2021-3-30, at 16:20, Eliot Lear <[email-masked]> wrote:
> If we have to have consensus on changes, what is the point of dispatching at all?  We might as well just go right to RFC from here.

it isn't clear that we have consensus for the minimal update to BCP45 that I'm trying to propose. I'm using gendispatch to get some initial feedback.

>  You are setting the bar so high that we cannot even have the discussion.

I'm sorry if I was unclear. I'm not setting any bar or stopping any discussion. If participants want to make a case for more fundamentally revamping the [email-masked] list, or replacing it with some other discussion forum, that's completely fine by me.

But that discussion will likely take some time, whereas a minimal update to bring BCP45 into alignment with current practice need not be delayed by that discussion. And if that minimal update becomes obsolete at that point, that's fine, too.

Thanks,
Lars

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 31 Mar 2021 09:03:17 +1300

> If the intent is to makes sure that people are aware of relevant discussions, even if they're not on one of the attendee lists (and I usually decline that), it might be better to use…

Sure, if it's an "official" topic that somebody with posting rights for -announce decides to publicise.
 
> Again, ietf@ should _not_ be the default place for announcing things. It is a subset of the community.

But it's the list that anybody can write to about possibly heretical ideas, including people outside the leadership bubble. (Also, BTW, ietf-announce is a shockingly small subset of the community. A lot of people apparently limit themselves to specific IETF echo chambers.)

On that topic, my own experience is that twice in my life, I have stopped reading ietf@ for about a year - once when I stepped down from the IAB, and once when I stepped down from the IESG. Both times, I felt like a break from the rather weird threads that sometimes develop there. Both times, I rejoined because I don't know a better way to hear what's on people's minds.

Regards
   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 31 Mar 2021 09:13:03 +1300

> I'd prefer to do a minimal update to BCP45 soon, to bring its charter back in line with its current use.

Yes please. And I think it can be dispatched fairly rapidly as an AD-sponsored draft, for which I hope Lars can find an AD ;-).

> We can always revise it again, when there is consensus on more fundamental changes.

Agreed, and that needs a much deeper analysis. And IMNSHO there are many much more important process issues to resolve than the occasional unruly threads on ietf@. Just to pick one at random, what can we do to prevent something like Cluster 238 ever happening again?

    Brian

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 30 Mar 2021 13:20:52 -0700

On Tue, Mar 30, 2021 at 1:13 PM Brian E Carpenter <
[email-masked]> wrote:

> >> That’s my point.  Before we do a BCP45 update, perhaps we should ask if
> we should go farther, and take on Mark’s draft as well in this context, and
> then consider what should be done.  I like the idea of facilitated
> conversation.  I think it could be fun (a term not usually associated with
> the IETF list) but that’s me.  I’m sure others have their own ideas.
> >
> Yes please. And I think it can be dispatched fairly rapidly as an
> AD-sponsored draft, for which I hope Lars can find an AD ;-).
>
> >
> Agreed, and that needs a much deeper analysis. And IMNSHO there are many
> much more important process issues to resolve than the occasional unruly
> threads on ietf@. Just to pick one at random, what can we do to prevent
> something like Cluster 238 ever happening again?
>

This is a bit hard to answer without having a clearer statement
of what went wrong with C238.

I could imagine several objections here:

- We shouldn't have projects which require changes to large
  chunks of the protocol suite.

- We shouldn't have to publish all the documents in those
  projects simultaneously.

- It's hard for the RPC to manage the simultaneous publication
  of all those documents.

- Something else?

It seems like each of these might have different solutions.

-Ekr

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 31 Mar 2021 11:06:22 +1300

Off topic, but just to clarify my intention:

On 31-Mar-21 09:20, Eric Rescorla wrote:
> 
> 
> On Tue, Mar 30, 2021 at 1:13 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
...
> of what went wrong with C238.

There's a partial analysis at https://www.ietf.org/blog/webrtc-pandemic/

> It seems like each of these might have different solutions.

Indeed, and some of them are related to the old question of how to
dynamically document complex standards with components at different
maturity levels. My real question is: are we going to duck the hard
questions about the IETF standards process?

    Brian

---

From: Christian Huitema <[email-masked]>
Date: Tue, 30 Mar 2021 15:59:15 -0700

I think this draft needs, at a very minimum, an editing pass. The 
problem starts with the first paragraph:

    The IETF discussion list [IETF-DISCUSS] furthers the development and
    specification of Internet technology through the general discussion
    of topics for which no dedicated mailing lists exists.  As this is
    the most general IETF mailing list, considerable latitude is allowed.

OK. So you are telling us that there is this discussion list, and "considerable latitude is allowed".
But that's not quite the point of the draft. Indeed, the next sentence says:

  Advertising, whether to solicit business or promote employment
    opportunities, falls well outside the range of acceptable topics, as
    do discussions of a personal nature.

Why do we have to say that in the introduction? What is this document that jumps from latitude
to, by the way, no advertising? I think there is something missing. The very purpose of the
document appears to be, "considerable latitude is allowed, but there are limits. In the
following section, we explain these limits, and the processes used to enforce them."

And then we can have an open discussion about what the limits shall be. Advertising, tone and
code of conduct, overlap with WG lists, etc.

-- Christian Huitema

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 31 Mar 2021 17:12:02 +1100

> important characteristics for our broadest discussion venue.

If that's what you got from my draft, I didn't communicate well.

I want to be informed about new topics of interest in the IETF, whether they're announcements by leadership or discussions instigated by the community. However, IME the ietf@ list is a horrible venue for both tasks. Some will undoubtedly debate that, and I'm not really interested in convincing them. However, I feel quite strongly that ietf@ cannot and should not ever be considered the _canonical_ place for such tasks -- i.e., no one should ever be able to say 'well, it was discussed on ietf@, it's your fault you weren't there.'

One of the ways we can assure that it isn't considered as such is to establish alternatives. For example, we could set up a Discourse instance <https://www.discourse.org> for people to ask IETF-wide questions, make proposals, or circulate ideas informally. With proper moderation, categorisation, and tagging, I suspect it would be a much more broadly used facility than the IETF list.

Cheers,

---

From: Lars Eggert <[email-masked]>
Date: Wed, 31 Mar 2021 10:19:40 +0300

Hi,

On 2021-3-31, at 1:59, Christian Huitema <[email-masked]> wrote:
> I think this draft needs, at a very minimum, an editing pass. The problem starts with the first paragraph:
> 
> to, by the way, no advertising?

FWIW, that text is unchanged from RFC3005.

> I think there is something missing. The very purpose of the

I'll try to reflect this suggestion in the text.

Thanks,
Lars