Subject: [Gendispatch] Agenda item request

From: "Salz, Rich" <[email-masked]>
Date: Wed, 20 Oct 2021 14:37:09 +0000

I would like to have this on the next GENDISPATCH agenda.

    Name:		draft-rsalz-termlimits
    Revision:	00
    Title:		Term limits for IETF Leadership Positions
    Document date:	2021-10-20
    Group:		Individual Submission
    Pages:		3
    URL:            https://www.ietf.org/archive/id/draft-rsalz-termlimits-00.txt 
    Status:         https://datatracker.ietf.org/doc/draft-rsalz-termlimits/ 
    Html:           https://www.ietf.org/archive/id/draft-rsalz-termlimits-00.html 
    Htmlized:    https://datatracker.ietf.org/doc/html/draft-rsalz-termlimits 

    Abstract:
       This document says that nobody can be picked by NomCom for a position
       more than two consecutive terms.

       It obsoletes some other documents, which ones are TBD.

    Discussion Venues

       This note is to be removed before publishing as an RFC.

       Source for this draft and an issue tracker can be found at
       https://github.com/richsalz/draft-rsalz-termlimits

    The IETF Secretariat

---

From: John C Klensin <[email-masked]>
Date: Wed, 20 Oct 2021 12:54:03 -0400

I concur with Rich's request and favor a discussion but, if we
are going to do that, I request that draft-klensin-nomcom-term
(yes, from 2005-2006) be added as well.  Unless Spencer has
vigorous objections, I'll try to find the original and get a
version with current dates, affiliations, etc., posted within
the next several days.

The abstract of that I-D read:

	A consensus is emerging in the IETF that very long
	tenure in leadership roles is not in the best interests
	of the community. While, in theory, that advice could
	simply be given to the NomCom, there is reason to
	believe that a different model for consideration of
	renewal or replacement for members of the leadership
	would be more efficient for the NomCom and would impose
	less hardship on incumbents and the community. This
	document outlines that alternate method.

In addition to proposing an approach that would limit most
Nomcom appointees to two terms and change the way Nomcoms review
appointees, Section 3 (of -01) reviews the discussions at the
time about other alternatives including hard term limits.

    john

---

From: Barry Leiba <[email-masked]>
Date: Wed, 20 Oct 2021 13:23:32 -0400

Rich, thanks for bringing this to discussion.

First: I am very strongly *against* hard term limits, as it places
unreasonable limitations on the appointment process.  In a public
voting system, it's antidemocratic, artificially eliminating the
ability to vote for whom one thinks is best.  In our NomCom system, it
restricts the NomCom from considering excellent candidates who have
been doing well and can be expected to continue that way.  And it
would make it impossible for a NomCom to re-appoint an excellent AD
(say), when there are no good alternatives, ending us up with a bad
choice because it's the best the NomCom had to work with.

Second, I am very strongly *for* soft term limit guidance.
Specifically saying that NomComs MUST consider more than two terms to
be atypical and more than three to be truly exceptional, and [etc,
etc, wording like that with further explanation] would absolutely get
my support.  But NomComs *have* to have options to deal with
situations where re-appointing someone for a third (or fourth) term
really *is* the right thing *in this case*.

Third, while I appreciate the desire not to have ADs move straight to
the IAB or vice-versa, and while a one-year gap before making the move
is not unreasonable, the issue is more of a challenge for someone
moving into the IETF Chair role.  Here are two reasons why:

- It's critical for an IETF Chair to have experience as an AD.  And,
while Lars's experience is older and he is doing and will do fine,
we've generally had more recent ADs step into the IETF Chair position.
I would not want to limit the NomCom by saying that they can't appoint
a sitting AD as the next IETF Chair.

- The IETF Chair is only appointed every two years.  An AD who wants
the IETF Chair position would have to step down at least a year ahead,
and an AD whose term is in sync with the IETF Chair appointment would
have to step down at least two years ahead.  Given that a one-term
IETF Chair is likely to get a second term, that could move to four
years ahead.  Now we have an AD who might have been a great choice for
IETF Chair, but has to wait four years -- and be four years away from
the AD experience -- before she will really be considered by the
NomCom (especially if we should also move in the direction of JCK's
proposal).

So *if* we should go in the direction Rich proposes, I would want to
see an exception for IETF Chair appointments.

But, really, I'd much rather see us move toward giving NomComs very
clear and strong guidance on what the community expects, but leave
them the option to do what needs to be done as the situation might
require.

Barry

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 20 Oct 2021 18:16:39 +0000

Note that term limits is not quite the correct term, but it's close enough to foster discussion.

The limit is no more than two consecutive terms.  Is there a one-word description for that?

I agree it's an issue. I think the more important issue, now, is to get "new blood" into leadership positions. Others of course may disagree.

    > Now we have an AD who might have been a great choice for

The downside of this is we don't know who would make a great IETF Chair because if the AD->Chair bias that presently exists.

---

From: Kyle Rose <[email-masked]>
Date: Wed, 20 Oct 2021 14:34:07 -0400

On Wed, Oct 20, 2021 at 2:16 PM Salz, Rich <rsalz=
[email-masked]> wrote:

> I agree it's an issue. I think the more important issue, now, is to get
> "new blood" into leadership positions. Others of course may disagree.
>

I think part of Barry's point is that we have a supply problem: not enough
good candidates. Further constraining supply at a time like that is
probably unwise. If you want new blood and not end up with incompetent
leadership, you have to somehow solve that issue. I might be more inclined
to agree on the desirability of term limits if there were lots of deserving
candidates being passed over, but that is simply not the case today.

Kyle

---

From: Barry Leiba <[email-masked]>
Date: Wed, 20 Oct 2021 14:49:08 -0400

Exactly, Kyle; thanks for rephrasing more clearly.

Barry

On Wed, Oct 20, 2021 at 2:34 PM Kyle Rose <[email-masked]> wrote:
>
> On Wed, Oct 20, 2021 at 2:16 PM Salz, Rich <rsalz=[email-masked]> wrote:
>>
> I think part of Barry's point is that we have a supply problem: not enough good candidates. Further constraining supply at a time like that is probably unwise. If you want new blood and not end up with incompetent leadership, you have to somehow solve that issue. I might be more inclined to agree on the desirability of term limits if there were lots of deserving candidates being passed over, but that is simply not the case today.
>
> Kyle
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 20 Oct 2021 19:14:41 +0000

*   think part of Barry's point is that we have a supply problem: not enough good candidates.

I don’t that point is proven.  I could agree that we don’t have enough candidates, but whether they are good or not is unknown.

  *   If you want new blood and not end up with incompetent leadership, you have to somehow solve that issue

It’s not clear that we will end up with “incompetent” leadership. It’s not even clear what that means, beyond “I know it when I see it.” It is also not clear if having “new blood” is worse than the current path.

I am opposed to making it “strong guidance” to NomCom because nobody is incentivized to find additional candidates.

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 20 Oct 2021 12:25:54 -0700

I mostly agree with Barry. Specifically, Barry raises two points:

1. In exceptional cases a candidate needs to be appointed for a third term.
I've seen this as well though I think it wouldn't be fatal if we limited to
two terms.
2. That often you want to pick an active AD or an IAB member as IETF Chair.
I think this is the strongest point and it would be quite bad to make this
more difficult.

I am more sympathetic to the IAB case: there are always a lot of IAB
candidates and I don't think that having it be common practice for ADs to
go right to the IAB is that great.

-Ekr

I

On Wed, Oct 20, 2021 at 10:23 AM Barry Leiba <barryleiba=
[email-masked]> wrote:

> --
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch
>

---

From: Bob Hinden <[email-masked]>
Date: Wed, 20 Oct 2021 12:43:16 -0700

I agree about hard term limits, but think the selection bar should go way up for more than two terms.  Related, I think doing a second term as an AD (and other positions too) should be encouraged.

I think people should not move directly from one leadership group (IESG, IAB, LLC, Trust) to another.   At least one year being a regular IETF participant provides a lot of perspective.   Otherwise we get an inbred (so to speak) leadership who may loose site of what it is like to be a regular IETF participant.   Note, I purposely didn’t include w.g. chair in my list.

The IETF Chair is different, I agree it’s good to have a person who has served recently as an AD.  I think that should be the exception to moving between leadership positions.  However, I don’t think an IETF chair should be appointed to the IAB, LLC, or Trust directly when their term ends.

Bob

> On Oct 20, 2021, at 10:23 AM, Barry Leiba <barryleiba=[email-masked]> wrote:
>

---

From: Rob Sayre <[email-masked]>
Date: Wed, 20 Oct 2021 13:02:01 -0700

I mostly agree with Barry as well. I also find that the people who get
reappointed or agree to serve again tend to be pretty cool folks, so I'm
not sure term limits solve a problem. However, I'm not against it either,
really.

thanks,
Rob

On Wed, Oct 20, 2021 at 12:26 PM Eric Rescorla <[email-masked]> wrote:

> 1. In exceptional cases a candidate needs to be appointed for a third
> term. I've seen this as well though I think it wouldn't be fatal if we
> limited to two terms.
> 2. That often you want to pick an active AD or an IAB member as IETF
> Chair. I think this is the strongest point and it would be quite bad to
> make this more difficult.
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 20 Oct 2021 21:25:44 +0000

Gendispatch to BCC; using the general IETF@ list for this discussion.

>    The IETF Chair is different, I agree it’s good to have a person who has served recently as an AD.

Let's see.  Looking at https://www.ietf.org/about/groups/iesg/past-members/

Lars was Transport AD until 2011; 10 years.
Aliisa was General AD until 2020, no gap.
Jari was Internet AD until 2012; one year.
Russ was Security AD until 2007; no gap
Brian Carpenter wasn't an AD unless it was before 1989 so at least a 15 year gap.
Harald was Ops AD until 1998 so three year gap.
Fred Baker wasn't an AD before 1989 so at least a six year gap.
Paul Mockapetris wasn't an AD before 1989 so at least a six year gap.
Phillip Gross wasn't an AD unless before 1989
Michael Corrigan was an AD unless before 1989

Did I make any mistakes (quite likely!) in the above?

Not that my proposal doesn't say "can't be an AD"  It just says that if you serve the commonplace two terms, then there must be gap year.

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 Oct 2021 10:08:24 +1100

+1. Our bench is sometimes *very* thin for ADs.

Regarding the IAB - rather than tweak the rules it might be good for the community to have a re-think about the function that it serves (or thinks it does). Once we have clarity on that we can figure out what the best policies are.

Cheers,

> On 21 Oct 2021, at 6:25 am, Eric Rescorla <[email-masked]> wrote:
> 
> 1. In exceptional cases a candidate needs to be appointed for a third term. I've seen this as well though I think it wouldn't be fatal if we limited to two terms.
> 2. That often you want to pick an active AD or an IAB member as IETF Chair. I think this is the strongest point and it would be quite bad to make this more difficult.
> 
> I am more sympathetic to the IAB case: there are always a lot of IAB candidates and I don't think that having it be common practice for ADs to go right to the IAB is that great.
> 
> -Ekr
> 
> 
> 
> I
> 
> On Wed, Oct 20, 2021 at 10:23 AM Barry Leiba <barryleiba=[email-masked]> wrote:

--
Mark Nottingham   https://www.mnot.net/