Subject: [GGIE] Notes and presentations -- VIG at IETF 104

From: "Leslie Daigle" <[email-masked]>
Date: Tue, 02 Apr 2019 17:12:55 -0400

Hi,

Thanks to those who were able to come out and participate in last 
week’s Video Interest Group meetings at IETF 104!

Thumbnail re-cap — there’s clear interest in _some_ kind of 
formalization of the activity at the IETF; people who’ve been 
following along have been leaning towards an OPS area WG.  We’ll see 
what the ADs decide.

In the meantime, you can find notes from our VIG meeting here:

https://yana.techark.org/20190327-video-interest-group-final/

And presentations from Jake Holland, Sanjay Mishra and Marc Cymontkowski 
here:

https://yana.techark.org/vig-at-ietf/vig-at-ietf-104-presentations/

(I was going to attach them, but they aren’t all small).

Leslie.

-- 

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------

---

From: "Holland, Jake" <[email-masked]>
Date: Tue, 23 Apr 2019 00:25:04 +0000

Hi Leslie,

Thanks for putting this together.

I was wondering whether there was any update yet on the draft charter for the media ops wg we discussed in Prague?  Or any other discussions that have been happening on that front?

Thanks and regards,
Jake

From: Leslie Daigle <[email-masked]>
Date: 2019-04-02 at 14:13
To: "[email-masked]" <[email-masked]>
Subject: [GGIE] Notes and presentations -- VIG at IETF 104

Hi,

Thanks to those who were able to come out and participate in last week’s Video Interest Group meetings at IETF 104!

Thumbnail re-cap — there’s clear interest in some kind of formalization of the activity at the IETF; people who’ve been following along have been leaning towards an OPS area WG. We’ll see what the ADs decide.

https://yana.techark.org/20190327-video-interest-group-final/<https://urldefense.proofpoint.com/v2/url?u=https-3A__yana.techark.org_20190327-2Dvideo-2Dinterest-2Dgroup-2Dfinal_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=yzWM1kLYys21AFp28yhilNkVnuSOEkIc1hkzo5irzbE&s=7p-fG6ZisgqfPfiO7tWe9XUh3PXAHXZ2qTM3uxZljwo&e=>

And presentations from Jake Holland, Sanjay Mishra and Marc Cymontkowski here:

https://yana.techark.org/vig-at-ietf/vig-at-ietf-104-presentations/<https://urldefense.proofpoint.com/v2/url?u=https-3A__yana.techark.org_vig-2Dat-2Dietf_vig-2Dat-2Dietf-2D104-2Dpresentations_&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=yzWM1kLYys21AFp28yhilNkVnuSOEkIc1hkzo5irzbE&s=Xz5n4CSyPXoCvqT11ieXiUeCrQf9DDw0rPC-lulpGQ4&e=>

Leslie.

--

________________________________

Leslie Daigle

[email-masked]<mailto:[email-masked]>

---

From: "Leslie Daigle" <[email-masked]>
Date: Tue, 23 Apr 2019 18:02:42 -0400

Hiya,

The short answer is, no, we’ve heard nothing from the ADs since we had 
discussions in Prague.  I am following up with them.

In the meantime, here’s the draft charter, following our discussion in 
the VIG Whither session in Prague.

Media OPS (MOPS) WG

The Media OPS Working Group is a forum for coordinating the deployment, 
engineering, and operation of media streaming and manipulation protocols 
and procedures in the global Internet, inter-domain and single domain. 
In this case, media is considered to include the transport of video, 
audio, objects and any combination thereof, possibly non-sequentially. 
The scope is media and media protocols’ interactions with the network, 
but not the technology of control protocols or media formats.
 This activity will include, but not be limited to:
– Document deployment operational gaps for video in the global 
Internet, including last mile issues
– Receive regular reports on the current state of the deployment of 
media technology, and media technology industry technology developments
– Create "practice and experience" documents that capture the 
experience of those who have deployed and are deploying various media 
technologies.
– Based on reports and other information, provide feedback to other 
relevant working groups.
– Develop mechanisms and procedures for sharing operational 
information to aid in operation of media technologies in the global 
Internet
– Develop tools, extend protocols and provide operational and 
implementation advice that assists in media technology administration, 
diagnostics, troubleshooting and deployment between/within native and 
 non-native environments.
– This working group may develop requirements and assist in review and 
feedback of documents in other working groups responsible for such 
protocols.

Thoughts welcome.

Leslie.

On 22 Apr 2019, at 20:25, Holland, Jake wrote:

> I was wondering whether there was any update yet on the draft charter 
> for the media ops wg we discussed in Prague?  Or any other discussions 
> that have been happening on that front?
>
> Thanks and regards,
> Jake
>
> Thumbnail re-cap — there’s clear interest in some kind of

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 23 Apr 2019 22:55:46 +0000

Hello Leslie,

Thank you for pushing this VIG forward. And, thank you as well for drafting a WG charter (but do not forget to ask for a WG-forming BoF for July 2019)

About the charter itself, may I suggest to follow the structure of V6OPS? Esp for the last bullet?

Also unsure whether “a forum for coordinating the deployment, ...” is accurate. If we ask for a forum, then we will get a mailing list (I am afraid). Also, do we need to ‘coordinate’ ?

Again, thank you for pushing video forward

-éric

From: GGIE <[email-masked]> on behalf of Leslie Daigle <[email-masked]>
Date: Tuesday, 23 April 2019 at 18:03
To: "Holland, Jake" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [GGIE] Draft charter Re: Notes and presentations -- VIG at IETF 104

Hiya,

The short answer is, no, we’ve heard nothing from the ADs since we had discussions in Prague. I am following up with them.

In the meantime, here’s the draft charter, following our discussion in the VIG Whither session in Prague.

Media OPS (MOPS) WG

The Media OPS Working Group is a forum for coordinating the deployment, engineering, and operation of media streaming and manipulation protocols and procedures in the global Internet, inter-domain and single domain. In this case, media is considered to include the transport of video, audio, objects and any combination thereof, possibly non-sequentially. The scope is media and media protocols’ interactions with the network, but not the technology of control protocols or media formats.
 This activity will include, but not be limited to:
– Document deployment operational gaps for video in the global Internet, including last mile issues
– Receive regular reports on the current state of the deployment of media technology, and media technology industry technology developments
– Create "practice and experience" documents that capture the experience of those who have deployed and are deploying various media technologies.
– Based on reports and other information, provide feedback to other relevant working groups.
– Develop mechanisms and procedures for sharing operational information to aid in operation of media technologies in the global Internet
– Develop tools, extend protocols and provide operational and implementation advice that assists in media technology administration, diagnostics, troubleshooting and deployment between/within native and  non-native environments.
– This working group may develop requirements and assist in review and feedback of documents in other working groups responsible for such protocols.

Thoughts welcome.

Leslie.

Hi Leslie,

Thanks and regards,

Jake

Hi,

Leslie.

--

Leslie Daigle

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Tue, 23 Apr 2019 23:57:27 +0000

Hi Eric,

Perhaps coordinate or forum is not the optimum word for the task which is to help be an ingest point of contact for video projects that are seeking a friendly entry point who understands both the video technology needs and the ietf structure.

Any suggestions on perhaps other words that maybe better?

We do want to have a path to help video efforts that have ietf work or dependencies to engage with the larger community.

Glenn

On Apr 23, 2019, at 3:56 PM, Eric Vyncke (evyncke) <[email-masked]<mailto:[email-masked]>> wrote:

Hello Leslie,

-éric

From: GGIE <[email-masked]<mailto:[email-masked]>> on behalf of Leslie Daigle <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 23 April 2019 at 18:03
To: "Holland, Jake" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [GGIE] Draft charter Re: Notes and presentations -- VIG at IETF 104

Hiya,

Media OPS (MOPS) WG

Thoughts welcome.

Leslie.

Hi Leslie,

Thanks and regards,

Jake

From: Leslie Daigle <[email-masked]<mailto:[email-masked]>>
Date: 2019-04-02 at 14:13
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [GGIE] Notes and presentations -- VIG at IETF 104

Hi,

Leslie.

--

Leslie Daigle

[email-masked]<mailto:[email-masked]>
_______________________________________________
GGIE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ggie

---

From: "Leslie Daigle" <[email-masked]>
Date: Wed, 24 Apr 2019 17:34:25 -0400

Hi Éric,

Thanks for the review and feedback.

To the specific point:   “a forum for coordinating the deployment, 
..” — that’s actually text pretty much straight from MBONED WG.  
I’d be afraid of just a mailing list, too — rather, we’d like to 
have regular meetings so that it’s a visible place for people working 
on technology outside of the IETF to come and talk.  E.g., those using 
WebRTC for new and interesting purposes.

Which, I’ll observe, is a different role than the v6ops WG’s focus 
on “soliciting input from network operators and identifying 
operational issues with <a specific IETF protocol>”.

Leslie.

-- 

On 23 Apr 2019, at 18:55, Eric Vyncke (evyncke) wrote:

> Hello Leslie,
>
> Thank you for pushing this VIG forward. And, thank you as well for 
> drafting a WG charter (but do not forget to ask for a WG-forming BoF 
> for July 2019)
>
> Also unsure whether “a forum for coordinating the deployment, ...” 
> is accurate. If we ask for a forum, then we will get a mailing list (I 
> am afraid). Also, do we need to ‘coordinate’ ?
>
> The short answer is, no, we’ve heard nothing from the ADs since we 
> had discussions in Prague. I am following up with them.
>
> The Media OPS Working Group is a forum for coordinating the 
> deployment, engineering, and operation of media streaming and 
> manipulation protocols and procedures in the global Internet, 
> inter-domain and single domain. In this case, media is considered to 
> include the transport of video, audio, objects and any combination 
> thereof, possibly non-sequentially. The scope is media and media 
> protocols’ interactions with the network, but not the technology of 
> control protocols or media formats.
> – This working group may develop requirements and assist in review 
> and feedback of documents in other working groups responsible for such 
> protocols.
>
> Thoughts welcome.
>
> Leslie.
>

---

From: "Roni Even (A)" <[email-masked]>
Date: Sun, 28 Apr 2019 06:16:29 +0000

Hi Leslie,
Thanks for drafting this proposed charter.

I have a general question , are we talking about media technology or media delivery or maybe media delivery technology?

I had some trouble parsing the following sentence “and media technology industry technology developments”   should it be “” and media delivery industry technologies developments”

Roni Even

From: GGIE [mailto:[email-masked]] On Behalf Of Leslie Daigle
Sent: Wednesday, April 24, 2019 1:03 AM
To: Holland, Jake
Cc: [email-masked]
Subject: [GGIE] Draft charter Re: Notes and presentations -- VIG at IETF 104

Hiya,

Media OPS (MOPS) WG

Thoughts welcome.

Leslie.

Hi Leslie,

Thanks and regards,

Jake

Hi,

Leslie.

--

Leslie Daigle

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Sun, 28 Apr 2019 13:23:46 +0000

On Apr 27, 2019, at 11:16 PM, Roni Even (A) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Leslie,

My thinking is that it is media technology which includes protocols used in the capture and edit and packaging workflows as well as delivery.

For one example, there are the network pieces used to capture and transport live cameras in a stadium and then transport the video to a facility for live editing and then encoding for distribution and finally the transport of the newly encoded video to CDN caches for delivery.   That’s all network stuff that happens before the player connects to a CDN cache.

This wholistic view is important as the video requirements on the various network pieces that are involved in the transport tasks come out when the tasks are viewed together.

Glenn

Glenn

Roni Even

From: GGIE [mailto:[email-masked]] On Behalf Of Leslie Daigle
Sent: Wednesday, April 24, 2019 1:03 AM
To: Holland, Jake
Cc: [email-masked]<mailto:[email-masked]>
Subject: [GGIE] Draft charter Re: Notes and presentations -- VIG at IETF 104

Hiya,

Media OPS (MOPS) WG

Thoughts welcome.

Leslie.

Hi Leslie,

Thanks and regards,

Jake

Hi,

Leslie.

--

Leslie Daigle