Subject: [hackathon] Fwd: Related Implementations tag on Datatracker

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 9 Mar 2022 17:32:21 +0000

Good news everyone, a new mechanism has been added to the datatracker to help make it easier to identify and find code related to IETF drafts. For example, you can use this tag to associate the code you are working on in the Hackathon with corresponding working group or individual drafts.

Please see the forwarded message from Tommy for instructions on how to use this new mechanism. Note that anyone can add this tag to their individual drafts. I added one here, https://datatracker.ietf.org/doc/draft-eckel-edm-find-code/.
You will need to work with the appropriate working group chair(s) to add them to existing working group drafts.

Please give this try for your Hackathon projects. Hopefully it will make it easier for everyone to find and collaborate on running code.

Thanks,
Charles

Begin forwarded message:

From: Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>
Subject: Related Implementations tag on Datatracker
Date: March 8, 2022 at 12:56:03 PM PST
To: [email-masked]<mailto:[email-masked]>

Hi WG Chairs,

One of the actions we took out of the survey on implementation status tracking was to add a Datatracker tag that could be added to the page for a document or a working group in the “additional resources” section.

You can click on “Edit” by “Additional Resources”, and add one or more entries for related_implementations.

For example, you could add:

related_implementations https://implementation_info_page.example.com/foobar

This shows up in the page as “Related Implementations”. You can customize that string like this:

related_implementations https://implementation_info_page.example.com/foobar (Protocol Implementation Info)

I’ve added an example for Binary HTTP Messages, with two implementations, here:

https://datatracker.ietf.org/doc/draft-ietf-httpbis-binary-message/

This can be a way to help highlight and link implementation status. It will be highlighted in the hackathon, but you may want to bring it up with your working groups at IETF 113 too!

Thanks,
Tommy, on behalf of the EDM IAB Program

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 9 Mar 2022 17:33:00 +0000

Thanks,
Charles

Begin forwarded message:

Hi WG Chairs,

Thanks,