Subject: RE: [Hipsec] Recovery from state loss

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 6 Jul 2004 07:59:06 -0700

> -----Original Message-----
> From: Erik Nordmark [mailto:[email-masked]] 
> Sent: Monday, July 05, 2004 2:53 AM
> To: Henderson, Thomas R
> Cc: Erik Nordmark; [email-masked]
> Subject: RE: [Hipsec] Recovery from state loss
> 
> 
> 
> Is there some encrypted set of bits exchange when the HIP association
> is setup which could be used just to apply a keyed hash on 
> the close message?
> 
There is an HMAC parameter based on keying material derived from the Diffie Hellman exchange.

Tom
_______________________________________________
Hipsec mailing list
[email-masked]
http://honor.trusecure.com/mailman/listinfo/hipsec

---

From: Julien Laganier <[email-masked]>
Date: Tue, 06 Jul 2004 17:10:13 +0200

On Tuesday 06 July 2004 16:59, Henderson, Thomas R wrote:
> > Is there some encrypted set of bits exchange when the HIP
> > association is setup which could be used just to apply a keyed
> > hash on the close message?
>

BTW, having both a HMAC and a SIGNATURE might make sense: The end-node 
verifies only the HMACs while midboxes verify SIGNATUREs.

--julien