Subject: [Hipsec] API and LSI resolution

From: [email-masked] (Henderson, Thomas R)
Date: Fri Mar 12 10:59:04 2004

>=20
> Hence, I would like to see using
> host NAT as a "MAY", with text stating that there may
> be other alternatives in the future, and the exact
> method of resolving LSI conflicts in the long run is
> an open issue.

OK

>=20
> > iii) Add a subsection after 3.5 (TCP/UDP checksum) that
> > describes ii) above, and summarizes API issues and the
> > issue of LSIs or HITs in the application data stream,
> > while deferring full API discussion to another draft
>=20
> I'm fine with explicitly deferring API discussion to another
> document.  What comes to the TCP/UDP checksum, we use the
> IPv6 pseudo header with HITs anyway, at least conceptually.
> Consequently, I would say that any discussion of how to handle
> this in the case of using IPv4 stack with possibly host
> NATted LSIs belongs to an appendix.
>=20

OK, but I think that there needs to be some statement in the
main body that describes that HITs and LSIs may be used in
the application data stream and hence may be observed at the API;
such a statement deals with the bits that may be seen on the wire.
It might not merit a separate section, though.  I will work out
a specific text proposal along the lines you suggested.

Tom

---

From: [email-masked] (Pekka Nikander)
Date: Fri Mar 12 12:25:00 2004

> such a statement deals with the bits that may be seen on the wire.

Agreed.

> a specific text proposal along the lines you suggested.

Ok.

--Pekka