Subject: [Hipsec] HIP ESP draft

From: Petri Jokela <[email-masked]>
Date: Thu, 04 May 2006 11:42:36 +0300

Folks,

I made two modifications to the ESP draft based on the security analysis.

- The ESP Sequence Number is now a 64-bit value

   o 3.3.6 Sequence Number section is modified
   o 5.1.2 ESP_TRANSFORM packet description is modified

The ESP_TRANSFORM contains at the moment a 16-bit reserved field.
It is possible now to start Suites immediately after the length
field unless we want to keep the reserved field for some possible future
versions of the protocol.

- 5.1.2 ESP_TRANSFORM text was changed similarly to the HIP_TRANSFORM
in the base draft. The possibility to change the default configuration
was added.

The pre-version (040506) is available at:

http://hip4inter.net/drafts.php

/petri

_______________________________________________
Hipsec mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/hipsec

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 16 May 2006 10:03:30 -0700

> -----Original Message-----
> From: Petri Jokela [mailto:[email-masked]] 
> Sent: Thursday, May 04, 2006 1:43 AM
> To: HIP
> Subject: [Hipsec] HIP ESP draft
> 
> Folks,
> 

Unless someone thinks of an anticipated need, I would suggest to remove
the reserved field here.

> in the base draft. The possibility to change the default configuration

OK

> http://hip4inter.net/drafts.php

Some minor editorial nits in Section 5.1.2:

   first party sends a selection of transfrom families in the
                                    ^^^^^^^^^^
                                    transform

   are no more than six (6) HIP Suite-IDs in one
                            ^^^
                           (suggest to delete "HIP" and call them
Suite-IDs)

Tom

---

From: Miika Komu <[email-masked]>
Date: Thu, 18 May 2006 12:59:25 +0300 (EEST)

> Unless someone thinks of an anticipated need, I would suggest to remove

After some offline discussion, I believe the reserved field is needed for 
further extensions.

-- 
Miika Komu              [email-masked]          http://www.iki.fi/miika/