Subject: [Hipsec] ORCHID RFC

From: Miika Komu <[email-masked]>
Date: Mon, 11 Jan 2010 17:52:08 +0100

Hi,

I assume that the ORCHID RFC will be updated also in addition to the 
other RFC. I have already a small suggestion. If the prefix changes, it 
would be nice to get a prefix multiple of eight bits. The current /28 
prefix is more prone to developer errors.

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Mon, 11 Jan 2010 09:05:33 -0800

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Miika Komu
> Sent: Monday, January 11, 2010 8:52 AM
> To: hip WG
> Subject: [Hipsec] ORCHID RFC
>
> Hi,
>

I did not participate in the previous ORCHID discussions with IANA, but some questions have arisen during the review cycle of draft-ietf-hip-native-api.

1) what is the process for possibly renewing ORCHID?

2) is 100 bits of hash considered to be enough for the 2nd preimage attack resistance, or should future ORCHIDs have more hash bits?   Was the reason for setting an expiration date due to concerns that 100 bits was not enough hash?  (I don't recall this being the case but it seems that others may have this recollection)

Thanks,
Tom

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 20 Jan 2010 09:02:48 -0800

Hi,

I do not think we can get a prefix shorter than /28. I do not think we should design protocols for an hypothetic developer who can't handle masking on non-byte-boundaries.

--julien
 
Miika Komu
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec