Subject: [Hipsec] NAT traversal and the standards track work

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 20 Apr 2010 15:44:44 +0300

Hi,

we need to decide what to do with NAT traversal when moving to the
standards track. We have the following drafts:

https://datatracker.ietf.org/doc/draft-ietf-hip-nat-traversal/

The draft above will soon become an Experimental RFC.

https://datatracker.ietf.org/doc/draft-keranen-hip-native-nat-traversal/

The draft above proposes implementing HIP-based connectivity checks
instead of STUN-based ones.

http://www.watersprings.org/pub/id/draft-melen-hip-nat-mm-00.txt

The draft above, which needs to be revised, describes the mobility and
multihoming extensions for NAT traversal.

I would like to hear people's views on what to do here.

Cheers,

Gonzalo
HIP co-chair

---

From: Miika Komu <[email-masked]>
Date: Tue, 20 Apr 2010 16:16:35 +0300

On 04/20/2010 03:44 PM, Gonzalo Camarillo wrote:

Hi,

for the design and implementation reasons discussed earlier on this 
mailing list, I'd give my support on draft-keranen-hip-native-nat-traversal.

> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 20 Apr 2010 20:48:32 +0300

Hi Miika,

thanks for your input. Note that I would also like to get input on what
to do with the mobility and multihoming NAT traversal extensions. We can
rule them out or in scope.

Cheers,

Gonzalo

---

From: Miika Komu <[email-masked]>
Date: Tue, 20 Apr 2010 21:05:31 +0300

On 20/04/10 20:48, Gonzalo Camarillo wrote:

Hi,

I believe we could also fold mobility extensions into the native draft 
(or a separate one). I can volunteer to help to get this done if the WG 
agrees that the native way is the path to proceed.

---

From: Ari Keranen <[email-masked]>
Date: Thu, 22 Apr 2010 02:49:08 +1000

Hi,

I think the mobility and multihoming with NAT traversal is important 
(we're pretty much crippling HIP otherwise) and should be included as a 
work item.

Cheers,
Ari

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Sun, 25 Apr 2010 21:51:59 -0700

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
> Sent: Tuesday, April 20, 2010 5:45 AM
> To: HIP
> Subject: [Hipsec] NAT traversal and the standards track work
>
> Hi,
>

Gonzalo, I would like to see both topics (NAT traversal, and mobility management aspects of NAT traversal) on the revised charter, as the second phase of standards-track work, as we discussed in Anaheim.  I am neutral on the questions of which one of the two drafts to adopt (if a choice needs to be made now) and on whether the nat-mm draft should remain separate or should be combined into one NAT traversal draft.

- Tom

---

From: Tobias Heer <[email-masked]>
Date: Mon, 26 Apr 2010 12:06:25 +0200

> Gonzalo, I would like to see both topics (NAT traversal, and mobility management aspects of NAT traversal) on the revised charter, as the second phase of standards-track work, as we discussed in An…
I share Tom's opinion here. I would like to see both progress (provided there is enough manpower to support both). However, I think it might be useful to address mobility in the actual NAT documents since it poses special challenges that are special to NATs. 

Tobias

--  

Dipl.-Inform. Tobias Heer, Ph.D. Student
Distributed Systems Group 
RWTH Aachen University, Germany
tel: +49 241 80 207 76
web: http://ds.cs.rwth-aachen.de/members/heer