Subject: [Hipsec] What is in a name -- HMAC HIP Parameter

From: Robert Moskowitz <[email-masked]>
Date: Mon, 26 Apr 2010 10:19:52 -0400

I do not like naming this parameter HMAC and HMAC2:

Eventhough according to draft-irtf-cfrg-kdf-uses-00.txt, we can only use 
HMAC (D-H derived key is NOT uniformly distributed), There may be a 
future hkdf that is NOT HMAC that is secure to use with a D-H derived 
key, or a different key derivation method is used.

This parameter is really the MAC operation of SIGMA compliance, which is 
currently achieved via HMAC.

So I offer two possible alternative parameter names:

HIP_MAC and HIP_MAC2

or

HIP_MIC and HIP_MIC2

The alternative 'MIC' TLA stands for Message Integrity Check.  This 
comes out of the IEEE 802 community that already had a MAC and needed a 
different TLA.

Hum 1)

Change HMAC to HIP-MxC

Hum 2)

x :== A  or  x:== I

---

From: Miika Komu <[email-masked]>
Date: Mon, 26 Apr 2010 17:39:46 +0300

On 26/04/10 17:19, Robert Moskowitz wrote:

Hi,

I would hum for option 2 (with slight preference for "MAC").

> The alternative 'MIC' TLA stands for Message Integrity Check. This comes
> out of the IEEE 802 community that already had a MAC and needed a
> different TLA.
>
> Hum 1)
>
> Change HMAC to HIP-MxC
>
> Hum 2)
>
> x :== A or x:== I
>
>
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec

---

From: Tobias Heer <[email-masked]>
Date: Mon, 26 Apr 2010 17:41:00 +0200

Hello Robert. 

Am 26.04.2010 um 16:19 schrieb Robert Moskowitz:

...

> Change HMAC to HIP-MxC

+1

> x :== A  or  x:== I
I prefer A. We don't have the MAC in the protocol specs and I think the term MIC is not that often used in IETF documents (at least I it did not make a strong impression to me).

Tobias

--  

Dipl.-Inform. Tobias Heer, Ph.D. Student
Distributed Systems Group 
RWTH Aachen University, Germany
tel: +49 241 80 207 76
web: http://ds.cs.rwth-aachen.de/members/heer