Subject: [Hipsec] Certs draft: experimental or PS

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 17 Jan 2011 15:53:39 +0200

Hi,

in our last charter update, we decided to move the certs draft to the
standards track:

o Specify in a standards track RFC how to carry certificates in the
base exchange. This was removed from the base HIP spec so that the
mechanism is specified in a stand-alone spec.

However, I would like to double-check with the group. If we intend to
specify all this in 5201 bis anyway, it may make sense to publish this
as an Experimental RFC. If we want 5201bis to reference this spec, then
it needs to be PS. I would like to get your opinions on this issue?

Thanks,

Gonzalo

---

From: Miika Komu <[email-masked]>
Date: Tue, 18 Jan 2011 08:40:32 +0200

Hi,

> it needs to be PS. I would like to get your opinions on this issue?

+1 for standards track

---

From: Tobias Heer <[email-masked]>
Date: Tue, 18 Jan 2011 10:13:04 +0100

Hello Gonzalo,

> it needs to be PS. I would like to get your opinions on this issue?

I would be interested what the implications of PS or experimetal are for the publication of the draft.

Can we publish the draft as PS with downreferences to RFC5201 now (in absence of a 5201-bis) or would we have to wait until 5201-bis is approved?

If we go experimental, can we bis the cert draft later and go for PS instead?

One reason why I would not like to have the certs in 5201-bis is because it is a separate issue/problem/solution and does not really belong to the _base_ documents but rather extends it. As extension it covers a well defined problem space and can stand on its own.

Tobias

> Thanks,
> 
> Gonzalo
> 
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 18 Jan 2011 11:36:11 +0200

Hi Tobias,

yes, those are exactly the points that need to be considered. A straight
forward approach would be to publish this draft as experimental and then
create a bis draft, this time as a PS, which would reference 5201bis.

Another possibility is not to publish the experimental draft at all. We
could update the current draft so that it references 5201bis and publish
it together with 5201bis.

Cheers,

Gonzalo

---

From: Ari Keranen <[email-masked]>
Date: Tue, 18 Jan 2011 12:21:48 +0200

Hi,

I'd go for publishing experimental CERT now and bis'ed PS version later with the rest of the PS HIP stuff.

Cheers,
Ari

---

From: Tobias Heer <[email-masked]>
Date: Tue, 18 Jan 2011 12:22:25 +0100

Hello, 

> I'd go for publishing experimental CERT now and bis'ed PS version later with the rest of the PS HIP stuff.
I second that. I think it makes sense to publish the RFC as experimental first.

The draft is a companion document for 5201 (not bis).
I think it should be published as experimental right now. However, I think we might consider a non-experimental version in the future (when 5201-bis is done).

Tobias

---

From: Samu Varjonen <[email-masked]>
Date: Tue, 18 Jan 2011 13:25:27 +0200

> I think it should be published as experimental right now. However, I think we might consider a non-experimental version in the future (when 5201-bis is done).

+1

BR, Samu

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 18 Jan 2011 21:46:14 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Samu Varjonen
> Sent: Tuesday, January 18, 2011 3:25 AM
> To: [email-masked]
> Subject: Re: [Hipsec] Certs draft: experimental or PS
> 
> > I think it should be published as experimental right now. However, I
> think we might consider a non-experimental version in the future (when
> 5201-bis is done).
> >
> > Tobias
> >
> 
> +1
> 

+1

- Tom

---

From: Miika Komu <[email-masked]>
Date: Wed, 19 Jan 2011 09:54:09 +0200

Hi,

>> think we might consider a non-experimental version in the future (when

ok, fine by me too.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 21 Jan 2011 13:39:18 +0200

Hi,

I have just requested its publication as Experimental.

Cheers,

Gonzalo