Subject: Re: [Hipsec] WGLC: draft-ietf-hip-cert-06

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 11 Jan 2011 20:18:44 +0200

Hi Samu,

when do you intend to submit a new revision of this draft including the
changes that have been agreed?

Thanks,

Gonzalo

On 20/12/2010 12:53 PM, Samu Varjonen wrote:
> On 20/12/10 06:01, Henderson, Thomas R wrote:
>>
>>
>>> -----Original Message-----
>>> From: [email-masked]
>>> [mailto:[email-masked]] On Behalf Of Gonzalo Camarillo
>>> Sent: Sunday, December 05, 2010 7:51 AM
>>> To: HIP
>>> Subject: [Hipsec] WGLC: draft-ietf-hip-cert-06
>>>
>>> Folks,
>>>
>>> we hereby start the WGLC on the following draft. This WGLC will end on
>>> December 20th.
>>>
>>> https://datatracker.ietf.org/doc/draft-ietf-hip-cert/
>>>
>>> Please, send your comments to this list.
>>>
>>> Thanks,
>>>
>>
>> Gonzalo, I reread this draft and feel that it is ready to publish, modulo the resolution of a couple of comments below.
>>
>> At the top of page 6, I believe that the line
>>      Subject: CN=hit-of-issuer
>> should read
>>      Subject: CN=hit-of-subject
>>
> 
> OK, fixed
> 
>> In section 8, the second paragraph recommends to not use grouping or hash and URL encodings when HIP aware middleboxes are anticipated to be on the path.  First of all, it is not really clear how a HIP host may know about these boxes except via side information.  If the HIP host does know about them, then presumably it could also know (via side information) whether they can support grouping and hash formats, and the host could act accordingly.  Second, it is not clear whether the use of these options by a well-behaved host would make these devices more prone to attacks, or whether it is rather the use of these options by other malicious hosts that is the real problem.  It seems to me that it may be better to defer this issue to a future HIP-aware middlebox draft, where it could be specified, for instance, how a middlebox that does not want to support these formats may signal to a host that it requires "full credentials" to proceed.  So, I would like to suggest for your co
ns
> id
>>   eration to remove this paragraph.
>>
> 
> I agree with the comment and agree on leaving the subject to a future draft on 
> HIP-aware middleboxes. Anyone against the removal of the paragraph? If not 
> consider it removed.
> 
>> - Tom
>> _______________________________________________
>> Hipsec mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/hipsec
>

---

From: Samu Varjonen <[email-masked]>
Date: Wed, 12 Jan 2011 14:32:48 +0200

> changes that have been agreed?

Uploaded it a minute ago.

BR,
Samu

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 12 Jan 2011 16:12:02 +0200

Hi Samu,

thanks. At this point, I will take care of the PROTO write up and of
requesting the publication of the draft.

Cheers,

Gonzalo