Subject: [Hipsec] Fwd: Re: Last Call: <draft-irtf-hiprg-dht-04.txt> (Host Identity Protocol Distributed Hash Table Interface) to Experimental RFC

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 3 Nov 2011 15:22:16 +0200

Folks,

related to my previous email to this list, we need to think about the
IANA policies we want the bis specs to use.

Cheers,

Gonzalo

-------- Original Message --------
Subject: Re: Last Call: <draft-irtf-hiprg-dht-04.txt> (Host Identity
Protocol	Distributed Hash Table Interface) to Experimental RFC
Date: Thu, 3 Nov 2011 12:29:37 +0100
From: Jari Arkko <[email-masked]>
To: [email-masked] <[email-masked]>
CC: [email-masked]
<[email-masked]>, Ralph Droms <[email-masked]>

Ralph,

> This document calls for the assignment of a new HIP Packet Type from the HIP Packet Type registry, http://www.iana.org/assignments/hip-parameters/hip-parameters.xml Assignment of HIP Packet Types requires IETF consensus. The purpose of this last call is to assess IETF consensus for the assignment described in the document.

I support this action.

RFC 5201 defines the rules for the registry. I would like to request
that RFC 5201bis
http://tools.ietf.org/html/draft-ietf-hip-rfc5201-bis-07#section-9 would
use "IETF Review or IESG Approval" rule as opposed to just saying "IETF
Review". I think it is pretty obvious in this case that a number
allocation should have been made, and having the "or IESG Approval" part
in this IANA rule would have allowed an allocation without a last call,
unless something special was going on (large number of numbers were
being allocated, we'd be running out of the numbers, the proposal came
from some entity not as trustworthy as the IRTF, etc).

Jari

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Tobias Heer <[email-masked]>
Date: Thu, 03 Nov 2011 21:04:48 +0100

Hello Gonzalo,

> IANA policies we want the bis specs to use.
_all_ other types of assignments in RFC5201-bis are "IETF Review or IESG Approval" already. This includes also HIP packet types. To me it seems like a editing error that the parameter types do not mention IESG Approval. Do you see any reason why the assignment procedure of HIP packet types should be more restrictive than the assignment procedure of HIP parameter types or all other namespaces in HIP? I do not see any problem in adding IESG Approval as option.

If we consider not going for "IETF Review or IESG Approval", we should probably rethink the currently specified assignment policies for all other parameters as well.

Best regards,
Tobias

> Hipsec mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hipsec

-- 
Dipl.-Inform. Tobias Heer, Ph.D. Student
Chair of Communication and Distributed Systems - comsys
RWTH Aachen University, Germany
tel: +49 241 80 207 76
web: http://www.comsys.rwth-aachen.de/team/tobias-heer/
blog: http://dtobi.wordpress.com/
card: http://card.ly/dtobi
pgp id: AEECA5BF

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 4 Nov 2011 09:36:15 +0200

Hi,

I personally would be OK with adding the IESG approval policy.

Cheers,

Gonzalo