Subject: [Hipsec] Stephen Farrell's No Objection on draft-ietf-hip-multihoming-11: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Wed, 14 Sep 2016 04:25:35 -0700

Stephen Farrell has entered the following ballot position for
draft-ietf-hip-multihoming-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-hip-multihoming/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- I think section 6 ought note the privacy issue that
was relatively recently with WebRTC and ICE where a
client might not want all of it's IP addresses
exposed, as doing so could expose the fact that the
client e.g. is using Tor or another VPN service. The
issue being that in some locations, that information
may be quite sensitive.  4.2 notes this but in a quite
opaque way, ("may be held back") but it'd be better to
say some more. 5.1 is also relevant maybe in that it
says one "SHOULD avoid" sending info about virtual
interfaces. Anyway, I think it'd be good to add some
recognition of this privacy issue to section 6. I am
not arguing that this draft ought specify the one true
way to avoid this problem, but only that it be
recognised.

- 4.11: what's the concern about anti-replay windows?
I didn't get that fwiw, not sure if that just my
relative ignorance of HIP or if more needs to be said
in the document.

---

From: Jari Arkko <[email-masked]>
Date: Wed, 14 Sep 2016 15:16:08 +0300

Thanks for your review, Stephen.

> say some more.

Seems very reasonable.

> 5.1 is also relevant maybe in that it

Yes

Jari