Subject: Re: [Hipsec] Stephen Farrell's No Objection on draft-ietf-hip-rfc5206-bis-13: (with COMMENT)

From: Tom Henderson <[email-masked]>
Date: Sun, 18 Sep 2016 22:31:03 -0700 (PDT)

Hi Stephen, please see below.

On 09/14/2016 03:18 PM, Stephen Farrell wrote:
> Stephen Farrell has entered the following ballot position for
> draft-ietf-hip-rfc5206-bis-13: No Objection
> 
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
> 
> 
> My review was based on the diff vs. 5206 [1], and turned
> up nothing new of note:-) Seems like a reasonable update
> to me.
> 
> I do however agree about the privacy issue raised by Mirja
> wrt exposing locators. It is worth noting that, so that
> implementers have it flagged that they need to consider
> that - not doing so caused quite a fuss for WebRTC so
> better to not repeat that.

I proposed some text about privacy issues with exposing locators in the multihoming draft comment resolution (earlier today)-- do you think something along those lines fits with this draft also (mobility)?   Perhaps rephrased to mention that even in a non-multihoming case, a host should be aware of any privacy issues of the locator that it chooses to next expose after a mobility event renders its current locator unusable...

- Tom

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 21 Sep 2016 08:24:57 +0100

Hi Tom,

>> up nothing new of note:-) Seems like a reasonable update to me.
>> 
>> I do however agree about the privacy issue raised by Mirja wrt
>> exposing locators. It is worth noting that, so that implementers
>> have it flagged that they need to consider that - not doing so
>> caused quite a fuss for WebRTC so better to not repeat that.
> 
> I proposed some text about privacy issues with exposing locators in
> the multihoming draft comment resolution (earlier today)-- do you
> think something along those lines fits with this draft also
> (mobility)? 

Sure. Warning folks about non-obvious things over which we've
previously tripped seems like a generally good thing. (Well,
at least until we all learn to not trip over that thing;-)

>  Perhaps rephrased to mention that even in a
> non-multihoming case, a host should be aware of any privacy issues of
> the locator that it chooses to next expose after a mobility event
> renders its current locator unusable...

I trust you to find the relevant wording.

Cheers,
S.