Subject: [hrpc] The IEEE project about TLS

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 29 Mar 2017 19:39:08 -0500

At the plenary, someone said that the IEEE, in one of its working
groups, works on a TLS interception solution. He was not sure it was
was officially adopted by the IEEE or just discussed.

It seems that it is this technical solution:

http://mctls.org/

A perfect example of the things we discuss in HRPC about the
responsability of the engineers. Not only such "solutions" open
possible vulnerabilities in TLS (a protocol which is complicated and
sometimes brittle: changes have unintended consequences), but it is
also easy to see how it could be used for evil.

---

From: <[email-masked]>
Date: Thu, 30 Mar 2017 03:03:10 +0000 (UTC)

Does anyone have any ideas about if this is implemented, how widespread, etc?

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

--------------------------------------------
On Wed, 3/29/17, Stephane Bortzmeyer <[email-masked]> wrote:

 Subject: [hrpc] The IEEE project about TLS
 To: [email-masked]
 Date: Wednesday, March 29, 2017, 7:39 PM
 
 At the plenary, someone said that the IEEE, in one of its
 working
 groups, works on a TLS interception solution. He was not
 sure it was
 was officially adopted by the IEEE or just discussed.

 http://mctls.org/
 
 A perfect example of the things we discuss in HRPC about
 the
 responsability of the engineers. Not only such "solutions"
 open
 possible vulnerabilities in TLS (a protocol which is
 complicated and
 sometimes brittle: changes have unintended consequences),
 but it is
 also easy to see how it could be used for evil.
 
 _______________________________________________
 hrpc mailing list
 [email-masked]
 https://www.irtf.org/mailman/listinfo/hrpc