Subject: [hrpc] draft-tenoever-hrpc-political-00.txt

From: Melinda Shore <[email-masked]>
Date: Mon, 3 Jul 2017 20:12:23 -0800

This is a terrific topic and I'm glad to see this draft.
A couple of quick comments:

1) I don't think the distinction between 3.4 and 3.5 is
as clear as it could be.  Or rather, it seemed clear in
the first sentence of 3.5 and then got lost in the Postman
quote.  I'm not actually sure that 3.4 and 3.5 really are
that different, effectively.

2) No mention was made of the Raven process (which resulted
in RFC 2804).  That was an instance where the IETF took a
position that was largely political, although driven by a
technical argument.  It was similar to the process that
led to 6973, in which something that occurred in the
political space (CALEA, Snowden) engendered, in both cases,
responses from the IETF that led to what I don't think is
*simply* a process change.  That is to say, I think it's a
considerable oversimplification to characterize those as
being just process changes.

Thanks for an excellent start on this,

Melinda
-- 
Software longa, hardware brevis

PGP fingerprint: 795A 714B CD08 F996 AEFE
                 AB36 FE18 57E9 6B9D A293

---

From: Bastiaan Goslings <[email-masked]>
Date: Tue, 4 Jul 2017 11:21:11 +0200

Hi all,

> On 4 Jul 2017, at 06:12, Melinda Shore <[email-masked]> wrote:
> 
> This is a terrific topic and I’m glad to see this draft.

Absolutely. Very interesting, thanks a lot for all the work done and sharing this milestone!

Some comments, if I may. 

(Disclaimer: I have not been part in the discussions leading up to this draft, nor have I read the doc’s/RFC’s in the references. I therefore take the draft at face value including the quotes it contains.) 

> that different, effectively.

Yes. Maybe a stronger distinction between 3.4 and 3.5. can help.

3.4 states ‘A technology, once created, has its own logic that is independent of the human actors that either create or use the technology.’ While 3.5 argues, in my words, that protocols are ‘inherently political’ as design influences (or even stronger ‘determines’—> Postman) usage. I do not think 3.4 and 3.5 are effectively saying the same thing, although the design will obviously impact the ‘independent logic’ of a technology.

However, I think both 3.4 and 3.5 need to be more explicit and specific. The way I read the draft is that the crux of the argument that leads to ‘the need for a position’ in chapter 4, is to be found in these two paragraphs. and to some extent in the so called ’pragmatic’ paragraph 3.3 ‘Some protocols are political some times’.

More importantly, I struggle with the line of reasoning in 3.4.

(Indeed, maybe a ‘reference’ [CREF2] can clarify ‘A technology, once created, has its own logic that is independent of the human actors that either create or use the technology.’)

I assume ‘the very existence of the automobile imposes physical forms on the world different from those that come from the electric tram or the horse-cart’ is meant as an example of a technology’s ‘own logic’. To me it is unclear though what this analogy illustrates. If one wants to stick to it, it might be good to describe what ‘physical forms’ an ‘automobile imposes on the world’,  what the consequences are of this supposedly independent and autonomous enforcement (’imposing’) by a particular technology, why that is relevant, and how it relates/compares to other technologies like the ‘electric tram or the horse-cart’ which probably ‘impose’ something else etc.

I also do not understand the ‘Under this view, the technology has its own needs and pressures, independent of those of human actors. As it changes, it will change at least in part  according to those needs and pressures.’ 

Which (‘this’) ‘view’ is being referred to? Why, and what does ’the technology has its own needs and pressures’ mean? Same for ‘it will change at least in part according to those needs and pressures’? Why is this important in this context?
What ‘needs’ does ‘the’ technology have (which technology? ‘once created’?) and what potential ‘pressures’? I have no idea what ‘having pressures’ means btw.

So. For me then the ‘result’ in 3.4’s last sentence is not a logic conclusion: ‘Internet protocols express at least to some extent the logic and values of the overall Internet technology.’

Besides the fact I’d imagine Internet technology to express ‘at least to some extent the logic and values’ of Internet protocols, as the protocols come before the technology based on them, what is ‘the overall Internet technology’ here? And what ‘values’ does it have?

From 3.5:

‘Internet processes and protocols have become part and parcel of political processes and public policies’: be that as it may, it seems to me this is outside the realm of the IETF, i.e. protocols become part of e.g. ‘political processes and public policies’ after they have been designed, for instance within the IETF.  

(And I agree with [CRFEF3]) 

Furthermore ‘According to [Abbate]: “protocols are politics by other means".  This emphasises the interests that are at play in the process of designing standards. This position holds further that protocols can never be understood without their contextual embeddedness’ 

Again, I have not read, in this case, Abbate’s paper. While I personally can sympathise with the ‘contextual’ remark, an ‘according to’ quote doesn’t prove nor emphasise anything IMO, other than the fact that someone made the statement. Which, at least in this draft, has no factual basis and cannot (help) IMO to lead to (support) the conclusion in chapter 4.  

Hope this makes sense, thanks again

regards
Bastiaan

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 4 Jul 2017 12:22:16 +0100

> This is a terrific topic and I'm glad to see this draft.

I agree it's a fun topic. I'm not sure if this'll end up
as a useful draft or not though, but I figure it's worth
exploring.

My own quick comments:

- I'm not sure this should try seek to "answer the
  question whether protocols are political" as I don't
  believe that's as useful as just fairly describing
  various positions on the topic. Maybe, after we've
  gotten the describing bit properly done, we'd be able
  to seek an answer, but I'm not sure that's worthwhile.

- 3.3 basically reflects what'd be my starting position,
  but I don't agree that that position "requires that
  each protocol and use be evaluated" follows from that
  at all, at least not without a qualifier like "if you
  care about whether protocol-foo may be political..."

- I think Andrew is right that some definition of how
  the term politics is used in this draft is needed.
  Does it encompass internal "politics" amongst IETF
  participants? Does it encompass company-internal,
  and intra-company politics? I'm not sure if the
  authors intended to include those or not.

FWIW, I'd probably review a version of this in detail
later, if the RG decide to adopt a later revision of
this draft. As of now, I don't think it's baked enough
for the RG to decide to do that yet, but discussing it
seems useful, as the topic has come up a few times.

Cheers,
S.

---

From: Eliot Lear <[email-masked]>
Date: Tue, 4 Jul 2017 15:15:53 +0200

Hi,

It seems to me that the most interesting assertion in the draft is that
the IETF are not protocol police.  IMHO if the draft answered JUST that
question, it would be worthwhile publishing.  Certainly Gueren,
Dovrolis, et al, would say that it is nearly impossible to change the
waist of the hourglass.  North and south of that point provides a little
more room, but just try changing TLS or HTTP outside of the IETF. 
Nuttin doin.  At the same time, most phone/tablet apps bypass standards
organizations for pretty much any sort of development.  And oh by the
way, in that case, who cares about the protocol or standards development
since the endpoints are often coded by the same entity?  (And when there
is disagreement in that case, the word we seek is schizophrenia).  And
so perhaps the more refined question would be this: when is an SDO the
protocol police?

Eliot

On 7/4/17 1:22 PM, Stephen Farrell wrote:
> _______________________________________________
> hrpc mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hrpc

---

From: Niels ten Oever <[email-masked]>
Date: Thu, 6 Jul 2017 10:43:57 +0200

Hi Eliot,

> so perhaps the more refined question would be this: when is an SDO the

Should I conclude from this that you think that because the IETF does not have total control, it has no responsibilities whatsoever?

I think the IETF has responsibility over what it produces, and should think about what the (intended and unintended) consequences of that might be. Nothing more, but defintely also nothing less.

Best,

Niels

-- 

Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint	   2458 0B70 5C4A FD8A 9488  
                   643A 0ED8 3F3A 468A C8B3

---

From: Eliot Lear <[email-masked]>
Date: Thu, 6 Jul 2017 10:57:16 +0200

Hi Niels,

On 7/6/17 10:43 AM, Niels ten Oever wrote:
>> the IETF are not protocol police.  
>> [...]

Quite the opposite!  In the draft, you made an assertion, perhaps as an
aside, that the IETF are not protocol police, the inference being based
on our statements again and again that these are voluntary
community-driven standards.  My point is to question just how and when
they really are "voluntary" .  Indeed if we conclude that some standards
are LESS voluntary than we think they are, then we have commensurately
MORE responsibilities.  But the formulation of this concept of
"voluntary" should be well examined before we go too far down that line,
and this additional step would be a good day's work in and of itself.

Eliot

---

From: Niels ten Oever <[email-masked]>
Date: Thu, 13 Jul 2017 13:43:56 +0200

Hi Elliot,

This is a great point, and I somehow just accepted the assumption that
Internet standards are voluntary, but I think you are totally right.

I think this would be very interesting  to discuss in Prague in the
discussion of the draft. I'll add in a slide on this.

Cheers,

Niels

Niels ten Oever
Head of Digital

Article 19
www.article19.org