Subject: [hrpc] draft-tenoever-hrpc-unrequested-00

From: Stephen Farrell <[email-masked]>
Date: Sun, 22 Oct 2017 20:22:39 +0100

Hiya,

I had a read of this. I don't think it's in a state where
the RG ought adopt it. I'm not even sure it's worthwhile
to keep working on it, as is but there may be a reworking
of this that'd be good.

My main comment is: Who is this for?

The only audience I can envisage are folks (e.g. activists)
who'd otherwise maybe think that DDoS/spam are legitimate
vehicles for protest. If that is the target audience then
it ought be written for them. It currently is not and would
need a major re-write for that audience.

I could maybe see value in an RFC that did that.

Put another way, I don't think this text is convincing in
deriving it's correct conclusion, which seems to be what
it's attempting but failing to do now. I don't think an
RFC that attempts to derive a proof that DDoS-is-bad
would be a useful RFC. It might be a fine thing for some
other publication venue, who knows.

So I'd say either drop the idea of documenting this, (*) or,
if the above target audience is agreed, then do the major
re-write to set out the conclusion (incl. in the abstract)
and then explain why that is correct in terms the target
audience would understand.

S.

(*) It's ok to not pursue every idea, maybe this is one
such, not sure.

---

From: Niels ten Oever <[email-masked]>
Date: Mon, 23 Oct 2017 16:21:17 +0200

Hi Stephen,

> My main comment is: Who is this for?

The reasoning for writing this was following up on your request here:

https://youtu.be/4Cn0lcvWKFA

as to show that also if one includes human rights considerations, spam
and DDoS are still attacks.

Best,

Niels

> _______________________________________________
> hrpc mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hrpc
>

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 23 Oct 2017 15:32:49 +0100

Hiya,

> https://youtu.be/4Cn0lcvWKFA

I didn't watch all 90 mins again:-)

> and DDoS are still attacks.

So maybe I wasn't clear at the mic but what I
think could be useful is a document that tries
to explain that DDoS and spam are bad, written
for folks who might otherwise be liable to
assume there are valid uses of DDoS and spam
(e.g. for protest).

The current document seems to set out to prove
the propositions that DDoS and spam are bad, but
doesn't really try to explain the badness, in ways
that that readership might understand. (And I'm
not sure if the proof is there now, nor if it's
even necessary, but that's another day's work.)

Hence my comment that the readership for this is
maybe the critical thing that'll distinguish
whether or not it's worth working on this to make
it an HRPC RFC.

I don't see value in an RFC that aims to convince
IETF participants that DDoS or spam are bad. They
already know that, so there's no need.

Cheers,
S.

PS: I *think* that's what I meant to say at the
mic in Prague too, apologies if I was confused or
confusing:-)

---

From: Niels ten Oever <[email-masked]>
Date: Mon, 23 Oct 2017 17:03:52 +0200

> I didn't watch all 90 mins again:-)
I did :) wanted to send you the link with the right timecode:

https://youtu.be/4Cn0lcvWKFA?t=1h16m11s

> even necessary, but that's another day's work.)

I think I get this, so you don't think it is relevant for the IETF or
protocol developers to hear that also from the angle of human rights
considerations spam and DDoS are wrong because they already think its wrong?

AFAIK it is part of science to test assumptions also if you validate
them, right?

I thought it might be killing two birds with one stone:

1. Improve understanding of human rights considerations
2. Ensure that there is no misunderstanding on DDoS

But that might indeed be two audiences. I am not too convinced that many
activists read RFCs though.

Cheers,

Niels

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 23 Oct 2017 16:10:36 +0100

> https://youtu.be/4Cn0lcvWKFA?t=1h16m11s

Thanks. And phew - I've not contradicted myself
(this time:-).

> considerations spam and DDoS are wrong because they already think its wrong?

It may be relevant. But I don't think it's
worth the effort, no.

> AFAIK it is part of science to test assumptions also if you validate

Sure. But for example, a proof by induction
might be really useless for explaining things.

> activists read RFCs though.

That last is a fair point. I'd defer to others
as to that. (And if the conclusion is that it'd
not be read, then I'm fine for it not to be
written:-)

OTOH, we did have that debate as part of the
development of what'll soon be rfc8280.

Cheers,
S.