Subject: [hrpc] Chainiac and the problem of software supply-chain security and transparency

From: Bryan Ford <[email-masked]>
Date: Fri, 17 Nov 2017 11:48:51 +0800

Dear colleagues,

For those interested, here are the slides for the presentation we didn’t have time for at the end of the HRPC session, on the software supply-chain security and transparency problem, which I think is an increase:

	https://drive.google.com/a/epfl.ch/file/d/1dAOKd4-Wxn9Jfgglw0s9mkbP8tSSpOKS/view?usp=sharing <https://drive.google.com/a/epfl.ch/file/d/1dAOKd4-Wxn9Jfgglw0s9mkbP8tSSpOKS/view?usp=sharing>

…and here’s a pointer to our Chainiac paper and talk at USENIX Security ’17, which this is based on:

	https://www.usenix.org/conference/usenixsecurity17/technical-sessions/presentation/nikitin <https://www.usenix.org/conference/usenixsecurity17/technical-sessions/presentation/nikitin>

The main purpose was to raise awareness and try to start discussing some of the key challenges around this software supply-chain security issue, so I’ll try to make it to London, and in the meantime discussion on the mailing list or elsewhere is welcome.

Thanks
Bryan

---

From: Bob Harold <[email-masked]>
Date: Fri, 17 Nov 2017 09:14:44 -0500

On Thu, Nov 16, 2017 at 10:48 PM, Bryan Ford <[email-masked]> wrote:

> Dear colleagues,
>
> For those interested, here are the slides for the presentation we didn’t
> have time for at the end of the HRPC session, on the software supply-chain
> security and transparency problem, which I think is an increase:
>
> https://drive.google.com/a/epfl.ch/file/d/1dAOKd4-
> Wxn9Jfgglw0s9mkbP8tSSpOKS/view?usp=sharing
>
> https://www.usenix.org/conference/usenixsecurity17/technical-sessions/
> presentation/nikitin
>
> The main purpose was to raise awareness and try to start discussing some
> of the key challenges around this software supply-chain security issue, so
> I’ll try to make it to London, and in the meantime discussion on the
> mailing list or elsewhere is welcome.
>
> Thanks
> Bryan
>

First link (google doc) says "You need permission".

Second link (presentation) was interesting, thanks!

-- 
Bob Harold