Subject: Re: [http-extensions] Reconciling MAY/can vs. SHOULD (#101)

From: HTTP issue updates <[email-masked]>
Date: Sun, 01 Nov 2015 20:32:33 -0800

Discussed in Yokohama; seems reasonable.

---
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/101#issuecomment-152910314

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 01 Nov 2015 20:45:43 -0800

The "seems reasonable" applies to my comment, right?

---
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/101#issuecomment-152911379

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 04 Nov 2015 04:51:28 -0800

There are unfortunately 2 change request here, one of which I partly agree with, the other I disagree with.

The first one is caused by having normative language spread over 2.2 and 2.4; I tried to address this in https://github.com/httpwg/http-extensions/commit/acc3ae3c4290323069501d55ea8cdb5bacdbc6e8.

The second one is about adding a duplicate requirement; I continue to believe we shouldn't do that. We can mention requirements multiple times, but only one place should have the magic keyword (otherwise we risk ending up with exactly the kind of inconsistencies this pull request is about).

@MikeBishop are you ok with the change?

---
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/101#issuecomment-153712056