Subject: [http-extensions] Merge encryption (#128)

From: HTTP issue updates <[email-masked]>
Date: Tue, 22 Dec 2015 21:52:15 -0800

Need to check that this is OK first.
You can view, comment on, or merge this pull request online at:

  https://github.com/httpwg/http-extensions/pull/128

-- Commit Summary --

  * Initial commit
  * Initial version
  * 24825
  * Update
  * Update to show location of key
  * Noting manual maintenance options
  * Updating README
  * Adding panache
  * Travis speedup
  * Missing var
  * Updates based on testing
  * Fixing formatting
  * Fixing draft name selection
  * Sorting to get the right answer
  * Tweaks
  * Now supports drafts authored using outline.el (i.e. draft-*.org)
  * Fixed ordering issue found by Martin.
  * Merge pull request #2 from kwatsen/master
  * Adding rfcdiff
  * More toying with Makefile an diff cration.
  * Based on input from Martin.
  * Fixing intermediate handling
  * Adding update target
  * Permitting local changes to files
  * I don't like using if in Makefile shells
  * Getting revisions right
  * Removing ugly sed hack
  * Removing false error
  * Fixing ordering
  * Updating to include PDF
  * Updating README
  * Fixing variables on HTML
  * ignoring pdf
  * Fix make clean so it doesn't delete the source XML. Add a readme target, that copies the draft txt to README.md (after wrapping in backticks for formatting)
  * Merge pull request #7 from wkumari/master
  * Explaining tagging a little better.  Closes #8.
  * Removing dead text
  * Moving submission guidance to a new file.
  * Updating travis sync notes
  * setup-ghpages
  * Update docs
  * Fixes
  * Oops
  * Fixing travis error
  * Recommend virtualenv for pip
  * Merge pull request #9 from kuba/virtualenv
  * Beefing up installation instructions
  * Adding draft
  * Updating travis config
  * Rework intro
  * Rework format description
  * Correct error in derivation
  * Reflow
  * Fixup of grammar
  * Removing some errors
  * Update from upstream
  * Using idref db on github
  * Updating header field definitions
  * Properly qualify 'key' on each use
  * Being more precise about what message means
  * Some key management, not none
  * Editorial fixes
  * The last record size is smaller than rs+taglength
  * Padding is right 1-256, not 0-255
  * Removing confusion about the use of 'nonce'
  * CEK -> IKM as a constraint on salt uniqueness
  * At least 16 octets, not exactly
  * Scoping Encryption-Key
  * Lengths on examples were wrong
  * Reuse implications
  * Starting from a non-zero nonce
  * The hyphen must die
  * Adding record sizing note; s/byte/octet
  * ...when decoded
  * Merge pull request #3 from martinthomson/mattsson
  * Moving IANA considerations, fixing capitals
  * Updating JWE text
  * Updating references
  * Crediting John properly
  * s/key/aesgcm128/g
  * Fixing header definition
  * Cleanup
  * Setup repository for draft-thomson-http-encryption
  * Updating acknowledgments
  * Updating build setup
  * Adding fix for contributory behaviour; renaming Encryption-Key to Crypto-Key; fixing examples
  * Updating examples to include new label
  * Adding note about expanded context
  * Fixing ABNF declarations
  * Adding authentication secret section
  * Expanding the length of the IKM when derived from an authentication secret
  * Additional corrections/clarifications
  * Canonical encoding to octets of context
  * Merge pull request #5 from martinthomson/auth
  * Update template
  * Disallow duplicated values in the Encryption and Crypto-Key headers
  * Merge pull request #6 from beverloo/duplicated-values
  * Update SHA-256 ref
  * Fixing reference
  * Fixing X9.62 ref
  * Fixing template
  * Adding encrypted content encoding

-- File Changes --

    M .gitignore (5)
    M Makefile (11)
    M README.md (13)
    A draft-ietf-httpbis-encryption-encoding.md (840)

-- Patch Links --

https://github.com/httpwg/http-extensions/pull/128.patch
https://github.com/httpwg/http-extensions/pull/128.diff

---
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/128

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 29 Dec 2015 21:47:05 -0800

Merged #128.

---
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/128#event-502595186