Subject: Re: [httpwg/http-extensions] Advice for new parameters / headers (#227)

From: HTTP issue updates <[email-masked]>
Date: Fri, 02 Sep 2016 09:46:00 -0700

I disagree with the proposed change; in particular for header fields that already use this syntax.

We could make a recommendation for new header fields, but what you propose is yet another new format, so I just do not see the benefit over that we have right now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/227#issuecomment-244427628

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 04 Sep 2016 23:13:21 -0700

We could give an example, e.g., percent-encoding over utf-8 (which is already specified elsewhere).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/227#issuecomment-244665866

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 04 Sep 2016 23:52:37 -0700

A format that has a single mode *and* supports non-ASCII (over HTTP/1.1) will need an escape character (such as %). This is a new format (if we don't count the Slug header field in atompub). It also means that senders always will have to escape (so that "%" isn't ambiguous).

Yes, we can specify that somewhere, but until we do so we can't recommend something like that. At the end of the day it's not clear to me at all whether yet another format improves the situation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/227#issuecomment-244670759