Subject: Re: [httpwg/http-extensions] Digest algorithm (#228)

From: HTTP issue updates <[email-masked]>
Date: Tue, 27 Sep 2016 21:49:14 -0700

xxHash seems good, but see https://github.com/Cyan4973/xxHash/issues/49.

Likewise, the other ones mentioned there are also defined by their source.

I think our options are:

1. Specify one of these as a normative reference and hope we can get that through the process (not likely)
2. Write the spec for one of these (ouch)
3. Wait for someone else to write the spec for one of these (may be some time)
4. Continue using a specified algorithm. 

I'm kind of leaning towards (4), possibly leaving extensibility for other hash algorithms (although, as discussed before, it's not clear how we'd negotiate for that; maybe #22 could help).

Thoughts?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/228#issuecomment-250070867

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 27 Sep 2016 23:42:11 -0700

Don't know what the relevance of #22 is.

I would say that this seems like a good basis for 2: https://github.com/aappleby/smhasher/wiki/MurmurHash3  These are necessarily very simple programs to specify.  A draft shouldn't be hard to write if that's necessary.  Of course, I'm lazy just like you.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/228#issuecomment-250084836

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 27 Sep 2016 23:44:27 -0700

Sorry, #229.

I take it you're volunteering, then...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/228#issuecomment-250085146

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 28 Sep 2016 00:02:25 -0700

"Internet-Draft seeks editor, must like long walks on the beach, sunsets and have poor impulse control."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/228#issuecomment-250087947