Subject: Re: [httpwg/http-extensions] Dictionary parsing - trailing comma (#479)

From: HTTP issue updates <[email-masked]>
Date: Sun, 04 Feb 2018 02:34:11 +0000 (UTC)

The ABNF doesn't allow it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/479#issuecomment-362875382

---

From: HTTP issue updates <[email-masked]>
Date: Sat, 03 Feb 2018 18:38:25 -0800

Could just change "2. While input_string is not empty:" to "2. In a loop:"

I think that also makes steps 3 and 4 unreachable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/479#issuecomment-362875528

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 04 Feb 2018 14:54:12 -0800

My plan was to add a step at the bottom of the loop "if input_string is empty, fail parsing."

Question is whether we want to be tolerant of trailing commas. Based upon the approach we seem to be taking elsewhere, I think we probably don't want to be. That means that this would fail:

> FooHeader: bar,baz,

... and this would as well:

> FooHeader: bar, baz
> FooHeader:

I think I'm comfortable with that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/479#issuecomment-362947439

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 04 Feb 2018 23:18:33 -0800

+1

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/479#issuecomment-363000379

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 05 Feb 2018 07:21:29 +0000 (UTC)

(The ticket talks about dictionaries, but you're talking about lists. The same rule/fix should apply to both.) 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/479#issuecomment-363000842

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 15 Feb 2018 19:15:18 -0800

Closed #479 via 3ed28941cb4a8ecc6be4e9e08c579220b6a23046.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/479#event-1477208296