Subject: Re: [httpwg/http-extensions] binary content, non-paddability (#495)

From: HTTP issue updates <[email-masked]>
Date: Sun, 18 Feb 2018 13:36:57 -0800

It's from when there wasn't a final delimiter. I think you're right; we should accept  `=`. I *think* we should also accept without.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/495#issuecomment-366550008

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 19 Feb 2018 09:33:00 +0000 (UTC)

I think we should just rely on whatever the B64 rfc says, without inventing anything new.  (Postel Was Wrong and all that.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/495#issuecomment-366633660

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 19 Feb 2018 23:21:06 +0000 (UTC)

It says:

> Implementations MUST include appropriate pad characters at the end of encoded data unless the specification referring to this document explicitly states otherwise.

I think we want to make it easy to conform to whatever we require with shipping implementations of base64. Spot-checking Python and Node, it seems like Python enforces the requirement, whereas Node does not. 

Given that, it seems like the sensible thing to do is to require the padding to be produced with a MUST, but only require parsers to reject content without padding as a SHOULD.

See also #473.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/495#issuecomment-366825362

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 22 Feb 2018 00:13:32 -0800

WFM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/495#issuecomment-367599837

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 22 Feb 2018 08:20:24 +0000 (UTC)

Closed #495.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/495#event-1486397030