Subject: Re: [httpwg/http-extensions] Number algorithm (#475)

From: HTTP issue updates <[email-masked]>
Date: Sun, 04 Feb 2018 02:49:01 +0000 (UTC)

Could be related to #479 (the higher-order issue being that algorithms and ABNF aren't exactly 1:1), in which case it's probably part of #477.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/475#issuecomment-362875910

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 16 Feb 2018 03:11:43 +0000 (UTC)

I just meant that what's there is only a sketch :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/475#issuecomment-366133344

---

From: HTTP issue updates <[email-masked]>
Date: Thu, 15 Feb 2018 20:32:46 -0800

Just call me the problem dwarf.  (I dig too deep.)

Integer is a weird one, though.  The ABNF limits input to 19 characters (plus hyphen), the prose restricts output values, and the algorithm glosses the actual transformation of characters to value.  So the authoritative specification is all over the place.

Do you have to choose which part is more authoritativer (#477) before you can work out how to flesh out the sketch?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/475#issuecomment-366141686

---

From: HTTP issue updates <[email-masked]>
Date: Sat, 17 Feb 2018 21:34:55 +0000 (UTC)

Both integer and float ABNF allows leading zeros.  Do we want that ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/475#issuecomment-366473121

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 18 Feb 2018 21:37:19 +0000 (UTC)

Probably not.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/475#issuecomment-366550050