Subject: Re: [httpwg/http-extensions] Added description of caching limitations for Range-less shift-buffer requests (#506)

From: HTTP issue updates <[email-masked]>
Date: Mon, 12 Mar 2018 10:49:05 +0000 (UTC)

martinthomson commented on this pull request.

> @@ -463,6 +464,16 @@ Content-Range: bytes 1020000-1254567/*
       <t>
         from the server to indicate that the response will start at byte 1020000, end at byte 1254567, and will not include any aggregated content. This is the response expected from a typical HTTP server - one that doesn't support byte-range requests on aggregating content.
       </t>
+      <t>
+          Note that responses to GET requests against shift-buffer representations using Range 
+          can be cached by intermediaries, since the Content-Range response header indicates 
+          which portion of the representation is being returned in the response body. However 
+          GET requests without a Range header cannot be cached since the first byte of the response 

either that or the resource provided might be identified differently

that is, if the start of `/live` moves by 10M, then you might redirect to `/live+10M`, all assuming that the redirect works (content-location isn't especially nice for this because it isn't any more cacheable

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/506#pullrequestreview-102993570

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 12 Mar 2018 17:20:51 -0700

craigpratt commented on this pull request.

       <t>

Interesting idea @martinthomson. I'll see if I can reword to not preclude this option.

So guess I need to sprinkle in "successful responses" on both of these sentences and maybe include redirect as an example.

I'll revise tonight. Thx!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/506#discussion_r173985798

---

From: HTTP issue updates <[email-masked]>
Date: Sun, 18 Mar 2018 08:37:48 +0000 (UTC)

@craigpratt pushed 1 commit.

7a01a2b  Added an alternate to handling range-less get requests by disabling caching

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/506/files/64cf7c9349c9545b5805f7067f51a4d99610d2d5..7a01a2b1832db31be13c94721ef3ee0a94c422c6

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 19 Mar 2018 12:24:10 -0700

e550f15  Replaced a "buffered" with a "cached"

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/httpwg/http-extensions/pull/506/files/7a01a2b1832db31be13c94721ef3ee0a94c422c6..e550f15a7f45ae2f7937856ceb5c16a599a6865a

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 19 Mar 2018 12:34:58 -0700

Merged #506.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/pull/506#event-1529348287