Subject: Re: [httpwg/http-extensions] "_" is invalid in ABNF rule names, also: rule names are case-insensitive (#520)

From: HTTP issue updates <[email-masked]>
Date: Sun, 18 Mar 2018 07:48:33 -0700

FWIW, the ABNF below would work:

~~~

dictionary        = dictionary-member 0*1023( OWS "," OWS dictionary-member )
dictionary-member = identifier "=" item

list = list-member 0*1023( OWS "," OWS list-member )
list-member = item

param-list = param-id 0*255( OWS "," OWS param-id )
param-id   = identifier 0*256( OWS ";" OWS identifier [ "=" item ] )

item = integer / float / string / identifier / binary

integer   = ["-"] 1*19DIGIT

float    = ["-"] (
             DIGIT "." 1*14DIGIT /
            2DIGIT "." 1*13DIGIT /
            3DIGIT "." 1*12DIGIT /
            4DIGIT "." 1*11DIGIT /
            5DIGIT "." 1*10DIGIT /
            6DIGIT "." 1*9DIGIT /
            7DIGIT "." 1*8DIGIT /
            8DIGIT "." 1*7DIGIT /
            9DIGIT "." 1*6DIGIT /
           10DIGIT "." 1*5DIGIT /
           11DIGIT "." 1*4DIGIT /
           12DIGIT "." 1*3DIGIT /
           13DIGIT "." 1*2DIGIT /
           14DIGIT "." 1DIGIT )

string    = DQUOTE 0*1024(character) DQUOTE
character = unescaped / escape ( DQUOTE / "\" )
unescaped = %x20-21 / %x23-5B / %x5D-7E
escape    = "\"

identifier = lcalpha 0*255( lcalpha / DIGIT / "_" / "-"/ "*" / "/" )
lcalpha    = %x61-7A ; a-z

binary = "*" 0*21846(base64) "*"
base64 = ALPHA / DIGIT / "+" / "/" / "="
~~~

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/520#issuecomment-374005126

---

From: HTTP issue updates <[email-masked]>
Date: Mon, 26 Mar 2018 20:07:02 -0700

Closed #520.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/520#event-1542274068