Subject: Re: [httpwg/http-extensions] If you have multiple connections (#523)

From: HTTP issue updates <[email-masked]>
Date: Tue, 20 Mar 2018 09:58:24 -0700

Draft currently says:

> As a result, clients MUST NOT assume that because one origin was previously colocated with another, those origins will be reachable via the same endpoints in the future. Clients MUST NOT consider previous secondary certificates to be validated after TLS session resumption. However, clients MAY proactively query for previously-presented secondary certificates.

While that was originally talking about future session resumption, I think it's equally applicable to parallel connections.  The only certificate that applies to a connection when it begins is the one proven in TLS.  Anything else has to be bound to that specific connection.  You can remember interesting things you want to send a request for, but you can't assume.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/523#issuecomment-374675329

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 20 Mar 2018 17:17:18 +0000 (UTC)

Closed #523.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/523#event-1531497132

---

From: HTTP issue updates <[email-masked]>
Date: Tue, 20 Mar 2018 17:17:17 +0000 (UTC)

Ahh yes, that seems totally adequate (I was just trying to capture concerns that I heard during the meeting).  Closing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/523#issuecomment-374682134