Subject: Re: [httpwg/http-extensions] CONNECT: consider using ALPN registry for the :protocol values. (#471)

From: HTTP issue updates <[email-masked]>
Date: Wed, 21 Mar 2018 11:07:18 +0000 (UTC)

discussed in london/101 and decided to not make a change

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/471#issuecomment-374902013

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 21 Mar 2018 04:07:18 -0700

Closed #471.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/471#event-1532941656

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 23 Mar 2018 03:05:50 +0000 (UTC)

Sounds good, thanks for bringing this up to the forum!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/471#issuecomment-375529321

---

From: HTTP issue updates <[email-masked]>
Date: Fri, 23 Mar 2018 03:15:48 +0000 (UTC)

Though, reading [IETF101 meeting notes](https://github.com/httpwg/wg-materials/blob/gh-pages/ietf101/minutes.md#bootstrapping-websockets) (sorry for missing it!), it seems that discussion was around using ALPN for negotiating WebSocket-over-HTTP/2 and not about `:protocol` values.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/471#issuecomment-375531004

---

From: HTTP issue updates <[email-masked]>
Date: Sat, 24 Mar 2018 17:14:37 +0000 (UTC)

@PiotrSikora, those are the same topic.  The `:protocol` extension to CONNECT was defined for the primary purpose of using WebSockets over an HTTP/2 stream; it just happens to be a general-purpose mechanism we can use for other things too.  And I think the Upgrade registry, being an existing registry which contains protocols that HTTP can upgrade to is probably the right choice when defining a new sort of upgrade within HTTP.

However, if we were redefining the Upgrade registry now, I'd argue for using the ALPN registry for both of these.  Fundamentally, they are both registries of tokens which identify an application-layer protocol which can run over a bytestream.  (Or collection of bytestreams, when used with QUIC.)  The only real restriction is that Upgrade requires that the protocol be able to answer the original HTTP request in the new protocol, which means there has to be a defined mapping between HTTP requests and whatever the new protocol is.

The currently-registered values are disjoint, but I wonder if perhaps HTTPter should consider merging the two registries?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/471#issuecomment-375909211