Subject: Re: [httpwg/http-extensions] structured-headers: Has JSON been considered? (#538)

From: HTTP issue updates <[email-masked]>
Date: Wed, 28 Mar 2018 05:56:54 +0000 (UTC)

Yes - there's a long history behind that, and we originally had a JSON-based approach.

Besides the reason you mention, there was a lot of discomfort around the imprecision of numbers in JSON, and also about enabling arbitrary nesting of data structures.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/538#issuecomment-376770575

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 28 Mar 2018 05:56:55 +0000 (UTC)

Closed #538.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/538#event-1544796143

---

From: HTTP issue updates <[email-masked]>
Date: Wed, 28 Mar 2018 05:58:10 +0000 (UTC)

Thanks for the feedback. I'm gonna try to dig into the discussions

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/httpwg/http-extensions/issues/538#issuecomment-376770780