Subject: [httpapi] Meeting minutes

From: Mark Nottingham <[email-masked]>
Date: Thu, 26 Nov 2020 11:27:10 +1100

I've put the cleaned-up minutes at:
  https://github.com/ietf-wg-httpapi/wg-materials/blob/main/ietf109/minutes.md

If you have any corrections or additions, please send them (e-mail or pull request) soon.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 26 Nov 2020 14:30:27 +0000

Uploaded to datatracker.  Thanks Bron, and Mark.

---

From: Erik Wilde <[email-masked]>
Date: Mon, 30 Nov 2020 17:27:13 -0800

hello.

> If you have any corrections or additions, please send them (e-mail or pull request) soon.

thanks for taking the notes, mark.

i have a question about the process. from the notes (and the discussion) 
it seems that "a call for adoption" is going to be issued for all 
presented drafts. i would be interested to move forward with this 
process, but i am not sure how it works.

should i write emails to the list (ideally separately for the separate 
drafts i presented, i assume), or is somebody else going to do that? if 
the latter, can i help with anything so that these calls get sent better 
sooner than later?

thanks a lot and cheers,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 1 Dec 2020 01:37:01 +0000

The formal description of the workflow is at https://www.rfc-editor.org/info/rfc2026

A call for adoption means that the WG members want to work on the document. New drafts are often presented at the IETF meetings (like we just had), and then we poll the room to see if there's interest. The official process is that everyone done virtual or at F2F meetings must be confirmed on the mailing list.  Per the minutes:
	Rate Limit Headers will be confirmed on the mailing list
	Deprecation header will be confirmed on the mailing list
	Linkset has concerns about duplication of efforts, but we'll discuss adoption on the mailing list
	Content-Warning doesn't seem ready for adoption quite yet

*Any draft can be discussed on the list, especially for purposes of getting enthusiasm, comments, etc.*

Once a draft is adopted, copyright is now owned by the IETF trust. WG chairs have the power to appoint document authors.  Original authors are usually chosen, although others may be added or shift as time passes.

We're waiting a bit for the GitHub config to be 'done' (it's close, if not already there). Our plan will be to create a repository in https://github.com/ietf-wg-httpapi, one repo per document.  The repo and document names should be like ietf-httpapi-XXXX, like ietf-httpapi-ratelimit-headers, etc.

Hope this helps.
	/r$

---

From: Erik Wilde <[email-masked]>
Date: Mon, 30 Nov 2020 18:21:35 -0800

hello all.

looking at @mnot's notes i realize that i still owe a response to alexey 
melnikov, who was asking about the CoRE link format as defined by 
https://tools.ietf.org/html/rfc6690#section-2

we did look into it when this was brought up a while ago, and here's a 
comment by my co-author made when this issue was brought up:

https://github.com/dret/I-D/issues/120#issuecomment-516785695

the short version is: CoRE links have a different serialization than the 
header field, and CoRE adds additional parameters into the mix.

i hope this explains the differences that i did not recall when this was 
brought up during my presentation at the IETF 109 meeting.

thanks a lot and cheers,

dret.