Subject: [httpapi] Getting ready for our first meeting at IETF 109

From: "Salz, Rich" <[email-masked]>
Date: Thu, 12 Nov 2020 15:56:28 +0000

Welcome to the HTTP-API working group!

This is an IETF Working Group (WG) that operates under the IETF rules. If you are familiar with them, skip to the next paragraph. A good overview of how a WG works can be found at https://www.ietf.org/about/participate/tao/#wgs  The IETF operates under a set of rules called the "Note Well" which can be found at https://www.ietf.org/about/note-well/  That basically says "no hidden patents" and "treat everyone respectfully." The official WG "home" is at https://datatracker.ietf.org/wg/httpapi and that will have links (under the meetings or documents tab) to most of the useful stuff.

We have a charter which identifies our scope of work. It is at https://datatracker.ietf.org/doc/charter-ietf-httpapi/  It's worth reviewing.

The agenda has been uploaded and is at https://datatracker.ietf.org/meeting/109/materials/agenda-109-httpapi-00  Note that the first item of business will be: to what extent (if any) do we want to conduct business on GitHub?  There was a WG that came up with several modes of operation; please see https://www.rfc-editor.org/rfc/rfc8874.html  Other valid responses include "all in, like QUIC" or "partial like TLS"

If anyone is interested in helping take minutes or being the Jabber scribe, please post. If you are not familiar with the videoconf tool the IETF uses, take a look at https://www.ietf.org/media/documents/IETF109-Meetecho_Documentation.pdf

At the meeting we'll review some candidate documents and make preliminary decisions about which one(s) to adopt. Other documents can also be brought up on the mailing list. The chairs will probably solicit submissions to cover other items in our charter if there's no candidates.

---

From: Roberto Polli <[email-masked]>
Date: Thu, 12 Nov 2020 17:16:52 +0100

Hi Rich + all,

Il giorno gio 12 nov 2020 alle ore 16:56 Salz, Rich
<rsalz=[email-masked]> ha scritto:
> The agenda [...] is at https://datatracker.ietf.org/meeting/109/materials/agenda-109-httpapi-00
Ok!

> to what extent (if any) do we want to conduct business on GitHub?
> There was a WG that came up with several modes of operation; please see https://www.rfc-editor.org/rfc/rfc8874.html
> Other valid responses include "all in, like QUIC" or "partial like TLS"
All in, like QUIC :)

It would be great to prepare a gh-repo like
https://github.com/httpwg/wg-materials/ beforehand.
I'm willing to help on that if you like!

Kind regards,
R

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 12 Nov 2020 17:04:11 +0000

>    It would be great to prepare a gh-repo like

We have ietf-wg-httpapi organization and we can create repo's like wg-materials, one per draft, etc., if that's the way the WG wants to go.

---

From: Roberto Polli <[email-masked]>
Date: Tue, 17 Nov 2020 15:50:50 +0100

Hi Rich + all,

Il giorno gio 12 nov 2020 alle ore 18:04 Salz, Rich <[email-masked]>
ha scritto:
> We have ietf-wg-httpapi organization and .
it's great to have https://github.com/ietf-wg-httpapi !

> we can create repo's like wg-materials, one per draft, etc., if that's the way the WG wants to go
I'd like to ask the other folks if they agree on the use of github: in that case
we could create a wg-material repo to store the presentations other
than link the I-Ds
(today, I struggled during some IETF sessions and having the slides
beforehand could have helped).

Here's a **mock** agenda file adapted from the httpwg one: slides & co
could be uploaded
to the repo beforehand so that interested folks can get ready for the meeting.

Kind Regards,
R

---

From: Roberto Polli <[email-masked]>
Date: Tue, 17 Nov 2020 16:30:11 +0100

I forgot the link :)

> to the repo beforehand so that interested folks can get ready for the meeting.

(the mock agenda)

https://gist.github.com/ioggstream/0bba431c4966f9bada70143675a80475

---

From: Darrel Miller <[email-masked]>
Date: Tue, 17 Nov 2020 16:15:41 +0000

Hi Roberto,

I am in favour of using GitHub for working group materials,  but discussing that is one of the first items on the agenda.  Does anyone have any objections or concerns about pre-emptively putting content on GitHub in advance of the meeting with the caveat that the plan may change?

Darrel

From: Roberto Polli<mailto:[email-masked]>
Sent: November 17, 2020 10:31 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [httpapi] Getting ready for our first meeting at IETF 109

I forgot the link :)

(the mock agenda)

https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgist.github.com%2Fioggstream%2F0bba431c4966f9bada70143675a80475&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7Cd4ebeea6a16e4ef550d808d88b0db745%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C637412238771268628%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=IQM8SM6d9L1TBSOZqwFNBQBfbqMzt9XqLRwT7gkoDto%3D&amp;reserved=0

--
httpapi mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fhttpapi&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7Cd4ebeea6a16e4ef550d808d88b0db745%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C637412238771268628%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=Az0UEe6tJwrHvnajqr%2BHex7FCDWWHf8fd6qsB830n1k%3D&amp;reserved=0

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 17 Nov 2020 17:16:48 +0000

Thanks for showing examples.

We're going to follow IETF practice, chat for a few minutes in person and then confirm consensus on the mailing list.  But there's no need to stop discussing now.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 17 Nov 2020 17:21:49 +0000

> Does anyone have any objections or concerns about pre-emptively putting content on GitHub in advance of the meeting with the caveat that the plan may change?

I do.