Subject: [httpapi] Associating the old draft-xxx and the new draft-ietf on datatracker

From: Roberto Polli <[email-masked]>
Date: Sat, 19 Dec 2020 16:38:48 +0100

Hi @ all,

it would be great if datatracker shows the evolution of  the previous
draft-polli-ratelimit-headers-xx
and the new  draft-ietf-httpapi-ratelimit-headers so that implementers
can follow
the new stream. How can I associate them?

Kind regards,
R.

---

From: Erik Wilde <[email-masked]>
Date: Sat, 19 Dec 2020 09:10:33 -0800

hello roberto.

> the new stream. How can I associate them?

there's an option when you submit where you can state which existing draft the new one is replacing. this will associate the drafts in the datatracker. but i am not sure whether you can do it retroactively. 

cheers,

dret.

---

From: Mike Bishop <[email-masked]>
Date: Sat, 19 Dec 2020 17:31:58 +0000

When you submit the 00 version, I believe there's a field for the draft it replaces. It you can't find it or forget, you can also email and they can add the association manually. Doesn't get added by CI, though so you need the manual route if you have CI submit the first draft.

Sent from Nine<http://www.9folders.com/>

________________________________
From: Roberto Polli <[email-masked]>
Sent: Saturday, December 19, 2020 10:39 AM
To: [email-masked]
Subject: [httpapi] Associating the old draft-xxx and the new draft-ietf on datatracker

Hi @ all,

Kind regards,
R.

--
httpapi mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/httpapi

---

From: Roberto Polli <[email-masked]>
Date: Sat, 19 Dec 2020 21:58:15 +0100

Thanks Erik and Mike,

I submitted from CI... Lazy me!

I'll write to
[email-masked] hoping they can fix it.

Thanks again folks,
R

Il sab 19 dic 2020, 18:32 Mike Bishop <[email-masked]> ha scritto:

> When you submit the 00 version, I believe there's a field for the draft it
> replaces. It you can't find it or forget, you can also email and they can
> add the association manually. Doesn't get added by CI, though so you need
> the manual route if you have CI submit the first draft.
>
> Sent from Nine <http://www.9folders.com/>
>
> ------------------------------
> *From:* Roberto Polli <[email-masked]>
> *Sent:* Saturday, December 19, 2020 10:39 AM
> *To:* [email-masked]
> *Subject:* [httpapi] Associating the old draft-xxx and the new draft-ietf
> on datatracker
>
> Hi @ all,
>

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 19 Dec 2020 23:56:15 +0000

> but i am not sure whether you can do it retroactively. 

The easiest thing to do might be to checkin each older draft into the GitHub repo.

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 20 Dec 2020 14:08:02 +0000

>> but i am not sure whether you can do it retroactively.
It is possible to do this retroactively. WG Chairs can certainly do that 
and maybe even editors.

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 20 Dec 2020 16:21:04 +0000

and maybe even editors.

I think it's important that the draft adopted by the WG starts with the one that was adopted, as it were. :)

You could submit 'n' individual drafts, as in draft-polli-ratelimit, in order, each one replacing the previous.  Then the last one will be transferred to the WG.