Subject: [httpapi] Scope of deprecation header

From: Darrel Miller <[email-masked]>
Date: Thu, 3 Dec 2020 02:07:39 +0000

Erik,

There are some issues that I would like to clarify with the current draft.

In the introduction of the document, the following statement is made.

  *   It just informs client of the fact that a resource is deprecated.
https://tools.ietf.org/html/draft-dalal-deprecation-header-00#section-1

In the documentation, there is further qualification,

Ø  For a resource, deprecation could involve one or more parts of

  *   request, response or both.
https://tools.ietf.org/html/draft-dalal-deprecation-header-00#section-3.1

There is then a list of potential partial deprecations, including methods, headers and request or response body elements.

By introducing the possibility of signalling the deprecation of some element of the overall HTTP interaction, it seems to be in conflict with the original statement that says a “resource is deprecated”.  It also introduces other conflicts such as not allowing multiple deprecation headers.  If deprecation can be partial, wouldn’t it be likely there would be multiple deprecations for a single resource?

The Sunset header is more explicit about the granularity of impact.  RFC 8594 describes the impact of the sunset header,

Ø  indicates that a URI is likely to become unresponsive at a

Ø     specified point in the future
https://tools.ietf.org/html/rfc8594

Is it intended that there be different granularity for the deprecated header vs sunset header?

Darrel

---

From: Erik Wilde <[email-masked]>
Date: Wed, 2 Dec 2020 20:30:15 -0800

hello darrel.

just as a quick note, while i am thinking about an actual response to 
your question...

> https://tools.ietf.org/html/draft-dalal-deprecation-header-00#section-3.1

please use version 3 when reading/quoting the draft.

https://tools.ietf.org/html/draft-dalal-deprecation-header-03

but in this case it doesn't matter as the parts that you are referring 
to also exist in version 3. i'll come back with a response very soon.

cheers,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |