Subject: [httpapi] Requesting adoption for REST API Mediatypes: application/yaml & co

From: Roberto Polli <[email-masked]>
Date: Wed, 1 Dec 2021 13:17:33 +0100

Dear all,

some time ago I created this draft
https://datatracker.ietf.org/doc/draft-polli-rest-api-mediatypes/
to register the following media-types:
   "text/yaml", "application/yaml", "application/openapi+json" and
   "application/openapi+yaml".

This is a very long standing issue...

Do you think  the httpapi wg can be interested in adopting this draft?
Have a nice day,
R.

---

From: Darrel Miller <[email-masked]>
Date: Wed, 1 Dec 2021 14:56:01 +0000

If this draft would facilitate registering these formats in the non-vendor subtree, I would definitely be supportive of this draft.   There is also now a non-GitHub URL for the OpenAPI specification https://spec.openapis.org/oas/v3.1.0

Darrel

-----Original Message-----
From: Roberto Polli <[email-masked]> 
Sent: December 1, 2021 7:18 AM
To: Salz, Rich <[email-masked]>; Darrel Miller <[email-masked]>
Cc: [email-masked]
Subject: Requesting adoption for REST API Mediatypes: application/yaml & co

Dear all,

https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-polli-rest-api-mediatypes%2F&amp;data=04%7C01%7CDarrel.Miller%40microsoft.com%7Cde6a22f6cb3241c6d0a608d9b4c49478%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637739578671934025%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=QU%2FXIiurlr3Sw3qMd0SM%2B7SfINzp6O%2Fget8es1Q7Z9o%3D&amp;reserved=0

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 1 Dec 2021 15:55:12 +0000

> https://datatracker.ietf.org/doc/draft-polli-rest-api-mediatypes/

This seems like a fairly easy thing to do and fills a gap.  I just started a formal call for adoption.  If anyone has issues with us adopting this, please speak up within two weeks.  Thank you.

---

From: Jason Desrosiers <[email-masked]>
Date: Wed, 1 Dec 2021 08:53:06 -0800

We've been discussing a similar effort to register application/schema+json
for JSON Schema. Would we be able to piggyback onto this draft?

On Wed, Dec 1, 2021 at 7:56 AM Salz, Rich <rsalz=[email-masked]>
wrote:

> This seems like a fairly easy thing to do and fills a gap.  I just started
> a formal call for adoption.  If anyone has issues with us adopting this,
> please speak up within two weeks.  Thank you.
>
> --
> httpapi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/httpapi
>

---

From: Roberto Polli <[email-masked]>
Date: Wed, 1 Dec 2021 20:25:38 +0100

Hi Jason,

I'd be really happy to do it!

Once adopted, the document can still be extended with the support of the
workgroup.

Have a nice day,
R

Il mer 1 dic 2021, 17:53 Jason Desrosiers <[email-masked]> ha scritto:

> On Wed, Dec 1, 2021 at 7:56 AM Salz, Rich <rsalz=
> [email-masked]> wrote:
>
>> This seems like a fairly easy thing to do and fills a gap.  I just
>> started a formal call for adoption.  If anyone has issues with us adopting
>> this, please speak up within two weeks.  Thank you.
>>
>> --
>> httpapi mailing list
>> [email-masked]

---

From: Roberto Polli <[email-masked]>
Date: Wed, 22 Dec 2021 16:54:48 +0100

Hi Rich,

any news on this draft's adoption?

Have a nice day and thanks for everything,
R.

Il giorno mer 1 dic 2021 alle ore 16:56 Salz, Rich <[email-masked]> ha

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 23 Dec 2021 15:07:32 +0000

Thanks for the reminder.  I found it in my Christmas stocking, hidden by the big lump of coal.

Please submit draft-ietf-httpapi-rest-api-mediatypes when you can.  Thanks!